Проблема с Wia.devicemanager в Висте

Тема в разделе "Visual Basic", создана пользователем gorlanovmax, 9 ноя 2009.

  1. gorlanovmax

    gorlanovmax Well-Known Member
    1C Team

    Регистрация:
    19 июн 2008
    Сообщения:
    286
    Симпатии:
    0
    Суть такова:

    Пишу код в 1С 7.7 (почти тот же VB)

    Код (Text):
    Перем ИмяФайла, oDevice[5];

    ИмяФайла=КаталогИБ()+"Sotrudnik\123.jpg";

    Процедура СделатьФото()
    Device=CreateObject("WIA.DeviceManager");
    Колво = Device.DeviceInfos.Count;
    Для Кол=1 По Колво Цикл
    Если Device.DeviceInfos(Кол).Type=3 Тогда
    Попытка
    oDevice[Кол]=Device/DeviceInfos(Кол).Connect();
    Исключение
    oDevice[Кол]=0;
    КонецПопытки;
    Иначе
    oDevice[Кол]=0;
    КонецЕсли;
    КонецЦикла;

    Для Кол=1 По Колво Цикл
    Если oDevice[Кол] <> 0 Тогда
    Item=oDevice[Кол].ExecuteCommand("{AF933CAC-ACAD-11D2-A093-00C04F72DC3C}");
    Image=Item.Transfer("{557CF401-1A04-11D3-9A73-0000F81EF32E}");
    Image.SaveFile(ИмяФайла);
    КонецЕсли;
    КонецЦикла
    КонецПроцедуры
    Вся проблема в том, что на ХР все работает нормально, но если я пробую получить снимок на Висте, то сталкиваюсь со следующей проблемой:

    Количество устройств WIA равно нулю, т.е. Device.DeviceInfos.Count=0, хотя камера в системе установлена.

    Заметил еще одну интересную вещь:
    В ХР когда камера установлена, открываю "МойКомпьютер" и вижу камеру, открываю ее и вижу видео с камеры. В висте камера установлена, но значка камеры в проводнике нет. (В списке оборудования камера присутствует)

    В чем может быть проблема???
    Как получить снимок на Висте???
     
Загрузка...
Похожие Темы - Проблема Wia devicemanager
  1. gorlanovmax
    Ответов:
    3
    Просмотров:
    9.174
  2. AgniXRudra
    Ответов:
    1
    Просмотров:
    39
  3. Zloikaktus
    Ответов:
    0
    Просмотров:
    27
  4. c0de3r
    Ответов:
    5
    Просмотров:
    151
  5. DobermannTT
    Ответов:
    10
    Просмотров:
    157

Поделиться этой страницей