Проблемы с открытием базы

Тема в разделе "Lotus - Программирование", создана пользователем spartanec, 1 окт 2010.

Статус темы:
Закрыта.
  1. spartanec

    spartanec Гость

    Создал в базе фреймсет который запускается только для роли админ. все нормально работает, только одна байда - перед открытием даного фрейма админом открывается в отдельной закладке (странице) дефолтный фрейсет с неким представлением вместе - тоесть открывается сразу 2 закладки в клиенте. В Database Script все правильно - меняю этот Фреймсет на любой навигатор - открывается одна закладка Не знаю где уже и ковырять
     
  2. morpheus

    morpheus скриптописец

    Регистрация:
    7 авг 2006
    Сообщения:
    3.927
    Симпатии:
    0
    а галочка открыть последний вид для юзера случаем не стоит?
     
  3. spartanec

    spartanec Гость

  4. morpheus

    morpheus скриптописец

    Регистрация:
    7 авг 2006
    Сообщения:
    3.927
    Симпатии:
    0
    проверте , как поведёт себя база если снять галочку?
     
  5. spartanec

    spartanec Гость

    Снял галочку (в запуске базы стоит запускать фреймсет админ) - теперь для админа все ок - запускается одна вкладка с фреймом. Ставлю себе роль юзера - обратная херня - 2 вкладки: первая з адми фреймом (неактивная) и вторая з навигатором предназначены даному юзеру - активная.
     
  6. spartanec

    spartanec Гость

    Вобщем почему закладка вылази я хер разобрался. Решил проблему в скрипте базы в PostOpen формулой закрываю вид который открывается в закладке (первый шаровый)
     
Загрузка...
Похожие Темы - Проблемы открытием базы
  1. aliaksandr89
    Ответов:
    3
    Просмотров:
    123
  2. Amfion
    Ответов:
    5
    Просмотров:
    120
  3. wowa
    Ответов:
    7
    Просмотров:
    378
  4. John_Tavarez
    Ответов:
    0
    Просмотров:
    335
  5. Валентин Амбер
    Ответов:
    11
    Просмотров:
    344
Статус темы:
Закрыта.

Поделиться этой страницей