Проблемы с запросом! 7.7

  • Автор темы MadDog
  • Дата начала
M

MadDog

#1
Добрый день! я начинающий программист 1С версии 7.7.
и у меня появилась такая проблема при работе с бухгалтерским запросом((
Мне нужно получить д*цензура*овый оборот по корреспандирующему счету. но счета по чему то не выбираются....
вот процедура:

Процедура Сформировать()
БИ=СоздатьОбъект("БухгалтерскиеИтоги");
БИ.ВыполнитьЗапрос(,КонецРассчитанногоПериодаБИ(),3);
БИ.Выбратьсчета();
Пока БИ.ПолучитьСчет()=1 Цикл
текСчет=БИ.Счет;
Сообщить("Анализ счета "+текСчет);
БИ.ВыбратьКорСчета();
Пока БИ.ПолучитьКорСчет()=1 Цикл
ТекКорСчет=БИ.КорСчет;
Сообщить("Оборот со счетом "+ТекКорСчет+" по д*цензура*у "+БИ.КорДО("С"));
КонецЦикла;
КонецЦикла;
КонецПроцедуры

Счета выбираются и выводятся а корСчета (корреспандирующие счета) нет!
МОЖЕТ КТО ЗНАЕТ В ЧЕМ ПРИЧИНА??
 
K
#2
ВыполнитьЗапрос(,КонецРассчитанногоПериодаБИ(),,,,3) может так
 
M

MadDog

#3
У меня и так запрос выполняется. при этом обычные счета выбираются... я проверял. но вот корСчета нет. Функция БИ.ВыбратьКорСчета()=0 почему то. не пойму.........
 
K
#4
<ТипИтогов> - число - тип отбираемых итогов. Может принимать следующие значения: 1 - остатки и обороты по счету в целом; 2 - обороты между счетами; 3 - первое и второе вместе. По умолчанию: 1.
У вас получается тип итогов 1
 
M

MadDog

#5
пробывал и "1" ставить все равно запрос выполняется но вот корреспандирующие счета и корреспондирующие субконто не выбираются..... хотя сам запрос выполняется , и выводит счета. субконто ,проверял... т.е. все но только когда обращаюсь к корреспандирующим счетам или субконто сразу в отказ. ... странно

Функции ВыбратьКорСчета() и ВыбратьКорСубконто() возвращают 0. не пойму почему. хотя до них все выбирается.
 

KiR

НЕ шибка опытный програмер)
11.09.2007
1 581
0
#6
Так 1 в итогах и так стоит по умолчанию. Нужно пробовать 2 или 3
 
M

MadDog

#9
Да пробывал... все равно функция ВыбратьКорСчета() возвращает ноль..... хотя данную процедуру я писал из книги вроде должно все работать.... странно. эти кор.счета икор субконто не выбираются почему то...
 

KiR

НЕ шибка опытный програмер)
11.09.2007
1 581
0
#10
Попробуй через черный запрос....
 
M

MadDog

#11
я не знаю что такое черный запрос. может у мну в конфигурации галочка где то стоит и кор счета не выбираются. пойду книжки умные читать может найду ответ))))