Проблемы с запросом! 7.7

Тема в разделе "1C и всё что с ней связано", создана пользователем MadDog, 24 ноя 2008.

  1. MadDog

    MadDog Гость

    Репутация:
    0
    Добрый день! я начинающий программист 1С версии 7.7.
    и у меня появилась такая проблема при работе с бухгалтерским запросом((
    Мне нужно получить д*цензура*овый оборот по корреспандирующему счету. но счета по чему то не выбираются....
    вот процедура:

    Процедура Сформировать()
    БИ=СоздатьОбъект("БухгалтерскиеИтоги");
    БИ.ВыполнитьЗапрос(,КонецРассчитанногоПериодаБИ(),3);
    БИ.Выбратьсчета();
    Пока БИ.ПолучитьСчет()=1 Цикл
    текСчет=БИ.Счет;
    Сообщить("Анализ счета "+текСчет);
    БИ.ВыбратьКорСчета();
    Пока БИ.ПолучитьКорСчет()=1 Цикл
    ТекКорСчет=БИ.КорСчет;
    Сообщить("Оборот со счетом "+ТекКорСчет+" по д*цензура*у "+БИ.КорДО("С"));
    КонецЦикла;
    КонецЦикла;
    КонецПроцедуры

    Счета выбираются и выводятся а корСчета (корреспандирующие счета) нет!
    МОЖЕТ КТО ЗНАЕТ В ЧЕМ ПРИЧИНА??
     
  2. kaa

    kaa Гость

    Репутация:
    0
    ВыполнитьЗапрос(,КонецРассчитанногоПериодаБИ(),,,,3) может так
     
  3. MadDog

    MadDog Гость

    Репутация:
    0
    У меня и так запрос выполняется. при этом обычные счета выбираются... я проверял. но вот корСчета нет. Функция БИ.ВыбратьКорСчета()=0 почему то. не пойму.........
     
  4. kaa

    kaa Гость

    Репутация:
    0
    <ТипИтогов> - число - тип отбираемых итогов. Может принимать следующие значения: 1 - остатки и обороты по счету в целом; 2 - обороты между счетами; 3 - первое и второе вместе. По умолчанию: 1.
    У вас получается тип итогов 1
     
  5. MadDog

    MadDog Гость

    Репутация:
    0
    пробывал и "1" ставить все равно запрос выполняется но вот корреспандирующие счета и корреспондирующие субконто не выбираются..... хотя сам запрос выполняется , и выводит счета. субконто ,проверял... т.е. все но только когда обращаюсь к корреспандирующим счетам или субконто сразу в отказ. ... странно

    Функции ВыбратьКорСчета() и ВыбратьКорСубконто() возвращают 0. не пойму почему. хотя до них все выбирается.
     
  6. KiR

    KiR НЕ шибка опытный програмер)
    1C Team

    Репутация:
    0
    Регистрация:
    11 сен 2007
    Сообщения:
    1.581
    Симпатии:
    0
    Так 1 в итогах и так стоит по умолчанию. Нужно пробовать 2 или 3
     
  7. MadDog

    MadDog Гость

    Репутация:
    0
    пробывал. все равно не получается.(((((
     
  8. Hryv

    Hryv Гость

    Репутация:
    0
    Вот так пробовал?
     
  9. MadDog

    MadDog Гость

    Репутация:
    0
    Да пробывал... все равно функция ВыбратьКорСчета() возвращает ноль..... хотя данную процедуру я писал из книги вроде должно все работать.... странно. эти кор.счета икор субконто не выбираются почему то...
     
  10. KiR

    KiR НЕ шибка опытный програмер)
    1C Team

    Репутация:
    0
    Регистрация:
    11 сен 2007
    Сообщения:
    1.581
    Симпатии:
    0
    Попробуй через черный запрос....
     
  11. MadDog

    MadDog Гость

    Репутация:
    0
    я не знаю что такое черный запрос. может у мну в конфигурации галочка где то стоит и кор счета не выбираются. пойду книжки умные читать может найду ответ))))
     
Загрузка...
Похожие Темы - Проблемы запросом
  1. Define

    Проблема Проблемы с шеллом

    Define, 18 июн 2017, в разделе: Kali Linux
    Ответов:
    2
    Просмотров:
    159
  2. Oksy
    Ответов:
    25
    Просмотров:
    1.106
  3. nikos
    Ответов:
    31
    Просмотров:
    1.124
  4. lmike
    Ответов:
    18
    Просмотров:
    675
  5. VikTor1990
    Ответов:
    0
    Просмотров:
    189

Поделиться этой страницей