Проводки документов

Тема в разделе "1C и всё что с ней связано", создана пользователем nMagz, 29 сен 2009.

  1. nMagz

    nMagz Гость

    Добрый день! Поставили задачу но так глубоко с 1С еще незнаком.

    Стандартная Конфигурация Бухгалтерия 7.7 редакция 4.5

    Документ "Услуги сторонних организаций" требуеться чтобы при Субконто1 = некоторым наименованиям с видом "Прочие операционные доходы и расходы" проводкой по налоговому учету падало на счет Н01.05 (Прямые расходы)...

    Наведите на мысль либо ткните на мануал который можно покурить :)
     
  2. vbs

    vbs Well-Known Member

    Регистрация:
    18 фев 2007
    Сообщения:
    1.708
    Симпатии:
    3
    Изучай в модуле документа процедуру

    СформироватьПроводкиДляЦелейНалоговогоУчета(ОбъектыАналитикиНУ, СтоимостьУслуг, Услуга)
     
  3. nMagz

    nMagz Гость

    Вот кусок кода
    но при запуске выдает ошибку Значение не представляет агрегатный объект (ВидПрочихДоходовИРасходов)

    Каким образом можно узнать что Субконто1 при проводке именно то
     
  4. Hryv

    Hryv Гость

    Скорее всего Субконто1 пустое, либо другого типа, чем вы ожидаете и у Субконто1 нет такого реквизита ВидПрочихДоходовИРасходов

    Можно проверить пройдя в отладчике
     
  5. nMagz

    nMagz Гость

    Дело в том что Субконто1 является реквизитом неопределенного типа табличной части документа, каким образом можно узнать что значение этого реквизита (в данной ситуации это Справочник ПрочиеДоходыИРасходы) именно того вида

    Субконто1.ВидПрочихДоходовИРасходов = Перечисление.ВидыПрочихДоходовИРасходов.ПрочиеОперационныеДоходыРасходы
     
  6. Hryv

    Hryv Гость

    1 вариант

    Код (Text):
    Попытка
    //Ваш код
    Исключение
    //ничего или какой-то код, когда Субконто1 не имеет реквизита ВидПрочихДоходовИРасходов
    Конец попытки;
    2 вариант

    Код (Text):
    Если ТипЗначения(Субконто1)=11 Тогда // то есть это Справочник
    Если Субконто1.Вид()="ПрочиеДоходыИРасходы" Тогда
    Если ПустоеЗначение(Субконто1)=0 Тогда
    //ваш код
    КонецЕсли;
    КонецЕсли;
    КонецЕсли;
     
  7. vbs

    vbs Well-Known Member

    Регистрация:
    18 фев 2007
    Сообщения:
    1.708
    Симпатии:
    3
    Или изначально проверить Субконто1 на Непустое значение
     
  8. Hryv

    Hryv Гость

    vbs, если
    то чисто теоретически Субконто1 может быть строкой или числом и не быть пустым
    Тогда проверка на ПустоеЗначение ничего полезного не даст, и для полной надежности ее не хватит
     
  9. vbs

    vbs Well-Known Member

    Регистрация:
    18 фев 2007
    Сообщения:
    1.708
    Симпатии:
    3
    Да, пожалуй, погорячился, невнимательно прочитал.
    Тип значения, конечно, важнее
     
Загрузка...

Поделиться этой страницей