Работа агентов под Web

  • Автор темы KLif
  • Дата начала
Статус
Закрыто для дальнейших ответов.
K

KLif

#1
Всем привет ...

Не получается запустить агента под веб, любого ... или получается, но тогда я не вижу результата его работы ....

1. Агент открывается в скрытом фрейме
2. Код агент содержит только Print '<h1>текст</h1>'
3. Вызов агента:
Код:
window.frames["buffer"].location = "http://Server/DB/OQCreateStaffField?OpenAgent"
Я как понял, у меня на странице должно появится то что написано в Print ... в итоге, ничего не происходит, и ошибок нет ...

Кто что подскажет?
 

yerke

Well-known member
28.08.2007
392
0
#2
<!--QuoteBegin-KLif+11:02:2008, 17:46 -->
<span class="vbquote">(KLif @ 11:02:2008, 17:46 )</span><!--QuoteEBegin-->3. Вызов агента:
Код
window.frames["buffer"].location = "http://Server/DB/OQCreateStaffField?OpenAgent"
[snapback]97517" rel="nofollow" target="_blank[/snapback]​
[/quote]

вызывал агент(джава и ЛС) собачкой
проблем не было
 
S

Sandr

#3
Всем привет ...

Не получается запустить агента под веб, любого ... или получается, но тогда я не вижу результата его работы ....

1. Агент открывается в скрытом фрейме
2. Код агент содержит только Print '<h1>текст</h1>'
3. Вызов агента:
Код:
window.frames["buffer"].location = "http://Server/DB/OQCreateStaffField?OpenAgent"
Я как понял, у меня на странице должно появится то что написано в Print ... в итоге, ничего не происходит, и ошибок нет ...

Кто что подскажет?
Ну, Вы ж его в скрытом фрейме открываете... Что Вы хотите увидить? :)
 
K

KLif

#4
Сделал фрейм видемым, страница не отображается ...

Может быть две проблемы
1. либо я непраивльно указываю путь к агенту в ссылке (но уже раз сто проглядел)
2. либо кривой агент, но в нём всего она строчка принта

больше ничего в голову не приходит ... где я ещё могу быть неправым?
 

yerke

Well-known member
28.08.2007
392
0
#5
может полностью написать?
:(
Код:
Print "<html><head></head><body><h1>текст</h1></body></html>"
 
K

KLif

#6
может полностью написать?
:(
Код:
Print "<html><head></head><body><h1>текст</h1></body></html>"
о господи, извините меня ;) ... дело в настройках, неверно указал с какими доками должен работать агент ...
Всем спасибо ...

p.s. надо быть внимательнее ...
 
S

Sandr

#8
Посмотрите свойства агента. Свойство Turget documents долждно стоять в None, и должна стоять галка Run as web user, уровеь секюрности агенту поставте 2-ку...

ЗЫ: И смотрите в консоль, все вебные ошибки там пишутся...

А.. вы уже разобрались :unsure:
 
Статус
Закрыто для дальнейших ответов.