Работа с метаданными в 1С 8

Тема в разделе "1C и всё что с ней связано", создана пользователем -, 8 дек 2010.

Статус темы:
Закрыта.
  1. Гость

    Мне нужно выгрузить данные из справочников и документов из 1С в Word, т.е нужно выгрузить метаданные.
    Проблема в том, что Я не знаю, как работать с метаданными в 1С 8...
    Кто-нибудь скиньте пож-та несколько основных примеров!
    Допустим, как достать "ВесТовара" из справочника "Товары", используя метаданные?
     
  2. TimeDontWait

    TimeDontWait Well-Known Member

    Регистрация:
    4 янв 2010
    Сообщения:
    383
    Симпатии:
    0
    Пользуйтесь
    Конфигурация - Oтчeт пo кoнфигуpaции
     
  3. Гость

    Спасибо, но туда Я уже заглядывала и мне это никак не помогло...
     
  4. unknown181538

    unknown181538 НеГуру
    1C Team

    Регистрация:
    28 дек 2008
    Сообщения:
    1.418
    Симпатии:
    0
    Да все не так сложно и интуитивно понятно.
    Вот накидал процедурку:

    Код ( (Unknown Language)):
        Для Каждого Спр из Метаданные.Справочники Цикл
    Сообщение = Новый СообщениеПользователю;
    Сообщение.Текст = Спр.Имя;
    Сообщение.Сообщить();
    Для каждого Рекв Из Спр.Реквизиты Цикл
    Сообщение = Новый СообщениеПользователю;
    Сообщение.Текст = "--"+Рекв.Имя;
    Сообщение.Сообщить();
    КонецЦикла;
    КонецЦикла;
     
  5. Гость

    Как достать имена реквизитов понятно, а можно значения из этих реквизитов достать???
    То есть, если "ВесТовара" = 15кг, как получить число 15???
     
  6. unknown181538

    unknown181538 НеГуру
    1C Team

    Регистрация:
    28 дек 2008
    Сообщения:
    1.418
    Симпатии:
    0
    Код ( (Unknown Language)):
    НужныйВес = МояСсылкаНасправочник[Рекв.Имя]
    Можно и запрос сделать со звездочкой в описании полей, и так же обратиться к выборке.
     
  7. Гость

    Извините пож-та, чЁ т мне не очень понятно...

    Сделала процедурку, самую первую, кот. вы написали.

    Результат:
    Товары
    --НазваниеТовара
    --ВесТовара
    --Стоимость
    --Склад

    А Как получить все НазванияТоваров??
    Какой там цикл должен быть?

    Не доходит до меня((((
     
  8. unknown181538

    unknown181538 НеГуру
    1C Team

    Регистрация:
    28 дек 2008
    Сообщения:
    1.418
    Симпатии:
    0
    Код ( (Unknown Language)):
    Для Каждого Спр из Метаданные.Справочники Цикл
    Сообщить(Спр.Имя);
    ВыборкаИзСпр = Справочники[Спр.Имя].Выбрать();
    Пока ВыборкаИзСпр.Следующий() Цикл
    Для каждого Рекв Из Спр.Реквизиты Цикл
    Сообщить("--"+ВыборкаИзСпр[Рекв.Имя]);
    КонецЦикла;
    КонецЦикла;
    КонецЦикла;
    Как-то так... ну или можно через запрос, чтоб быстрее было.
     
  9. KiR

    KiR НЕ шибка опытный програмер)
    1C Team

    Регистрация:
    11 сен 2007
    Сообщения:
    1.581
    Симпатии:
    0
    Данные из справочников и метаданные - это 2 разные вещи. вот народ и помогает с выгрузкой метаданных программы, а вам походу нужны просто данные. встает вопрос - из каких справочников и какие реквизиты?
     
  10. KiR

    KiR НЕ шибка опытный програмер)
    1C Team

    Регистрация:
    11 сен 2007
    Сообщения:
    1.581
    Симпатии:
    0
    Данные из справочников и метаданные - это 2 разные вещи. вот народ и помогает с выгрузкой метаданных программы, а вам походу нужны просто данные. встает вопрос - из каких справочников и какие реквизиты?
     
  11. Гость

    Спасибо unknown181538!!!!!! :blink:
     
Загрузка...
Похожие Темы - Работа метаданными 1С
  1. Andrey Kha
    Ответов:
    0
    Просмотров:
    34
  2. Hoasker
    Ответов:
    0
    Просмотров:
    65
  3. garri671
    Ответов:
    0
    Просмотров:
    75
  4. lelik200969
    Ответов:
    0
    Просмотров:
    55
  5. Kozolick
    Ответов:
    0
    Просмотров:
    147
Статус темы:
Закрыта.

Поделиться этой страницей