Работа с метаданными в 1С 8

  • Автор темы Guest
  • Дата начала
Статус
Закрыто для дальнейших ответов.
G

Guest

#1
Мне нужно выгрузить данные из справочников и документов из 1С в Word, т.е нужно выгрузить метаданные.
Проблема в том, что Я не знаю, как работать с метаданными в 1С 8...
Кто-нибудь скиньте пож-та несколько основных примеров!
Допустим, как достать "ВесТовара" из справочника "Товары", используя метаданные?
 
T

TimeDontWait

#2
Пользуйтесь
Конфигурация - Oтчeт пo кoнфигуpaции
 
G

Guest

#3
Спасибо, но туда Я уже заглядывала и мне это никак не помогло...
 

unknown181538

НеГуру
28.12.2008
1 417
0
#4
Да все не так сложно и интуитивно понятно.
Вот накидал процедурку:

Код:
	Для Каждого Спр из Метаданные.Справочники Цикл
Сообщение = Новый СообщениеПользователю;
Сообщение.Текст = Спр.Имя;
Сообщение.Сообщить();
Для каждого Рекв Из Спр.Реквизиты Цикл
Сообщение = Новый СообщениеПользователю;
Сообщение.Текст = "--"+Рекв.Имя;
Сообщение.Сообщить();
КонецЦикла;
КонецЦикла;
 
G

Guest

#5
Как достать имена реквизитов понятно, а можно значения из этих реквизитов достать???
То есть, если "ВесТовара" = 15кг, как получить число 15???
 

unknown181538

НеГуру
28.12.2008
1 417
0
#6
Код:
НужныйВес = МояСсылкаНасправочник[Рекв.Имя]
Можно и запрос сделать со звездочкой в описании полей, и так же обратиться к выборке.
 
G

Guest

#7
Извините пож-та, чЁ т мне не очень понятно...

Сделала процедурку, самую первую, кот. вы написали.

Результат:
Товары
--НазваниеТовара
--ВесТовара
--Стоимость
--Склад

А Как получить все НазванияТоваров??
Какой там цикл должен быть?

Не доходит до меня((((
 

unknown181538

НеГуру
28.12.2008
1 417
0
#8
Код:
Для Каждого Спр из Метаданные.Справочники Цикл
Сообщить(Спр.Имя);
ВыборкаИзСпр = Справочники[Спр.Имя].Выбрать();
Пока ВыборкаИзСпр.Следующий() Цикл
Для каждого Рекв Из Спр.Реквизиты Цикл
Сообщить("--"+ВыборкаИзСпр[Рекв.Имя]);
КонецЦикла;
КонецЦикла;
КонецЦикла;
Как-то так... ну или можно через запрос, чтоб быстрее было.
 

KiR

НЕ шибка опытный програмер)
11.09.2007
1 581
0
#9
Мне нужно выгрузить данные из справочников и документов из 1С в Word, т.е нужно выгрузить метаданные.
Данные из справочников и метаданные - это 2 разные вещи. вот народ и помогает с выгрузкой метаданных программы, а вам походу нужны просто данные. встает вопрос - из каких справочников и какие реквизиты?
 

KiR

НЕ шибка опытный програмер)
11.09.2007
1 581
0
#10
Мне нужно выгрузить данные из справочников и документов из 1С в Word, т.е нужно выгрузить метаданные.
Данные из справочников и метаданные - это 2 разные вещи. вот народ и помогает с выгрузкой метаданных программы, а вам походу нужны просто данные. встает вопрос - из каких справочников и какие реквизиты?
 
Статус
Закрыто для дальнейших ответов.