Работа с периодическим реквизитом

  • Автор темы Leska
  • Дата начала
L

Leska

Гость
#1
Доброе утро!

Столкнулась с такой проблемой, ну просто тупик.
Можно ли получить дату и цену последнего поступление периодического реквизита справочника (цена)?

Подсажите, пожалуйста.
 

puh14

Well-Known Member
11.07.2008
1 412
0
НеРезиновая
#2
Что-то типа переменная = Спр.реквизит.Получить(ПолучитьПозициюТА());

Либо через создание объекта Периодический.
 
H

Hryv

Гость
#3
Периодический = СоздатьОбъект("Периодический");
Периодический.ИспользоватьОбъект(Реквизит, ТекущийОбъект);
Периодический.ВыбратьЗначения(НачальнаяДата, КонечнаяДата);
Пока Периодический.ПолучитьЗначение() = 1 Цикл
ДатаЗначения = Периодический.ДатаЗнач;
Значение = Периодический.Значение;
КонецЦикла

Подробности в хелпе
 
L

Leska

Гость
#4
puh14
Hryv

Спасибо за ответы :rolleyes:
Периодический = СоздатьОбъект("Периодический");
Периодический.ИспользоватьОбъект(Реквизит, ТекущийОбъект);
Периодический.ВыбратьЗначения(НачальнаяДата, КонечнаяДата);
Пока Периодический.ПолучитьЗначение() = 1 Цикл
ДатаЗначения = Периодический.ДатаЗнач;
Значение = Периодический.Значение;
КонецЦикла
Это то что надо. Спасибо еще раз!
 
K

kaa

Гость
#5
Можно ли получить дату и цену последнего поступление периодического реквизита справочника (цена)?
Я бы сделал так:

Периодический = СоздатьОбъект("Периодический");
Периодический.ИспользоватьОбъект(Реквизит, ТекущийОбъект);

Периодический.ОбратныйПорядок(1);

Периодический.ВыбратьЗначения(НачальнаяДата, КонечнаяДата);
Пока Периодический.ПолучитьЗначение() = 1 Цикл
ДатаЗначения = Периодический.ДатаЗнач;
Значение = Периодический.Значение;
Прервать;
КонецЦикла;

Я думаю быстрее будет :)