Работа со строками

  • Автор темы Axxon
  • Дата начала
A

Axxon

#1
Уважаемые специалисты и любители 1С!
Подскажите,пожалуйста,нужно написать код процедуры которая сможет вывести мне кол-во слов.
Я уже написал код для строки в которой мы вводим слова и таблицу в которое добляется этот текст.Но вот по поводу счетчика у меня возникают проблемы.

Заранее Благодарен!
 

Zab

Well-known member
07.08.2006
583
0
#2
Посчитай количество символов разделителей. Нарпимер:
Код:
СтрЧислоВхождений(СокрЛП(СтрИсточник)," ")+1
Для строки "Считаем количество слов. По количеству пробелов" вернет 6
 
A

Axxon

#3
Вот жалкий релиз поставленной задачи.Но вопрос, как "СтрЧислоВхождений(СокрЛП(фСтрочка)," ")+1" работает в моем цикле?Ей Богу не пойму... :(


//*******************************************
Процедура Сформировать()


КонецПроцедуры

//__________________________________________
Процедура КликПоТз()
//Перем = Счетчик;

ЛС=фТз.ТекущаяСтрока();
ЛК=фТз.ТекущаяКолонка();
Если Лк="буква" Тогда
Лбуква=фТз.ПолучитьЗначение(лС,лК);//вводим новую перемунную делаем ей присвоение

фТз.Длина=СтрДлина(Лбуква);
фТз.буква=Лбуква;
КонецЕсли;

КонецПроцедуры

//__________________________________________
Процедура ОбрфСтрочка()
фТз.НоваяСтрока();
фТз.буква=фСтрочка;

Для (сч=1) по СтрДлина(фСтрочка) Цикл
СтрЧислоВхождений(СокрЛП(фСтрочка)," ")+1
Конеццикла;
КонецПроцедуры
//__________________________________________



//__________________________________________
фТз.НоваяКолонка("Буква");
фТз.НоваяКолонка("Длина");