Работа со строками

Тема в разделе "1C и всё что с ней связано", создана пользователем Axxon, 7 ноя 2007.

  1. Axxon

    Axxon Гость

    Уважаемые специалисты и любители 1С!
    Подскажите,пожалуйста,нужно написать код процедуры которая сможет вывести мне кол-во слов.
    Я уже написал код для строки в которой мы вводим слова и таблицу в которое добляется этот текст.Но вот по поводу счетчика у меня возникают проблемы.

    Заранее Благодарен!
     
  2. Zab

    Zab Well-Known Member
    1C Team

    Регистрация:
    7 авг 2006
    Сообщения:
    583
    Симпатии:
    0
    Посчитай количество символов разделителей. Нарпимер:
    Код (Text):
    СтрЧислоВхождений(СокрЛП(СтрИсточник)," ")+1
    Для строки "Считаем количество слов. По количеству пробелов" вернет 6
     
  3. Axxon

    Axxon Гость

    Вот жалкий релиз поставленной задачи.Но вопрос, как "СтрЧислоВхождений(СокрЛП(фСтрочка)," ")+1" работает в моем цикле?Ей Богу не пойму... :(


    //*******************************************
    Процедура Сформировать()


    КонецПроцедуры

    //__________________________________________
    Процедура КликПоТз()
    //Перем = Счетчик;

    ЛС=фТз.ТекущаяСтрока();
    ЛК=фТз.ТекущаяКолонка();
    Если Лк="буква" Тогда
    Лбуква=фТз.ПолучитьЗначение(лС,лК);//вводим новую перемунную делаем ей присвоение

    фТз.Длина=СтрДлина(Лбуква);
    фТз.буква=Лбуква;
    КонецЕсли;

    КонецПроцедуры

    //__________________________________________
    Процедура ОбрфСтрочка()
    фТз.НоваяСтрока();
    фТз.буква=фСтрочка;

    Для (сч=1) по СтрДлина(фСтрочка) Цикл
    СтрЧислоВхождений(СокрЛП(фСтрочка)," ")+1
    Конеццикла;
    КонецПроцедуры
    //__________________________________________



    //__________________________________________
    фТз.НоваяКолонка("Буква");
    фТз.НоваяКолонка("Длина");
     
Загрузка...
Похожие Темы - Работа со строками
  1. alexas1
    Ответов:
    1
    Просмотров:
    457
  2. shkeat
    Ответов:
    1
    Просмотров:
    1.690
  3. NickProstoNick
    Ответов:
    1
    Просмотров:
    2.309
  4. KiR
    Ответов:
    7
    Просмотров:
    9.458
  5. eugira
    Ответов:
    5
    Просмотров:
    5.405

Поделиться этой страницей