Распределение элементов справочника по группам

  • Автор темы VoodyGoo
  • Дата начала
Статус
Закрыто для дальнейших ответов.
V

VoodyGoo

Гость
#1
Здраствуйте.
Как можно изменить у существующего элемента справочника родителя, т.е. переместить его в определённую группу. При создании нового элемента всё просто:
Код:
НовыйЭлемент.Родитель = Какая то группа
А тот же метод на существующий элемент не действует.

Действие происходит так:

Есть документ с заполненной табличной частью (с реквизитом ТЧ - ТМЦ - тип спр.Номенклатура).
делаю цикл по строкам ТЧ, выхожу на ТМЦ и пытаюсь присвоить владельца описанным выше способом - не получется((
ТекНом.Родитель = ВыбГруппа;
{C:\VOODY\1C\РАСПРЕДЕЛЕНИЕПОГРУППАМ.ERT(23)}: Объект не может быть перепозиционирован!
метод Использовать владельца тоже не работает

как тут быть?
 

puh14

Well-Known Member
11.07.2008
1 412
0
НеРезиновая
#2
Эээ - ты ему прямо из документа пытаешся родителя задать? так не получится. Лучше примерно так ( в семерке)
Ном = СоздатьОбъект("Справочник.Номенклатура");
Пока ПолучитьСтроку() = 1 Цикл
ЕСли Ном.НайтиЭлемент(ТекущаяСтрока().Номенклатура) = 1 ТОгда
Ном.Родитель = ВыбГРуппа;
Ном.Записать();
Иначе
Сообщить("Элемент не найден в строке " + НомерСтроки);
КонецЕСли;
КонецЦикла;
 
V

VoodyGoo

Гость
#3
Так тоже самое, пробовал даже выгружать в тз, и отуда уже пытаться. Ничего.
Через СоздатьОбъект та же ошибка.

если смотреть по вашему коду, то ошибко уже тут
Ном = СоздатьОбъект("Справочник.Номенклатура");
Пока ПолучитьСтроку() = 1 Цикл
ЕСли Ном.НайтиЭлемент(ТекущаяСтрока().Номенклатура) = 1 ТОгда
Ном.Родитель = ВыбГРуппа;
Ном.Записать();
Иначе
Сообщить("Элемент не найден в строке " + НомерСтроки);
КонецЕСли;
КонецЦикла;
 

puh14

Well-Known Member
11.07.2008
1 412
0
НеРезиновая
#4
Значит косяк в типе переменной выбгруппа - неверное значение(элемент), не тот справочник. Мож выбгруппа вообще строка
Он ведь нашел элемент номенклатуры в справочнике а вот родитель подкачал.
 
V

VoodyGoo

Гость
#5
Значит косяк в типе переменной выбгруппа - неверное значение(элемент), не тот справочник. Мож выбгруппа вообще строка
Он ведь нашел элемент номенклатуры в справочнике а вот родитель подкачал.
Для выбора родителя создал на форме ПолеВвода (ид ВыбГруппа) тип Справочник.Номенклатура. И уже через него то и выбираю владельца

А если бы ВыбГруппа и была бы строкой, ии ещё чем либо, то элемент юы просто записался в корень справочника, такое я когда то замечал.
 

puh14

Well-Known Member
11.07.2008
1 412
0
НеРезиновая
#6
А ещё такой переменной в форме у тебя не объявлено? 1с в первую очередь смотрит на переменные формы, а потом на поля ввода, даже если идентификатор объявлен. Ещё посмотри - мож она у тебя перезаполняется чем. Если в лом искать - переименуй ВыбГРуппа в ВЫбгруппаНоменклатуры на поле ввода и в модуле и попробуй. Мож ВЫбГруппа - это вообще глобальная переменная.
 
V

VoodyGoo

Гость
#7
А ещё такой переменной в форме у тебя не объявлено? 1с в первую очередь смотрит на переменные формы, а потом на поля ввода, даже если идентификатор объявлен. Ещё посмотри - мож она у тебя перезаполняется чем. Если в лом искать - переименуй ВыбГРуппа в ВЫбгруппаНоменклатуры на поле ввода и в модуле и попробуй. Мож ВЫбГруппа - это вообще глобальная переменная.
нет, форма чистая, обработку спец для этого создавал. Есть только 2 элемента ВыбГрупа и ВыбДок. Ничто нигде не перекрывается, точно
 

puh14

Well-Known Member
11.07.2008
1 412
0
НеРезиновая
#8
переименуй поле ввода на форме и соответственно в модуле каким нибуть длинным названием - и попробуй.
 
V

VoodyGoo

Гость
#9
переименуй поле ввода на форме и соответственно в модуле каким нибуть длинным названием - и попробуй.
никаких улучшений
ТекНом.Родитель = ВыбГруппаДляИзменения;
{C:\VOODY\1C SOFT\РАСПРЕДЕЛЕНИЕПОГРУППАМ.ERT(23)}: Объект не может быть перепозиционирован!
 

puh14

Well-Known Member
11.07.2008
1 412
0
НеРезиновая
#10
ТекНом - это что? Код покажи целиком
Обычно такое бывает когда на одну переменную пытаются навесить несколько создать объект, или в поле ввода и переменная модуля совпадают.
 
V

VoodyGoo

Гость
#11
ТекНом - это что? Код покажи целиком
Обычно такое бывает когда на одну переменную пытаются навесить несколько создать объект, или в поле ввода и переменная модуля совпадают.
тут его очень немного) Вот вся обработка
Код:
Процедура Выполнить() 

спрНоменклатура = СоздатьОбъект("Справочник.Номенклатура");

ВыбДок.ВыбратьСтроки();
Пока ВыбДок.ПолучитьСтроку() = 1 Цикл 

спрНоменклатура.НайтиПоКоду(ВыбДок.ТМЦ.Код);

ТекНом = спрНоменклатура.ТекущийЭлемент();

ТекНом.Родитель = ВыбГруппаДляИзменения;
ТекНом.Записать();

КонецЦикла;

КонецПроцедуры
 

puh14

Well-Known Member
11.07.2008
1 412
0
НеРезиновая
#12
Процедура Выполнить()

спрНоменклатура = СоздатьОбъект("Справочник.Номенклатура");

ВыбДок.ВыбратьСтроки();
Пока ВыбДок.ПолучитьСтроку() = 1 Цикл

Если спрНоменклатура.НайтиЭлемент(ВыбДок.ТМЦ) = 1 ТОгда// ТМЦ- это точно номенклатура? мож просто значение типа Справочник

СпрНоменклатура.Родитель = ВыбГруппаДляИзменения;
СпрНоменклатура.Записать();
Иначе
Сообщить("Не нашли");//ну а вдруг...
КонецЕСли;

КонецЦикла;

КонецПроцедуры

Походу проблема в том, что ТекНом - это тебе не создатьОбъект ;-)
 
V

VoodyGoo

Гость
#13
Обычно такое бывает когда на одну переменную пытаются навесить несколько создать объект, или в поле ввода и переменная модуля совпадают.
а может быть такое, что причина всему то, что на один и тот же елемент справочника у меня сразу ссылается строка тч док-а(т.к мы в цикле на ней стоим), и Справочник Создать Объект Текущий элемент


puh14, спасибо ОГРОМНОЕ!
Получилось, только не понимаю в чём тут фокус?
Вроде и найти по коду и найтиэлемент возращают один и тот же тип, элемент.
Хотелось понять, а то получается что я тупо код списал -_-

Но и на этом уже спасибо!!!!
 

puh14

Well-Known Member
11.07.2008
1 412
0
НеРезиновая
#14
ТЧ дока ссылается через ВыбДок.ТМЦ а справочник серез СпрНоменклатура - так что не в этом дело. Короче - работает?

скорее всего дело было в том, что ТекНом - это не СоздатьОбъект, а тупо переменная. И Изменение параметров справочника через переменную невозможно - только через СоздатьОбъект. Ту же ошибку тебе выдаст ежли ты напишешь

ВыбДок.ТМЦ.Родитель = ВыбГруппаДляИзменения;
ВыбДок.ТМЦ.Записать();
 

unknown181538

НеГуру
28.12.2008
1 417
0
30
Москва
#16
НАйтиЭлмент и Найти ПОкКОду - это немножко разное. В восьмерке есть два типа "СправочникОбъект" и "СправочникСсылка". Чем различаются толком не понимаю. Для записи надо использовать НайтиЭлемент(). МОжно было написать НайтиПоКоду(), затем НАйтиЭлемент().
 
Статус
Закрыто для дальнейших ответов.