Расшифровка для сводной таблицы

Тема в разделе "1C и всё что с ней связано", создана пользователем Olna, 29 ноя 2008.

  1. Olna

    Olna Гость

    Доброго времени суток!
    В 1с8 делаю отчет, в виде сводной таблицы. Для ячеек нужно сделать расшифровку - другой отчет.
    Можно ли сделать расшифровку для сводной таблицы и как?

    Я попыталась сделать следующее:

    //сводную таблицу помещаю в полетабличногодокумента
    табдок=элементыформы.ПолеТабличногоДокумента1;
    нашаСводТаб=табдок.ВстроенныеТаблицы.Добавить(Тип("своднаяТаблица"));


    //полютабличногодокумента на событие обработкарасшифровки вешаю процедуру обработкарасшифровки
    //(элемент,расшифровка,стандартнаяобработка)

    //для сводной таблицы задаю свойства:
    нашасводтаб.ОбластьДанных.ИспользованиеРасшифровки=ИспользованиеРасшифровкиТабли
    чногоДокумента.Ячейка;
    нашасводтаб.ОбластьДанных.Расшифровка="СООБЩЕНИЕ"


    В процедуру обработкарасшифровки программа даже не заходит...
     
  2. Olna

    Olna Гость

    Мне подсказали выход: вместо обработки расшифровки повесить на событие Выбор элемента ПолеТабличногоДокумента1 процедурку:

    Процедура ПолеТабличногоДокумента1Выбор(Элемент, Область, СтандартнаяОбработка)
    Если ТипЗнч(Область) = Тип("ОбластьЯчеекТабличногоДокумента") Тогда
    Структура = Элемент.ВстроенныеТаблицы.СводнаяТаблица1.ПолучитьЗначения(Область);
    Если структура <> Неопределено Тогда
    Если Структура.Свойство("контрагент") и структура.свойство("Склад") Тогда
    Склад = Структура.склад;
    контрагент = структура.контрагент;
    сумм = структура.сумм;
    Сообщить(строка(контрагент)+ " "+строка(склад)+" "+строка(сумм));
    КонецЕсли;
    КонецЕсли;
    КонецЕсли;
    КонецПроцедуры

    //сводная таблица имеет измерения контрагент и склад и ресурс - сумм.
     
Загрузка...

Поделиться этой страницей