Редактирование таблицы значений

  • Автор темы arhiordinator
  • Дата начала
A

arhiordinator

#1
Всем привет. Работаю в версии 7.7
Хотел бы узнать можно ли как то редактировать таблицу значений двойным нажатием на нужную строчку.
Суть в том что моя таблица заполняется значениями из справочника, далее я хочу двойным нажатием на таблице значений отредактировать данные, но этого не получается, редактировать система не даёт. Как можно сделать подобное?
 

unknown181538

НеГуру
28.12.2008
1 417
0
#2
Нужно редактирование справочника или добавление нового - зависит от конкретной задачи:
Примеры:
<!--shcode--><pre><code class='1'>Процедура ВыборСтроки() // указывается в свойствах ТЗ
Если ТЗ.ТекущаяКолонка() = "вкл" Тогда
Если ТЗ.вкл=1 Тогда
ТЗ.вкл=2;
Иначе
ТЗ.вкл=1;
КонецЕсли;
ИначеЕсли ТЗ.ТекущаяКолонка() = "РН" Тогда
Если ТЗ.РН=1 Тогда
ТЗ.РН=2;
Иначе
ТЗ.РН=1;
КонецЕсли;
ИначеЕсли ТЗ.ТекущаяКолонка() = "Док" тогда
ОткрытьФорму(ТЗ.Док);
Иначе
ОткрытьФорму(ТЗ.Реализация);
КонецЕсли;
КонецПроцедуры[/CODE]
Добавить с помощью подбора:
<!--shcode--><pre><code class='1'>Процедура ОбработкаПодбора(ДОк, Конт)
Если ТЗ.НАйтиЗначение(ДОк,,)=0 Тогда
ТЗ.НоваяСтрока();
ТЗ.Поступление=Док;
КонецЕсли;
КонецПроцедуры[/CODE]