1. Набираем команду codeby webinar. Набираем команду для организации и проведения вебинаров. Подробнее ...

    Скрыть объявление
  2. Требуются разработчики и тестеры для проекта codebyOS. Требования для участия в проекте: Знание принципов работы ОС на базе Linux; Знание Bash; Крайне желательное знание CPP, Python, Lua; Навыки системного администрирования. Подробнее ...

    Скрыть объявление
  3. Получи 30.000 рублей. Для получения денег необходимо принять участие в конкурсе авторов codeby. С условиями и призами можно ознакомиться на этой странице ...

    Внимание! Регистрация авторов на конкурс закрыта.

    Скрыть объявление

Регистры

Тема в разделе "Базы данных и администрирование", создана пользователем TimeDontWait, 15 апр 2010.

  1. TimeDontWait

    TimeDontWait Well-Known Member

    Репутация:
    0
    Регистрация:
    4 янв 2010
    Сообщения:
    367
    Симпатии:
    0
    7.7
    Есть регистр остатков. Сделал отчет через запрос - получаю первую , почти пустую строку. Думал, может случайно по ошибке некорректные данные . Удалил все регистры ( на копии бд ) то же самое.
    Сделал другой отчет, в котором данные получаю с помощью ВыбратьДвижения() - все идеально.
    В модуле запроса все коротко и просто - теряюсь в догадках - в чем проблема ?
     

    Вложения:

    • __.jpg
      Размер файла:
      796,2 КБ
      Просмотров:
      34
  2. vitfil

    vitfil IT-интегратор

    Репутация:
    0
    Регистрация:
    2 апр 2004
    Сообщения:
    2.062
    Симпатии:
    0
    Текст запроса в студию!
     
  3. Hryv

    Hryv Гость

    Репутация:
    0
    Может в группировке по сотрудникам "без групп" не написано?
     
  4. TimeDontWait

    TimeDontWait Well-Known Member

    Репутация:
    0
    Регистрация:
    4 янв 2010
    Сообщения:
    367
    Симпатии:
    0
    Код:
    Процедура Сформировать()
    
    Запрос = СоздатьОбъект("Запрос");
    ТекстЗапроса = "
    |Период с ВыбдатаС по ВыбдатаПо;
    |Автор	 = Регистр.ОперацииD3D4.Автор;
    |ПерсНомер = Регистр.ОперацииD3D4.ПерсНомер;
    |ПІБ	  = Регистр.ОперацииD3D4.ПІБ;
    |сумма	 = Регистр.ОперацииD3D4.сумма;
    |нормгод  = Регистр.ОперацииD3D4.нормгод; 
    |Функция СуммаКонОст = КонОст(сумма);
    |Функция СуммаНГ	 = КонОст(нормгод);
    |Группировка ПерсНомер; 
    |Условие (Автор в Автор); 
    |";
    
    Если Запрос.Выполнить(ТекстЗапроса) = 0 Тогда
    Возврат;
    КонецЕсли;
    
    нач = Константа.Начальник.Наименование;
    сч=0;
    Таб = СоздатьОбъект("Таблица");
    Таб.ВывестиСекцию("Заголовок");
    Пока Запрос.Группировка("ПерсНомер",1)=1 цикл 
    сч=сч+1;
    Таб.ВывестиСекцию("Наряд");
    КонецЦикла;
    Таб.ВывестиСекцию("подвал");
    Таб.ПараметрыСтраницы(1,);
    Таб.Опции(0,,3,); 
    Таб.Показать("Звіт в бухгалтерію","ЗвітВБухг_"+ТекущаяДата()+"");
    
    КонецПроцедуры
    
    ВыбДатас=НачМесяца(ТекущаяДата());
    ВыбДатаПо=ПолучитьТА();
    Добавлено: Hryv был прав, вот такие мелочи не знал
     
  5. Hryv

    Hryv Гость

    Репутация:
    0
    Сам постоянно забываю поставить "без групп"
    При первом тесте это обнаруживаю и исправляю
    Поэтому глаз уже наметан ;)
     
Загрузка...

Поделиться этой страницей