Регистры

  • Автор темы TimeDontWait
  • Дата начала
T

TimeDontWait

#1
7.7
Есть регистр остатков. Сделал отчет через запрос - получаю первую , почти пустую строку. Думал, может случайно по ошибке некорректные данные . Удалил все регистры ( на копии бд ) то же самое.
Сделал другой отчет, в котором данные получаю с помощью ВыбратьДвижения() - все идеально.
В модуле запроса все коротко и просто - теряюсь в догадках - в чем проблема ?
 

Вложения

  • 796.2 КБ Просмотры: 34
H

Hryv

#3
Может в группировке по сотрудникам "без групп" не написано?
 
T

TimeDontWait

#4
Код:
Процедура Сформировать()

Запрос = СоздатьОбъект("Запрос");
ТекстЗапроса = "
|Период с ВыбдатаС по ВыбдатаПо;
|Автор	 = Регистр.ОперацииD3D4.Автор;
|ПерсНомер = Регистр.ОперацииD3D4.ПерсНомер;
|ПІБ	  = Регистр.ОперацииD3D4.ПІБ;
|сумма	 = Регистр.ОперацииD3D4.сумма;
|нормгод  = Регистр.ОперацииD3D4.нормгод; 
|Функция СуммаКонОст = КонОст(сумма);
|Функция СуммаНГ	 = КонОст(нормгод);
|Группировка ПерсНомер; 
|Условие (Автор в Автор); 
|";

Если Запрос.Выполнить(ТекстЗапроса) = 0 Тогда
Возврат;
КонецЕсли;

нач = Константа.Начальник.Наименование;
сч=0;
Таб = СоздатьОбъект("Таблица");
Таб.ВывестиСекцию("Заголовок");
Пока Запрос.Группировка("ПерсНомер",1)=1 цикл 
сч=сч+1;
Таб.ВывестиСекцию("Наряд");
КонецЦикла;
Таб.ВывестиСекцию("подвал");
Таб.ПараметрыСтраницы(1,);
Таб.Опции(0,,3,); 
Таб.Показать("Звіт в бухгалтерію","ЗвітВБухг_"+ТекущаяДата()+"");

КонецПроцедуры

ВыбДатас=НачМесяца(ТекущаяДата());
ВыбДатаПо=ПолучитьТА();
Добавлено: Hryv был прав, вот такие мелочи не знал
 
H

Hryv

#5
Сам постоянно забываю поставить "без групп"
При первом тесте это обнаруживаю и исправляю
Поэтому глаз уже наметан ;)