• Codeby web-security - Курс "Тестирование Веб-Приложений на проникновение с нуля" от команды codeby. Общая теория, подготовка рабочего окружения, пассивный фаззинг и фингерпринт, Активный фаззинг, Уязвимости, Пост-эксплуатация, Инструментальные средства, Social Engeneering и многое другое. Подробнее ...

  • Мобильный клиент нашего форума для Android гаджетов доступен в Google Play Market по этой ссылке. Клиент можно скачать с нашего форума по этой ссылке. Последняя версия МК в нашем телеграм канале вот здесь

RTL 8812AU – что делать, если не устанавливается драйвер

20.07.2016
613
620
#1
Всем привет!
Сразу хочу сказать – всё что здесь написано, проверено мной лично. Тема отслеживается больше года.
Поехали.
В последнее время на форуме, да и мне лично часто стали задавать такой вопрос:
Не устанавливается драйвер, что делать и скрин в придачу типа такого

01.png
Действительно, разработчики Kali Linux не очень то заморачиваютя с поддержкой новых чипов Wi-Fi адаптеров. В основном поддержка на уровне ядра используется для старых чипсетов RTL 8187L, Atheros AR9271, RT3572, RT3070.
25 апреля 2017 было объявлено о запуске Kali Linux 2017.1. При выпуске релиза было заявлено о поддержке
чипсетов RTL8812AU которые используются в адаптерах ALFA AWUS036ACH
AWUS036ACH.png
Есть такая поговорка:
Обещать – не значит жениться
Так вот, много людей купили эти адаптеры, расчитывая на то, что он будет работать из коробки, но не тут то было.
Хочу заявить, что настоящие ALFA AWUS036ACH, которые производятся на заводе Alfa Network Inc.
в Тайване не виноваты. Если этот адаптер не работает или работает, но не так как надо (имеется ввиду настоящая альфа), то это либо кривой дистрибутив, либо кривой драйвер, либо то и другое вместе взятые. Правда иногда бывают кривые руки и нехватка серого вещества в черепной коробке, но это отдельная история, и у нас на форуме таких людей НЕТ.
Теперь об установке драйвера.
Разработчики Kali рекомендуют делать это вводя поочерёдно команды в терминале:
Код:
apt-get update
apt install realtek-rtl88xxau-dkms
Если это не сработает, то ставим отсюда:

aircrack-ng/rtl8812au

На данный момент таким образом у нас установится драйвер v.5.1.5 от kimocoder.
02.png
Kimocoder этот в общем молодец, сначала он делал драйвера под этот чипсет для Arch, потом стал делать для Debian. Разработчики Kali просто включают его драйвер в репозиторий, начиная с Rolling 2017.1 не особо заботясь о работоспособности и совместимости драйвера с другими продуктами.
Драйвер этот в общем рабочий, работает с ядром 4.15, заявлено что поддерживает режим монитора и инжект, мощность по умолчанию 18 dBm
Здесь wlan1=RTL 8812AU
03.png
Можно поднять до 30 dBm
04.png
Но дело в том, что этот драйвер криво работает с aircrack-ng 1.2.
В частности в Fluxion 4.4 (а это стабильная версия по сравнению с 4.8 и 4.10) не дорабатывает завершение атаки, то есть жертва вводит валидный пароль, но он не верифицируется правильно и атака не завершается, хотя при вводе валидного пароля она должна прекратиться.
Ещё один драйвер который работает с ядром 4.15 это v.4.3.20

diederikdehaas/rtl8812AU

Очень нестабильный, много людей пытаются его поставить, но не у всех получается, то есть на одном железе ставится, на другом не ставится, не знаю с чем это связано. У меня установился. Вот что показывает iwconfig
05.png
Пытаюсь поднять мощность
Код:
Iwconfig wlan1 txpower 30
06.png
Код:
Iw wlan1 set txpower fixed 3000
07.png

Код:
Iwconfig wlan1 mode monitor
08.png

В общем только для сёрфинга. А нам это надо?

Ещё драйверы с поддержкой ядра 4.15

diederikdehaas/rtl8812AU

diederikdehaas/rtl8812AU

Тоже кривые, даже не заявлена работа в режиме монитора и инжекта

Наконец единственный драйвер который полностью раскрывает возможности RTL8812AU

aircrack-ng/rtl8812au

Однако есть одно НО, работает он с ядром 4.14 и ниже.
Итак перед установкой редактируем файл grub.cfg таким образом чтобы запуск происходил с ядра 4.14 или более раннего ядра, в зависимости от того с какого ядра вы обновлялись.
находится он /boot/grub/grub.cfg
Открываем редактором, ищем строку которая начинается так:
menuentry 'Kali GNU/Linux'
и далее меняем циферки с 4.15 на 4.14
не забываем сохраниться.
1.png
Перезагружаемся

Код:
uname –a

11.png
Установка:
12.png
13.png

Мощность по умолчанию 18 dBm

14.png

Меняем мощность на 30dBm

15.png

В общем ALFA с этим драйвером в приложениях использующих атаки на беспроводные сети (Fluxion 4.4, Airgeddon, Wifite, HT-WPS BREAKER и др.) ведёт себя вполне достойно и корректно.
И под конец конфетка.
Как то уже очень давно, уважаемый ghostphisher представлял здесь интересный инструмент HT-WPS-BREAKER.
Он работал в Кали, пока не обновился Reaver, потом долгое время этот инструмент никто не поддерживал и он в Rolling не работал. Сегодня я наткнулся на версию которую обновляли 3 месяца назад. Казалось бы WPS уже давно никто не пользуется, однако, ну в общем вот смотрите сами
16.png

Столько WPS сканировано

17.png

Столько взломано восстановлено (голубым цветом) за 40 мин

18.png

Вот такая красота
Берём здесь:

loco-sabek/HT-WPS-Breaker.loco

Желаю Удачи!
 

Вложения

Последнее редактирование:
20.07.2016
613
620
#3
Какие преимущества у RTL8812AU перед старыми RTL 8187L, Atheros AR9271, RT3572, RT3070 ?
Два диапазона 2.4GHz / 5GHz и одновременная работа в обоих диапазонах. Скорость до 300 Мбит / с для сети 2,4 ГГц и до 867 Мбит / с для сети 5.0 ГГц . А конкретно для ALFA awus036ACH очень высокая чувствительность и большая дальнобойность, а если ещё антенны поменять с 5dBi на 9dBi то "ВААЩЕ"
Сейчас уже не нужно менять регион на BO или BZ?
Для этого чипа нет. Команды для изменения мощности:
Код:
iwconfig wlan1 txpower 30
или
Код:
iw wlan1 set txpower fixed 3000
Для старых чипов


ifconfig wlan1 down && iwconfig wlan1 mode monitor && ifconfig wlan1 up ifconfig wlan1 down && macchanger -r wlan1 && iw reg set BZ && iwconfig wlan1 txpower 30 && ifconfig wlan1 up
 
Последнее редактирование:

yarr

Red Team
05.10.2017
201
378
#4
Тоже хотел пояснить за 036ACH, руки не доходили, отличная статья!
Оставьте, пожалуйста в покое txpower, на 036ACH его хоть 300000 программно можно выставить, но по факту там останется как было. 036ACH по чувствительности превосходит 036H. Лучше взять антенну направленную/панельную или усилитель.

Кстати, если iwconfig не видит адаптер, это не значит что его не видит ifconfig. Если слетели дрова, то данный адаптер все равно можно использовать для аудита (хотя его не будет видно в выдаче iwconfig).
 
Последнее редактирование:

Пила

New member
27.05.2018
1
0
#5
Это немного отходит от темы, но вопрос очень важный.

Началось с этого

1) Получаю ошибку при запуске make.
_____________________________________________________________________________________________________________________________________________________________________________
~/rtl8812au-5.1.5# make
/bin/sh: 1: bc: not found
make -j 4 ARCH=x86_64 CROSS_COMPILE= -C /lib/modules/4.14.0-kali3-amd64/build M=/root/.local/share/Trash/files/rtl8812au-5.1.5 modules
make[1]: *** /lib/modules/4.14.0-kali3-amd64/build: Нет такого файла или каталога. Останов.
Makefile:1911: ошибка выполнения рецепта для цели «modules»
make: *** [modules] Ошибка 2

---------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------

2) Ищу как найти и установить недостающий каталог - linux-headers-4.14.0-kali3-amd64.

2.1) Его нет, хотя репозитории на месте и apt-get update, apt-get upgrade, apt-get dist-upgrade -y я сделал;
_____________________________________________________________________________________________________________________________________________________________________________
apt-get install linux-headers-$(uname -r)
Чтение списков пакетов… Готово
Построение дерева зависимостей
Чтение информации о состоянии… Готово
E: Не удалось найти пакет linux-headers-4.14.0-kali3-amd64
E: Не удалось найти пакет с помощью glob «linux-headers-4.14.0-kali3-amd64»
E: Не удалось найти пакет с помощью regex «linux-headers-4.14.0-kali3-amd64»

---------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------

2.2) Далее искал этот каталог -
Для просмотра контента необходимо: Войти или зарегистрироваться
тут -
Для просмотра контента необходимо: Войти или зарегистрироваться


При попытке установить каталог .deb получаю ошибку
_____________________________________________________________________________________________________________________________________________________________________________
~/rtl8812au-4.3.21# apt-get install '/root/Загрузки/linux-headers-4.14.0-kali3-amd64_4.14.17-1kali1_amd64.deb'
Чтение списков пакетов… Готово
Построение дерева зависимостей
Чтение информации о состоянии… Готово
Заметьте, вместо «/root/Загрузки/linux-headers-4.14.0-kali3-amd64_4.14.17-1kali1_amd64.deb» выбирается «linux-headers-4.14.0-kali3-amd64»
Некоторые пакеты невозможно установить. Возможно, вы просите невозможного,
или же используете нестабильную версию дистрибутива, где запрошенные вами
пакеты ещё не созданы или были удалены из Incoming.
Следующая информация, возможно, поможет вам:


Пакеты, имеющие неудовлетворённые зависимости:
linux-headers-4.14.0-kali3-amd64 : Зависит: linux-headers-4.14.0-kali3-common (= 4.14.17-1kali1) но он не может быть установлен
Зависит: linux-kbuild-4.14 (>= 4.14.12-2~) но он не может быть установлен
E: Невозможно исправить ошибки, у вас отложены (held) битые пакеты.

---------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------

Версия:
_____________________________________________________________________________________________________________________________________________________________________________
uname -a
Linux MultiFruckt 4.14.0-kali3-amd64 #1 SMP Debian 4.14.12-2kali1 (2018-01-08) x86_64 GNU/Linux
---------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------

Главный вопрос - как установить или добавить каталог.deb в нужное место?
 
20.07.2016
613
620
#6
Это немного отходит от темы, но вопрос очень важный.

Началось с этого

1) Получаю ошибку при запуске make.
_____________________________________________________________________________________________________________________________________________________________________________
~/rtl8812au-5.1.5# make
/bin/sh: 1: bc: not found
make -j 4 ARCH=x86_64 CROSS_COMPILE= -C /lib/modules/4.14.0-kali3-amd64/build M=/root/.local/share/Trash/files/rtl8812au-5.1.5 modules
make[1]: *** /lib/modules/4.14.0-kali3-amd64/build: Нет такого файла или каталога. Останов.
Makefile:1911: ошибка выполнения рецепта для цели «modules»
make: *** [modules] Ошибка 2

---------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------

2) Ищу как найти и установить недостающий каталог - linux-headers-4.14.0-kali3-amd64.

2.1) Его нет, хотя репозитории на месте и apt-get update, apt-get upgrade, apt-get dist-upgrade -y я сделал;
_____________________________________________________________________________________________________________________________________________________________________________
apt-get install linux-headers-$(uname -r)
Чтение списков пакетов… Готово
Построение дерева зависимостей
Чтение информации о состоянии… Готово
E: Не удалось найти пакет linux-headers-4.14.0-kali3-amd64
E: Не удалось найти пакет с помощью glob «linux-headers-4.14.0-kali3-amd64»
E: Не удалось найти пакет с помощью regex «linux-headers-4.14.0-kali3-amd64»

---------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------

2.2) Далее искал этот каталог -
Для просмотра контента необходимо: Войти или зарегистрироваться
тут -
Для просмотра контента необходимо: Войти или зарегистрироваться


При попытке установить каталог .deb получаю ошибку
_____________________________________________________________________________________________________________________________________________________________________________
~/rtl8812au-4.3.21# apt-get install '/root/Загрузки/linux-headers-4.14.0-kali3-amd64_4.14.17-1kali1_amd64.deb'
Чтение списков пакетов… Готово
Построение дерева зависимостей
Чтение информации о состоянии… Готово
Заметьте, вместо «/root/Загрузки/linux-headers-4.14.0-kali3-amd64_4.14.17-1kali1_amd64.deb» выбирается «linux-headers-4.14.0-kali3-amd64»
Некоторые пакеты невозможно установить. Возможно, вы просите невозможного,
или же используете нестабильную версию дистрибутива, где запрошенные вами
пакеты ещё не созданы или были удалены из Incoming.
Следующая информация, возможно, поможет вам:


Пакеты, имеющие неудовлетворённые зависимости:
linux-headers-4.14.0-kali3-amd64 : Зависит: linux-headers-4.14.0-kali3-common (= 4.14.17-1kali1) но он не может быть установлен
Зависит: linux-kbuild-4.14 (>= 4.14.12-2~) но он не может быть установлен
E: Невозможно исправить ошибки, у вас отложены (held) битые пакеты.

---------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------

Версия:
_____________________________________________________________________________________________________________________________________________________________________________
uname -a
Linux MultiFruckt 4.14.0-kali3-amd64 #1 SMP Debian 4.14.12-2kali1 (2018-01-08) x86_64 GNU/Linux
---------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------

Главный вопрос - как установить или добавить каталог.deb в нужное место?
Во первых сначала установите bc
apt-get update
apt-get install bc
Во вторых пакеты .deb устанавливаются командой
dpkg -i имя пакета .deb
 
Вверх Снизу