Сальдо дебетовое на начало периода

Тема в разделе "1C и всё что с ней связано", создана пользователем UMonster, 18 фев 2009.

  1. UMonster

    UMonster Гость

    Пожалуйста, помогите получить остаток на начало периода по счету 41.2 и второму субконто. Если можно, то по подробней опишите, как это сделать
     
  2. KiR

    KiR НЕ шибка опытный програмер)
    1C Team

    Регистрация:
    11 сен 2007
    Сообщения:
    1.581
    Симпатии:
    0
    Элементарно через объект Бухгалтерские итоги. Хотя если у тебя восьмеркам - тады через запрос. Поэтому для начала определсь с платформой
     
  3. UMonster

    UMonster Гость

    У меня 1С v 7.7 B)
    Я пробую через процедуры СНД и СНДР, но ничего не получается

    ...
    Ит = СоздатьОбъект("БухгалтерскиеИтоги");
    Ит.ИспользоватьПланСчетов(ВыбранныйПланСчетов());
    Если Ит.ВыполнитьЗапрос(НачДата, КонДата, СчетПоКоду("41.2")) = 0 Тогда
    Возврат;
    КонецЕсли;

    Далее работаю с этим счетом, выбираю по проводкам, что мне надо, всё нормуль
    ...
    Потом пытаюсь получить д*цензура*овое сальдо

    Ит.СНД("41.2",1,,"Торговый офис") - пишет ошибку, что переданно слишком много параметров
    Ит.СНДРС("41.2",1, , " ","Торговый офис","!") - а при использовании этой функции вообще возращает ноль

    Если просто воспользоваться СНД() без пареметров, то он возращает сальдо полность по счету, а мне надо ещё и по второму субконту
    Кто ещё, что может посоветовать, народ подскажите -_-
     
  4. KiR

    KiR НЕ шибка опытный програмер)
    1C Team

    Регистрация:
    11 сен 2007
    Сообщения:
    1.581
    Симпатии:
    0
    Лучше сделай подругому:
    Код (Text):
    Ит = СоздатьОбъект("БухгалтерскиеИтоги");
    Ит.ИспользоватьПланСчетов(ВыбранныйПланСчетов());//используй только если несколько планов считов - иначе можешь закоментиь
    Ит.ИспользоватьСубконто();// Почитай в синтакс помощнике про нужные параметры
    Если Ит.ВыполнитьЗапрос(НачДата, КонДата, СчетПоКоду("41.2")) = 1 Тогда
    Если Ит.ВыбратьСубконто = 1 Тогда
    Пока Ит.ПолучитьСубконто() = 1 Цикл
    СуммарноеСальдо = Ит.СНД();
    КонецЦикла;
    КонецЕсли;
    КонецЕсли;
    Что-то типа этого вроде. Тока проверь грамматику, а то у мя периодически хромает
     
  5. kaa

    kaa Гость

    если выбираете по проводкам и т.д. тогда БИ.СНД("С");
     
  6. UMonster

    UMonster Гость

    Что-то ничего не клееться, посмотрел параметры, но ничего не пойму
     
  7. UMonster

    UMonster Гость

    Уже перепробывал сотню вариантов и не пшет, вот один из них
    Код (Text):
    ВидСубконто = "Торговый офис";
    Ит = СоздатьОбъект("БухгалтерскиеИтоги");
    //Ит.ИспользоватьПланСчетов(ВыбранныйПланСчетов());

    Ит.ИспользоватьСубконто(ВидыСубконто.МестаХранения, ВидСубконто, 1);
    Ит.ВыполнитьЗапрос(НачДата, КонДата, "41.2",,, 1,, "С");
    Ит.ВыбратьСубконто(ВидыСубконто.МестаХранения);
    Пока Ит.ПолучитьСубконто(ВидыСубконто.МестаХранения) = 1 Цикл
    Сообщить(Ит.СНД());
    КонецЦикла;
    Всем спасибо, всё, начал он мне его правильно считать
     
  8. KiR

    KiR НЕ шибка опытный програмер)
    1C Team

    Регистрация:
    11 сен 2007
    Сообщения:
    1.581
    Симпатии:
    0
    А ВидСубконто - это у тебя переменная которая содержит определенное место хранения? Попробуй так:
    Код (Text):
    Ит = СоздатьОбъект("БухгалтерскиеИтоги");
    Ит.ИспользоватьСубконто(ВидыСубконто.МестаХранения);
    Ит.ВыполнитьЗапрос(,КонДата, "41.2");
    Ит.ВыбратьСубконто(1);
    Пока Ит.ПолучитьСубконто() = 1 Цикл    
    Сообщить(Ит.СНД());   
    КонецЦикла;
    Еще какие есть нюансы - есть ли у тебя подсчета? И проверь через оборотку есть ли СНД на дату, которую ты делаешь запрос.
    Если же есть подсчета перед выполнением запроса поставь БухИт.ВключатьСубсчета(1);
     
  9. UMonster

    UMonster Гость

    Всем спасибо, всё, начал он мне его правильно считать

    Я так счастлив, спасибо вам и форуму :rolleyes:
     
Загрузка...
Похожие Темы - Сальдо дебетовое на
  1. Дайнеко
    Ответов:
    0
    Просмотров:
    1.112
  2. Natalya
    Ответов:
    6
    Просмотров:
    3.546

Поделиться этой страницей