Сальдо дебетовое на начало периода

  • Автор темы UMonster
  • Дата начала
U

UMonster

#1
Пожалуйста, помогите получить остаток на начало периода по счету 41.2 и второму субконто. Если можно, то по подробней опишите, как это сделать
 

KiR

НЕ шибка опытный програмер)
11.09.2007
1 581
0
#2
Элементарно через объект Бухгалтерские итоги. Хотя если у тебя восьмеркам - тады через запрос. Поэтому для начала определсь с платформой
 
U

UMonster

#3
У меня 1С v 7.7 B)
Я пробую через процедуры СНД и СНДР, но ничего не получается

...
Ит = СоздатьОбъект("БухгалтерскиеИтоги");
Ит.ИспользоватьПланСчетов(ВыбранныйПланСчетов());
Если Ит.ВыполнитьЗапрос(НачДата, КонДата, СчетПоКоду("41.2")) = 0 Тогда
Возврат;
КонецЕсли;

Далее работаю с этим счетом, выбираю по проводкам, что мне надо, всё нормуль
...
Потом пытаюсь получить д*цензура*овое сальдо

Ит.СНД("41.2",1,,"Торговый офис") - пишет ошибку, что переданно слишком много параметров
Ит.СНДРС("41.2",1, , " ","Торговый офис","!") - а при использовании этой функции вообще возращает ноль

Если просто воспользоваться СНД() без пареметров, то он возращает сальдо полность по счету, а мне надо ещё и по второму субконту
Кто ещё, что может посоветовать, народ подскажите -_-
 

KiR

НЕ шибка опытный програмер)
11.09.2007
1 581
0
#4
Лучше сделай подругому:
Код:
Ит = СоздатьОбъект("БухгалтерскиеИтоги");
Ит.ИспользоватьПланСчетов(ВыбранныйПланСчетов());//используй только если несколько планов считов - иначе можешь закоментиь
Ит.ИспользоватьСубконто();// Почитай в синтакс помощнике про нужные параметры
Если Ит.ВыполнитьЗапрос(НачДата, КонДата, СчетПоКоду("41.2")) = 1 Тогда
Если Ит.ВыбратьСубконто = 1 Тогда
Пока Ит.ПолучитьСубконто() = 1 Цикл
СуммарноеСальдо = Ит.СНД();
КонецЦикла;
КонецЕсли;
КонецЕсли;
Что-то типа этого вроде. Тока проверь грамматику, а то у мя периодически хромает
 
K
#5
если выбираете по проводкам и т.д. тогда БИ.СНД("С");
 
U

UMonster

#6
Что-то ничего не клееться, посмотрел параметры, но ничего не пойму
 
U

UMonster

#7
Уже перепробывал сотню вариантов и не пшет, вот один из них
Код:
ВидСубконто = "Торговый офис";
Ит = СоздатьОбъект("БухгалтерскиеИтоги");
//Ит.ИспользоватьПланСчетов(ВыбранныйПланСчетов());

Ит.ИспользоватьСубконто(ВидыСубконто.МестаХранения, ВидСубконто, 1);
Ит.ВыполнитьЗапрос(НачДата, КонДата, "41.2",,, 1,, "С");
Ит.ВыбратьСубконто(ВидыСубконто.МестаХранения); 
Пока Ит.ПолучитьСубконто(ВидыСубконто.МестаХранения) = 1 Цикл
Сообщить(Ит.СНД());
КонецЦикла;
Всем спасибо, всё, начал он мне его правильно считать
 

KiR

НЕ шибка опытный програмер)
11.09.2007
1 581
0
#8
А ВидСубконто - это у тебя переменная которая содержит определенное место хранения? Попробуй так:
Код:
Ит = СоздатьОбъект("БухгалтерскиеИтоги");
Ит.ИспользоватьСубконто(ВидыСубконто.МестаХранения);
Ит.ВыполнитьЗапрос(,КонДата, "41.2");
Ит.ВыбратьСубконто(1);
Пока Ит.ПолучитьСубконто() = 1 Цикл	  
Сообщить(Ит.СНД());	
КонецЦикла;
Еще какие есть нюансы - есть ли у тебя подсчета? И проверь через оборотку есть ли СНД на дату, которую ты делаешь запрос.
Если же есть подсчета перед выполнением запроса поставь БухИт.ВключатьСубсчета(1);
 
U

UMonster

#9
Всем спасибо, всё, начал он мне его правильно считать

Я так счастлив, спасибо вам и форуму :rolleyes: