сальдо по балансовым счетам

Тема в разделе "1C и всё что с ней связано", создана пользователем -, 18 фев 2010.

Статус темы:
Закрыта.
  1. Гость

    Добрый день!
    Не подскажите,что нужно изменить в процедуре,что бы выводил остатки ненулевого сальдо по балансовым счетам - вывести сальдо только по балансовым счетам.У меня выводит сальдо обработки,но что нужно изменить?!
    Спасибо заранее!

    Процедура Сформировать()
    Таб = СоздатьОбъект("Таблица");//будем все выводить в таблицу
    Ит = СоздатьОбъект("БухгалтерскиеИтоги");
    Ит.ВыполнитьЗапрос(ВыбНачПериода, ВыбКонПериода,,,, 1,, "С"); //выполняем
    запрос
    Таб.ВывестиСекцию("Шапка"); //выводим заголовок таблицы
    Таб.Опции(0,0,Таб.ВысотаТаблицы(),0);
    Ит.ВыбратьСчета(); //открываем выборку по счетам
    Пока Ит.ПолучитьСчет() = 1 Цикл
    сч=Ит.Счет;//получили номер счета
    //получаем итоги по каждому счету
    СНД=Ит.СНД();
    СНК=Ит.СНК();
    СКД=Ит.СКД();
    СКК=Ит.СКК();
    До=Ит.ДО();
    КО=Ит.КО();
    Таб.ВывестиСекцию("Счет");//выводим итоги в таблицу
    КонецЦикла;
    //а вот здесь, когда выборка не открыта (или уже закрыта)
    //можно получить отоги сразу по всем счетам.
    СНД=Ит.СНД();
    СНК=Ит.СНК();
    СКД=Ит.СКД();
    СКК=Ит.СКК();
    До=Ит.ДО();
    КО=Ит.КО();
    Таб.ВывестиСекцию("Подвал");
    Таб.ТолькоПросмотр(1);
    Таб.Показать("Сформировать","");
    КонецПроцедуры

    Процедура ПриОткрытии()
    //это чтобы не вводить каждый раз даты
    ВыбНачПериода = НачалоПериодаБИ();
    ВыбКонПериода = КонецПериодаБИ();
    КонецПроцедуры
     
  2. vbs

    vbs Well-Known Member

    Регистрация:
    18 фев 2007
    Сообщения:
    1.708
    Симпатии:
    3
    Подскажу : для начала стоит научиться формулировать свои вопросы, к тому же есть резон использовать русский язык, к которому приведенная выше тарабарщина
    имеет весьма отдаленное отношение
     
  3. Гость

    Тогда подскажите,что и как правильно должно быть!вывести сальдо только по балансовым счетам.
     
  4. Hryv

    Hryv Гость

    А в синтакс-помошнике посмотреть влом?

    Опции(<?>,)
    Синтаксис:
    Опции(<ВклЗабалансСуммы>,<ВклОборотСубкСуммы>)
    Назначение:
    Устанавливает режим включения сумм в итоги.
    Параметры:
    <ВклЗабалансСуммы> - признак включения в итоги сумм по забалансовым счетам. Число: 0 - не включаются суммы по забалансовым счетам; 1 - включаются суммы по забалансовым счетам.
    <ВклОборотСубкСуммы> -признак включения в итоги сумм по оборотным субконто. Число: 0 - не включаются суммы по оборотным суб-конто; 1 - включаются суммы по оборотным субконто.
     
  5. Гость

    в 1с 7.7 пойдет?
     
  6. Hryv

    Hryv Гость

    Павлов, загляните с синтакс-помощник
    узнаете много нового и интересного
     
  7. Гость

    не моглибы вы помочь мне в этом?
    описать процедуру. заранее спасибо от души)))

    Спс за совет - синтакс-помощник,не знал)))
     
  8. Hryv

    Hryv Гость

    Я же выложил уже описание
    просто скопированное из синтакс-помощника
     
  9. Гость


    спс))подскажите веточку по которой искать
     
  10. Hryv

    Hryv Гость

    Тебе что инструкцию по использованию хелпа написать :RTFM:
     
  11. Гость

    в моей справки к сожалению отсутствет данаая форма(( 7.7))

    Добавлено:
    спс огоромное за терпение нас "чайников")))спс отдуши за помощь!!!
    И ВСЕ РАВНО ОН НЕ ВЫДАЕТ ОСТАТКИ?В ЧЕМ Я ОШИБСЯ ОПЯТЬ?

    Процедура Сформировать()
    Таб = СоздатьОбъект("Таблица");//будем все выводить в таблицу
    Ит = СоздатьОбъект("БухгалтерскиеИтоги");
    Ит.ВыполнитьЗапрос(ВыбНачПериода, ВыбКонПериода,,,, 1,, "С"); //выполняем запрос
    Таб.ВывестиСекцию("Шапка"); //выводим заголовок таблицы
    Таб.Опции(1,0,Таб.ВысотаТаблицы(),0);
    Ит.ВыбратьСчета(); //открываем выборку по счетам
    Пока Ит.ПолучитьСчет() = 1 Цикл
    сч=Ит.Счет;//получили номер счета
    //получаем итоги по каждому счету
    СНД=Ит.СНД();
    СНК=Ит.СНК();
    СКД=Ит.СКД();
    СКК=Ит.СКК();
    До=Ит.ДО();
    КО=Ит.КО();
    Ит.СКД();//конечное сальдо дебитовое
    Ит.СКК();//конечное сальдо кредитовое
    Таб.ВывестиСекцию("Счет");//выводим итоги в таблицу
    КонецЦикла;
    //а вот здесь, когда выборка не открыта (или уже закрыта)
    //можно получить итоги сразу по всем счетам.
    СНД=Ит.СНД();
    СНК=Ит.СНК();
    СКД=Ит.СКД();
    СКК=Ит.СКК();
    До=Ит.ДО();
    КО=Ит.КО();
    Ит.СКД();//конечное сальдо дебитовое
    Ит.СКК();//конечное сальдо кредитовое
    ИТ.Опции(1,0);____________________________________________
    Таб.ВывестиСекцию("Подвал");
    Таб.ТолькоПросмотр(1);
    Таб.Показать("Сформировать","");
    КонецПроцедуры

    Процедура ПриОткрытии()
    //это чтобы не вводить каждый раз даты
     
  12. Hryv

    Hryv Гость

    ИТ.Опции надо делать до Ит.ВыполнитьЗапрос

    Если в от этого в цикле будет не то, что надо , тогда надо дважды делать Ит.ВыполнитьЗапрос
    Для счетов поотдельности и для всех вцелом
     
  13. Гость

    спс,и еще вопрос если позволите последний.
    как создать тут условие,что бы он вывод по признаку счета...когда признак забалансовый то невыводить.а остальные вывести?!

    за ранее спс
     
  14. Hryv

    Hryv Гость

    На этот вопрос я уже ответил
     
  15. Гость

     
  16. Гость

    ОГРОМНОЕ СПАСИБО всем За помощь!!!
     
Загрузка...
Статус темы:
Закрыта.

Поделиться этой страницей