Считывание из текста в реквизит

  • Автор темы Elle
  • Дата начала
Статус
Закрыто для дальнейших ответов.
E

Elle

Гость
#1
Я устала до такой степени что не вижу елементарной ошибки, и вынужденная обратиться к Вам форумчане, все работало, но от усталости что-то по-видимому изменила и непомню вообще ли что-то меняла. Суть вот в чем в журнале при выборе текущего документа, в реквизит текст записывается значение реквизита документа, из текста в диалог , где он изменяется и при нажатии кнопки изменяет документ, функция не корректно работает - присваивает значение в текст, из текста в диалог НомГТД, но при изменении в диалоге НомГТД, опять присваивает из текста тоже самое значение. Функция "висит" в формуле текста
Код:
Функция ПолучитьГТД()
Если ПустоеЗначение(ТекущийДокумент)=0 Тогда
Если ТекущийДокумент.вид() = "ГТД" Тогда			
текст =СокрЛП(Текущийдокумент.ГТДТаможня);
Если Лев(НомГТД,СтрДлина(текст)) <> СокрЛП(текст) Тогда				
НомГТД = текст; 

КонецЕсли;			
КонецЕсли;		
Иначе 
текст="";
НомГТД="";
КонецЕсли;	
Возврат текст;
КонецФункции
Добавлено:
Я устала до такой степени что не вижу елементарной ошибки, и вынужденная обратиться к Вам форумчане, все работало, но от усталости что-то по-видимому изменила и непомню вообще ли что-то меняла. Суть вот в чем в журнале при выборе текущего документа, в реквизит текст записывается значение реквизита документа, из текста в диалог , где он изменяется и при нажатии кнопки изменяет документ, функция не корректно работает - присваивает значение в текст, из текста в диалог НомГТД, но при изменении в диалоге НомГТД, опять присваивает из текста тоже самое значение. Функция "висит" в формуле текста
Код:
Функция ПолучитьГТД()
Если ПустоеЗначение(ТекущийДокумент)=0 Тогда
Если ТекущийДокумент.вид() = "ГТД" Тогда			
текст =СокрЛП(Текущийдокумент.ГТДТаможня);
Если Лев(НомГТД,СтрДлина(текст)) <> СокрЛП(текст) Тогда				
НомГТД = текст; 

КонецЕсли;			
КонецЕсли;		
Иначе 
текст="";
НомГТД="";
КонецЕсли;	
Возврат текст;
КонецФункции
:ya_lamo: хм уже опять что поменяла и работает, вот только если значение пустое в документе, диалогу присваиваеться которое не пустое было перед етим
Тема закрыта.
 
Статус
Закрыто для дальнейших ответов.