1. Набираем команду codeby webinar. Набираем команду для организации и проведения вебинаров. Подробнее ...

    Скрыть объявление
  2. Требуются разработчики и тестеры для проекта codebyOS. Требования для участия в проекте: Знание принципов работы ОС на базе Linux; Знание Bash; Крайне желательное знание CPP, Python, Lua; Навыки системного администрирования. Подробнее ...

    Скрыть объявление
  3. Получи 30.000 рублей. Для получения денег необходимо принять участие в конкурсе авторов codeby. С условиями и призами можно ознакомиться на этой странице ...

    Внимание! Регистрация авторов на конкурс закрыта.

    Скрыть объявление

Считывание из текста в реквизит

Тема в разделе "Базы данных и администрирование", создана пользователем Elle, 14 окт 2010.

Статус темы:
Закрыта.
  1. Elle

    Elle Гость

    Репутация:
    0
    Я устала до такой степени что не вижу елементарной ошибки, и вынужденная обратиться к Вам форумчане, все работало, но от усталости что-то по-видимому изменила и непомню вообще ли что-то меняла. Суть вот в чем в журнале при выборе текущего документа, в реквизит текст записывается значение реквизита документа, из текста в диалог , где он изменяется и при нажатии кнопки изменяет документ, функция не корректно работает - присваивает значение в текст, из текста в диалог НомГТД, но при изменении в диалоге НомГТД, опять присваивает из текста тоже самое значение. Функция "висит" в формуле текста
    Код:
    Функция ПолучитьГТД()
    Если ПустоеЗначение(ТекущийДокумент)=0 Тогда
    Если ТекущийДокумент.вид() = "ГТД" Тогда			
    текст =СокрЛП(Текущийдокумент.ГТДТаможня);
    Если Лев(НомГТД,СтрДлина(текст)) <> СокрЛП(текст) Тогда				
    НомГТД = текст; 
    
    КонецЕсли;			
    КонецЕсли;		
    Иначе 
    текст="";
    НомГТД="";
    КонецЕсли;	
    Возврат текст;
    КонецФункции
    Добавлено:
    :ya_lamo: хм уже опять что поменяла и работает, вот только если значение пустое в документе, диалогу присваиваеться которое не пустое было перед етим
    Тема закрыта.
     
Загрузка...
Статус темы:
Закрыта.

Поделиться этой страницей