серийный номера

Renat11111

Well-known member
20.04.2008
123
0
#1
Добрый день!
УТ 10.3

В документе поступления нужно поставить кнопку и ревизит поле ввода. Из этого поля ввода (тип строка) беру значение. Ну так вот нужно занести
это значение в подчиненны справоник Серийные номера по каждой номенклатуре документа + в таб части документа отобразить это значение.
Не могу додумать запрос, дайте наводку плиз как делать там уже сам додумаю. уверен кто то сталкивался с этой проблемой. Заранее спасибо
 
T

Typhoon

#2
Уважаемый а чем Вас не устраивает стандартный механизм работы с серийными номерами? Вроде бы он довольно грамотно все делает?!!
 

Renat11111

Well-known member
20.04.2008
123
0
#3
Что не нравится??? пытаюсь использовать серии как партии...... нужно в доументе например указать 09 партия для всей номенклатуры табличной части, а не вручную создавать серию для каждой номенклатуры... вот это и не нравилось. впрочем давно уже сделал если кому интересно:

Процедура СформироватьСерииНажатие(Элемент)
//МассивТоваров = новый Массви;
//МассивТоваров=Товары.ВыгрузитьКолонку("Номенклатура");
запрос = новый Запрос;
Запрос.УстановитьПараметр("ТекущийДокумент", ЭтотОбъект.Ссылка);
Запрос.Текст =
"ВЫБРАТЬ РАЗЛИЧНЫЕ
| ПоступлениеТоваровУслуг.Номенклатура.Ссылка Как Номенклатура
|ИЗ
| Документ.ПоступлениеТоваровУслуг.Товары КАК ПоступлениеТоваровУслуг
|ГДЕ
| ПоступлениеТоваровУслуг.Ссылка = &ТекущийДокумент";


СправочникСерии = Справочники.СерииНоменклатуры;
ВыборкаЗапрос = Запрос.Выполнить().Выбрать();
Пока ВыборкаЗапрос.Следующий() цикл
ТекВладелецСерии = ВыборкаЗапрос.Номенклатура;
НайденнаяСсылка=СправочникСерии.НайтиПоНаименованию(СерияДока,,,ТекВладелецСерии
);
Если (НайденнаяСсылка<>СправочникСерии.ПустаяСсылка())
и (НайденнаяСсылка.Владелец=ТекВладелецСерии) Тогда
Сообщить("Для товара"+ТекВладелецСерии+"уже определен серийный номер"+СерияДока);
продолжить;
КонецЕсли;

СправочникОбъект=СправочникСерии.СоздатьЭлемент();
справочникОбъект.Владелец = ТекВладелецСерии;
СправочникОбъект.Наименование = СерияДока;
СправочникОбъект.Записать();
КонецЦикла;

КолвоСтрокТабЧасти = Товары.Количество();
Для ин = 0 по КолвоСтрокТабЧасти-1 Цикл
ТекСтрокаТабЧасти=Товары.Получить(ин);
ТекСтрокаТабЧасти.СерияНоменклатуры = СправочникСерии.НайтиПоНаименованию
(СерияДока,,,ТекСтрокаТабЧасти.Номенклатура);
КонецЦикла;
КонецПроцедуры