Сканеры ШК-терминальный сервер.Проблема...

Тема в разделе "1C и всё что с ней связано", создана пользователем blackberry7230, 1 ноя 2009.

Статус темы:
Закрыта.
  1. blackberry7230

    blackberry7230 Гость

    Сервер Win 2003 Server SP2,лицезия.
    Клиенты WinXP Pro SP2,лицнзия.
    Сканеры Eclipse по com.
    1С 7.7.
    Терминал поднят.Порты проброшены и у клиентов и на сервере(на сервере захожу в настройки терминала и ставлю галку сопоставить com порты,у клиентов в дополнительно на подключении к удаленному раб.столу).
    Сервер не имеет физического com-порта.
    Есть scanpost.dll и scaner1c.dll.
    Ругается на “не удалось получить монопольный доступ“.
    Как на клиентских машинах заставить работать сканеры ШК.
    Раньше,при работе без сервера сканеры работали.
    Спасибо.
     
  2. gorlanovmax

    gorlanovmax Well-Known Member
    1C Team

    Регистрация:
    19 июн 2008
    Сообщения:
    286
    Симпатии:
    0
    Попробуй вот такую компоненту:

    ЕстьСканер=0;
    ПортОткрыт=0;
    ПутьКФНастройки=КаталогПользователя()+"BCS.txt";
    Если ФС.СуществуетФайл(ПутьКФНастройки)=1 Тогда
    Если ЗагрузитьВнешнююКомпоненту ("AddInCom.dll")=0 Тогда
    Сообщить("Ошибка при загрузке компоненты AddInCom.dll");
    КонецЕсли;
    Попытка
    ШКСканер = СоздатьОбъект("AddIn.CommDriver");
    ЕстьСканер = 1;
    ФНастройки=СоздатьОбъект("Текст");
    ФНастройки.Открыть(ПутьКФНастройки);
    НомерКОМПорта=ФНастройки.ПолучитьСтроку(1);
    НомерКОМПорта=СокрЛП(НомерКОМПорта);
    Если ШКСканер.ОткрытьПорт(СокрЛП(НомерКОМПорта))=1 Тогда;
    ПортОткрыт=1;
    Предупреждение("Сканер штрихкода упешно подключен!!!");
    КонецЕсли;
    Если ПортОткрыт=0 Тогда
    Предупреждение("Не удалось подключить сканер штрихкода!!!");
    КонецЕсли
    Исключение
    Сообщить("Ошибка создания объекта внешней компоненты для работы со сканером штрихкода");
    ЕстьСканер = 0;
    КонецПопытки;
    КонецЕсли;

    Код вставить в глобальный модуль, в процедуру ПриНачалеРаботыСистемы()

    В текстовом файле в каталоге пользователя указывается номер ком-порта текущего пользователя в формате "COM1"
    Если текстового файла нет, то сканер не подключается.

    У меня уже полгода все работает на ОК
     

    Вложения:

    • AddInCom.rar
      Размер файла:
      117,8 КБ
      Просмотров:
      27
  3. kaa

    kaa Гость

    Посмотри что б не совпадали имена портов на клиентских машинах(переименуй)
     
  4. blackberry7230

    blackberry7230 Гость

    Спасибо.Надеюсь сегодня доделать.Отпишусь какой способ мне помог.
     
  5. blackberry7230

    blackberry7230 Гость

    Сканеры соединились после того как на клиентах сделал порты ком разными,теперь на сервере так как нет физического ком-порта вылетает не удалось подсоединить устройство-оно и понятно пора ведь нет,а на выходе сканер дает крякозябры соответственно товар по ШК не находит о чем и сообщает.Локально в гипертерминале сканеры считывают правильно.Всетаки придется добавлять физический ком-порт??
     
  6. Hry

    Hry Гость

    попробуйте использовать net use
     
  7. kaa

    kaa Гость

    посмотри инструкцию к сканеру там должны быть штрих коды для настройки сканера. скорее всего не совпадают типы штрих кодов
     
  8. Pro

    Pro Гость

    а некто не задавался вопросом какой минимльный должен быть канал до сервера что бы работал СШ и ФР по терминалу?
     
  9. blackberry7230

    blackberry7230 Гость

    Итак,все получилось.Всем спасибо.
    Все оказалось намного проще.Как напомню на сервере не было физического COM-порта,для чистоты экперемента в сервак воткнули PCI-ную платку с двумя портами.Подсоединили и настроили локально сканер.
    На клиентских машинах обозвали порты как на сервере - com2.Проверяю гипртерминалом,все ОК.Соединяюсь.Смотрю change port /query,нормально,COM2 порт прокинут на tsclient\COM2,захожу в 1с в настройках сканер-шк ставлю порт ком2,ставлю подсоединить- молча проглатывает.Выхожу с 1с.Захожу снова о чудо товар ищется.Все просто :) .
     
  10. Umka

    Umka Гость

    а LPT порта если нет на сервере, а мне надо подключить на локальную машину LPT принтер и чтобы он печатал из 1ски, установленной на сервере как быть? их тоже надо "пробросить" на сервере аналогичным образом?
     
  11. kaa

    kaa Гость

    в свойствах соединения поставь в локальных ресурсах галочку
     
  12. blackberry7230

    blackberry7230 Гость

    У нас принтеры безвопросов пошли,в т.ч. и LPT-шные,хотя на сервере нет физический порта...Правда поднят принтсервер.Посмотрите у клиентов галочка стоит на сопоставление принтеров...Была с заморочка с принтером Зебра,но она решилась добавлением драйверов на сервер.
     
Загрузка...
Статус темы:
Закрыта.

Поделиться этой страницей