Сохранение настроек отчета

Тема в разделе "1C и всё что с ней связано", создана пользователем Eternity, 14 май 2007.

Статус темы:
Закрыта.
  1. Eternity

    Eternity Гость

    Необходимо добавить в отчет(нетиповой), созданный с помощью построителя, сохранение набора настроек(как в стандартных отчетах). В данный момент сохраняется только один(последний вариант настроек)

    В данный момент текст модуля, отвечающий за сохранение настроек выглядит так:

    Процедура ПриЗакрытии()

    СохранитьЗначение("НастройкаВнешниеОтчетыВнешнийОтчет1Отчет_60b07b44-7fcb-41cf-88dc-e2c0d556680b", ПостроительОтчетаОтчет.ПолучитьНастройки());

    КонецПроцедуры

    Процедура ДействияФормыОтчетНастройка(Кнопка)
    Форма = ВнешнийОтчетОбъект.ПолучитьФорму("ОтчетНастройка");
    Форма.ПостроительОтчета = ПостроительОтчетаОтчет;
    Настройка = ПостроительОтчетаОтчет.ПолучитьНастройки();
    Если Форма.ОткрытьМодально() = Истина Тогда
    ОтчетВывести();
    Иначе
    ПостроительОтчетаОтчет.УстановитьНастройки(Настройка);
    КонецЕсли;

    КонецПроцедуры

    Процедура ОтчетИнициализация()
    ..................................
    Настройка = ВосстановитьЗначение("НастройкаВнешниеОтчетыВнешнийОтчет1Отчет_60b07b44-7fcb-41cf-88dc-e2c0d556680b");
    Если Настройка <> Неопределено Тогда
    ПостроительОтчетаОтчет.УстановитьНастройки(Настройка);
    КонецЕсли;
    КонецПроцедуры
     
  2. GOsha

    GOsha Гость

    Странно, я думал на всех формочках наверху треугольнички со стрелочками есть, для сохранения настроек.
     
Загрузка...
Статус темы:
Закрыта.

Поделиться этой страницей