Создать отчет

Тема в разделе "1C и всё что с ней связано", создана пользователем -, 5 апр 2009.

Статус темы:
Закрыта.
  1. Гость

    не могу выбрать из регистра данный. Выходит просто пустой отчет.
    Процедура Сформировать()
    Перем Запрос, ТекстЗапроса, Таб;
    //Создание объекта типа Запрос
    Запрос = СоздатьОбъект("Запрос");
    ТекстЗапроса =
    "//{{ЗАПРОС(Сформировать)
    // |Наименование = Регистр.рег_групп_тов.группа_товара.Наименование;
    |сумма = Регистр.рег_групп_тов.сумма;
    |группа_товара = Регистр.рег_групп_тов.группа_товара;
    |Функция суммаНачОст = НачОст(сумма);
    // |Группировка Наименование без групп;
    |"//}}ЗАПРОС
    ;
    // Если ошибка в запросе, то выход из процедуры
    Если Запрос.Выполнить(ТекстЗапроса) = 0 Тогда
    Возврат;
    КонецЕсли;

    // Подготовка к заполнению выходных форм данными запроса
    Таб = СоздатьОбъект("Таблица");
    Таб.ИсходнаяТаблица("Сформировать");
    // Заполнение полей "Заголовок"
    Таб = СоздатьОбъект("Таблица");
    Таб.ИсходнаяТаблица("Сформировать");
    Таб.ВывестиСекцию("Заголовок");
    Состояние("Заполнение выходной таблицы...");
    Таб.Опции(0, 0, Таб.ВысотаТаблицы(), 0);
    Пока Запрос.Группировка(1) = 1 Цикл
    // Заполнение полей Наименование
    Таб.ВывестиСекцию("Наименование");
    КонецЦикла;
    // Заполнение полей "Итого"
    Таб.ВывестиСекцию("Итого");
    // Вывод заполненной формы
    Таб.ТолькоПросмотр(1);
    Таб.Показать("Сформировать", "");
    КонецПроцедуры
     
  2. vbs

    vbs Well-Known Member

    Регистрация:
    18 фев 2007
    Сообщения:
    1.708
    Симпатии:
    3
    период в запрос вставь
     
  3. Гость

    не помогло
     
  4. unknown181538

    unknown181538 НеГуру
    1C Team

    Регистрация:
    28 дек 2008
    Сообщения:
    1.418
    Симпатии:
    0
    Группировку, думаю, раскомментарить надо.
     
Загрузка...
Статус темы:
Закрыта.

Поделиться этой страницей