Спасайте!

  • Автор темы kotikov
  • Дата начала
Статус
Закрыто для дальнейших ответов.
K

kotikov

Гость
#1
Создаешь заявку, тыкаешь "Подбор", а в ответ :
УстановитьОтбор(,);
{Справочник.Номенклатура.ФормаСписка.ДляПодбора.Модуль(630)}: Неверное имя реквизита!
:)
 

vitfil

IT-интегратор
02.04.2004
2 062
0
#2
Что делали перед тем, как начала ошибка вылазить?
 

vitfil

IT-интегратор
02.04.2004
2 062
0
#5
"Нет, раджа, спасай себя сам!" (с) "Золотая антилопа".
Оно либо не работало изначально, либо вы что-то сделали, чтобы оно перестало работать. Вы же понимаете, что только ваша откровенность поможет вам.
 
K

kotikov

Гость
#6
так в том то и дело, и что ничего не делали, последний раз с базой работали 11.01-сделали неподтвержденную заявку, 12.01 комп даже не включался, а сегодня с утра ошибка
 

KiR

НЕ шибка опытный програмер)
11.09.2007
1 581
0
#7
если никто ничо не делал - восстановите архив базы за 11.01 и все
 

KiR

НЕ шибка опытный програмер)
11.09.2007
1 581
0
#9
а у вас вообще база архивируется? и существует ли ответственный человек за 1С?
 

vbs

Well-Known Member
18.02.2007
1 708
3
#11
Прежде всего, стоит убедиться в правильности формирования списка параметров при вызове из документа формы списка для подбора
 
K

kotikov

Гость
#12
// ОтборПоВключениюВпрайс ()
//
// Параметры:
// Нет
//
// Возвращаемое значение:
// Нет
//
// Описание:
// Устанавливается при необходимости отбор в справочнике "Номенклатура" по флагу
// включения в прайс
//
Процедура ОтборПоВключениюВпрайс ()

Если ВключатьВпрайс = 1 Тогда
УстановитьОтбор ( "НеВключатьВпрайс", 0);
Иначе
УстановитьОтбор (, );
КонецЕсли;

КонецПроцедуры // ОтборПоВключениюВпрайс ()

//****************************************************************************
// УправлениеВидимостью (ВидимостьКолонок)
//
// Параметры:
// ВидимостьКолонок
//
// Возвращаемое значение:
// Нет
//
// Вызывается из формул элементов диалога:
// При изменении флага "ПоказыватьОстаткиЦену"
//
// Описание:
// Управляет видимостью колонок списка справочника в зависимости от установленных настроек
//
Процедура УправлениеВидимостью ( ВидимостьКолонок)

Перем ОбщВидимость, ВидимостьЦены;

// видмость колонки остаток
ВидимостьЦен = ВидимостьКолонок * ?(ЦенаВподборе <> "Нет", 1, 0);
//МихН
//Форма.Остаток.Видимость (ВидимостьКолонок);
Форма.Ост1.Видимость (ВидимостьКолонок);
Форма.Резерв1.Видимость (ВидимостьКолонок);
Форма.ОстатокПофирме.Видимость (0);
//МихК
Форма.ЕдиницаНоменклатуры.Видимость (ВидимостьКолонок);
//Форма.ВалютаНоменклатуры.Видимость (ВидимостьЦен);
КонецПроцедуры // УправлениеВидимостью ()
 
H

Hryv

Гость
#13
если действительно ничего не меняли, то или раньше всегда ВключатьВпрайс было равно 1 или на момент когда ВключатьВпрайс было равно 0 отбор был уже включен

возможно ВключатьВпрайс это какой-то флажок (у меня сейчас нет аналогичной конфы под рукой чтобы посмотреть)
если это флажок на форме, то включите его и не парьтесь

хотя можно и код подправить

Добавлено: например так будет надежнее

Код:
Процедура ОтборПоВключениюВпрайс ()

Если ВключатьВпрайс = 1 Тогда
УстановитьОтбор ( "НеВключатьВпрайс", 0);
Иначе 
ИО = "";
ПолучитьОтбор(ИО,);
Если ИО="НеВключатьВпрайс" Тогда
УстановитьОтбор(, );
КонецЕсли;
КонецЕсли;

КонецПроцедуры // ОтборПоВключениюВпрайс ()
 

KiR

НЕ шибка опытный програмер)
11.09.2007
1 581
0
#15
у меня сейчас нет аналогичной конфы под рукой
как будь-то автор счел нужным указать конфу... :angry:

не думаю что автору стоит лезть в код!
 
H

Hryv

Гость
#16
как будь-то автор счел нужным указать конфу...
я предполагаю, что это конфа ТиС
если бы оказалось что не она, то у меня аналогичной тем более нет :angry:
(с учетом, что это явно не бух)


не думаю что автору стоит лезть в код!
при любом раскладе ошибка есть и ее лучше исправить хотябы так, чем никак
 
K

kotikov

Гость
#17
Конфа ТиС 7.70.025
Есть еще вопрос
В справочнике номенклатуры не отображается дерево папок, можно как нить исправить?
Если нет, то может существует какой нибудь способ по перемещению номенклатуры из одной папки в другую не связанный с деревом папок?
 
H

Hryv

Гость
#18
В другой теме puh14 тебе уже ответил
мне добавить нечего

Добавлено: кстати, в правилах написано

Правила сказал(а):
4.4. Запрещается создание тем:
...
4.4.3. Имеющих малозначащее название. Название должно отражать суть Вашего вопроса или сообщения. За названия подобные "Памагите пажалуста", "Вася ответь", "У меня праблема"...
 
Статус
Закрыто для дальнейших ответов.