Список и подбор

Тема в разделе "1C и всё что с ней связано", создана пользователем Naomenko, 2 окт 2008.

Наш партнер Genesis Hackspace
  1. Naomenko

    Naomenko Гость

    Подскажите как сделать подбор программно?
    есть код кнопки:
    ВыбратьПредст(0)

    в модуле:
    [codebox]
    Процедура ВыбратьПредст(Реж)
    Перем Тек;
    Перем Фрм;
    Если ВыбПредст.РазмерСписка()>0 Тогда
    Тек=ВыбПредст.ПолучитьЗначение(ВыбПредст.ТекущаяСтрока());
    КонецЕсли;
    ОткрытьПодбор("Справочник.Сотрудники",,Фрм,Реж,Тек);
    Фрм.ВыборГруппы(1);
    КонецПроцедуры
    [/codebox]

    мне надо написать код, чтоб при нажатии кнопки в список добовлялись сразу 4 постоянных сотрудников, а не сидеть и нежимать подбором сотрудников.

    вообщем попытался сделать и решил создать кнопку с привызкой Чдш(), в модуле:
    [codebox]
    Процедура Чдш()
    Док = СоздатьОбъект("Справочник.Сотрудники");
    Док.ВыбратьЭлементы();
    Пока Док.ПолучитьЭлемент()=1 Цикл
    если найти(док.код,"00000018")<>0 тогда
    ВыбПредст.ДобавитьЗначение(док);
    Док.ВыборГруппы(1);
    конецесли;
    КонецЦикла;
    конецпроцедуры
    [/codebox]
    вообщем в список добовляеться, но при формированиии тоблицы, показывает вообщем ничего, как будето ничего и не выбрали
     
Загрузка...

Поделиться этой страницей