1. Наш канал codeby в telegram. Пишем об информационной безопасности, методах защиты информации, о программировании. Не пропускай новости с кодебай, будь в тренде ! Подробнее ...

    Скрыть объявление

Сравнение строчек

Тема в разделе "Базы данных и администрирование", создана пользователем Ugrumi, 26 окт 2007.

Статус темы:
Закрыта.
  1. Ugrumi

    Ugrumi Гость

    Репутация:
    0
    Проблем в названии фирмы, в справочнике забита фирма с названием таким (ООО "Сибирьконтракт")
    Мне нужно установить фильтр:
    Если Фирма=("ООО "Сибирьконтракт"") Тогда
    Номер="АС-"+"0001";
    КонецЕсли;

    Если Фирма=("ООО "Барнаульский"+ ЗКПД"") Тогда
    Номер="АБ-"+"0001";
    КонецЕсли;

    Если Фирма=("ООО "БЗКПД"") Тогда
    Номер="АД-"+"0001";
    КонецЕсли;

    Мне выдает такую вот ошибку: "Ожидается символ ')' " если без скобок тогда (Ожидается "then\тогда "). Подскажите пожайлусто как бороться с такой бедой?
     
  2. Isabela

    Isabela Гость

    Репутация:
    0
    Попробуй так :)
    if TrimR(Фирма.Наименование)="ООО "+"Сибирьконтракт" then
    или так :
    if Find(Фирма.Наименование,"Сибирьконтракт") > 0 then
     
  3. Typhoon

    Typhoon Гость

    Репутация:
    0
    А лучше всего писать так
    Если Фирма=("ООО """Сибирьконтракт""") Тогда
    Номер="АС-"+"0001";
    КонецЕсли;

    Просто нужно немножко размышлять что нужно кавычки по другому ставить"""

    :)
     
  4. Isabela

    Isabela Гость

    Репутация:
    0
    Синтаксис правильный, но боюсь, не сработает. Сравнивать строку надо все же с Фирма.Наименование.
    И вообще, зачем скобки ?
     
  5. Typhoon

    Typhoon Гость

    Репутация:
    0
    Для: Isabela Согласен с Изабелой но а вдруг он уже присвоил имя переменной Фирма. Короче я так пологаю вопрос закрыт!
     
Загрузка...
Похожие Темы - Сравнение строчек
  1. Erlan
    Ответов:
    8
    Просмотров:
    1.840
  2. k85
    Ответов:
    2
    Просмотров:
    1.291
  3. clas
    Ответов:
    3
    Просмотров:
    1.717
  4. juk-777
    Ответов:
    29
    Просмотров:
    5.129
  5. aank10
    Ответов:
    3
    Просмотров:
    2.084
Статус темы:
Закрыта.

Поделиться этой страницей