Сравнение строчек

Тема в разделе "1C и всё что с ней связано", создана пользователем Ugrumi, 26 окт 2007.

Статус темы:
Закрыта.
  1. Ugrumi

    Ugrumi Гость

    Проблем в названии фирмы, в справочнике забита фирма с названием таким (ООО "Сибирьконтракт")
    Мне нужно установить фильтр:
    Если Фирма=("ООО "Сибирьконтракт"") Тогда
    Номер="АС-"+"0001";
    КонецЕсли;

    Если Фирма=("ООО "Барнаульский"+ ЗКПД"") Тогда
    Номер="АБ-"+"0001";
    КонецЕсли;

    Если Фирма=("ООО "БЗКПД"") Тогда
    Номер="АД-"+"0001";
    КонецЕсли;

    Мне выдает такую вот ошибку: "Ожидается символ ')' " если без скобок тогда (Ожидается "then\тогда "). Подскажите пожайлусто как бороться с такой бедой?
     
  2. Isabela

    Isabela Гость

    Попробуй так :)
    if TrimR(Фирма.Наименование)="ООО "+"Сибирьконтракт" then
    или так :
    if Find(Фирма.Наименование,"Сибирьконтракт") > 0 then
     
  3. Typhoon

    Typhoon Гость

    А лучше всего писать так
    Если Фирма=("ООО """Сибирьконтракт""") Тогда
    Номер="АС-"+"0001";
    КонецЕсли;

    Просто нужно немножко размышлять что нужно кавычки по другому ставить"""

    :)
     
  4. Isabela

    Isabela Гость

    Синтаксис правильный, но боюсь, не сработает. Сравнивать строку надо все же с Фирма.Наименование.
    И вообще, зачем скобки ?
     
  5. Typhoon

    Typhoon Гость

    Для: Isabela Согласен с Изабелой но а вдруг он уже присвоил имя переменной Фирма. Короче я так пологаю вопрос закрыт!
     
Загрузка...
Статус темы:
Закрыта.

Поделиться этой страницей