Сравнение строчек

  • Автор темы Ugrumi
  • Дата начала
Статус
Закрыто для дальнейших ответов.
U

Ugrumi

#1
Проблем в названии фирмы, в справочнике забита фирма с названием таким (ООО "Сибирьконтракт")
Мне нужно установить фильтр:
Если Фирма=("ООО "Сибирьконтракт"") Тогда
Номер="АС-"+"0001";
КонецЕсли;

Если Фирма=("ООО "Барнаульский"+ ЗКПД"") Тогда
Номер="АБ-"+"0001";
КонецЕсли;

Если Фирма=("ООО "БЗКПД"") Тогда
Номер="АД-"+"0001";
КонецЕсли;

Мне выдает такую вот ошибку: "Ожидается символ ')' " если без скобок тогда (Ожидается "then\тогда "). Подскажите пожайлусто как бороться с такой бедой?
 
I

Isabela

#2
Попробуй так :)
if TrimR(Фирма.Наименование)="ООО "+"Сибирьконтракт" then
или так :
if Find(Фирма.Наименование,"Сибирьконтракт") > 0 then
 
T

Typhoon

#3
А лучше всего писать так
Если Фирма=("ООО """Сибирьконтракт""") Тогда
Номер="АС-"+"0001";
КонецЕсли;

Просто нужно немножко размышлять что нужно кавычки по другому ставить"""

:)
 
I

Isabela

#4
Синтаксис правильный, но боюсь, не сработает. Сравнивать строку надо все же с Фирма.Наименование.
И вообще, зачем скобки ?
 
T

Typhoon

#5
Для: Isabela Согласен с Изабелой но а вдруг он уже присвоил имя переменной Фирма. Короче я так пологаю вопрос закрыт!
 
Статус
Закрыто для дальнейших ответов.