Страница ушла

SeverBap

Well-known member
18.09.2007
451
0
#1
Проблема есть отчет в нем шапка с высотой по функции ТаблицаВысота()=5 (на самом деле там если подумать 10), эту шапку вывожу один раз в самом начале! В отчете есть таблица динамическая (завист от строк в документе) примерные поля: номерстроки, НомерУдостоверения - числовые хорошо без проблем и два ФИО и должность - строковые (данные из справочника тяну) - могут переходить на новую строку (стоит свойство переносить текст в колонке - ну вообщем вы поняли);
Суть проблемы надо их разбить по страницам, чтобы было все как надо (шапка таблицы повторяется на каждой странице с номером соответсвующей страницы), жесткое указание количества строк не помогает.... все поперепробовал ... незнаю как быть сейчас у меня такой листинг:
Код:
ТаблицаВывода=СоздатьОбъект("Таблица");
ТаблицаВывода.ИсходнаяТаблица("СписокРаботников");
ТаблицаВывода.Опции(0,0,0,0);
ТаблицаВывода.ВывестиСекцию("ШапкаСписка");
НомерЛиста=1;
ТаблицаВывода.ВывестиСекцию("НомерЛиста");
ТаблицаВывода.ВывестиСекцию("ШапкаТаблицы");
КоличествоСтрокВОтчетаНаСтранице=ТаблицаВывода.ВысотаТаблицы(); //ставлю 10, все работает но данные остальные портяся из-за сотрудника и должности
НомерПункта=1;
ВыбратьСтроки();
Пока ПолучитьСтроку()=1 Цикл
ТаблицаВывода.ВывестиСекцию("СтрокаДанных");
НомерПункта=НомерПункта+1;
КоличествоСтрокВОтчетаНаСтранице=КоличествоСтрокВОтчетаНаСтранице+1;
Если КоличествоСтрокВОтчетаНаСтранице=50 Тогда
КоличествоСтрокВОтчетаНаСтранице=3;
ТаблицаВывода.НоваяСтраница();
НомерЛиста=НомерЛиста+1;
ТаблицаВывода.ВывестиСекцию("НомерЛиста");
ТаблицаВывода.ВывестиСекцию("ШапкаТаблицы");
КонецЕсли;
КонецЦикла;	
ТаблицаВывода.ТолькоПросмотр(1);
ТаблицаВывода.Показать();
;)
 

gorlanovmax

Well-known member
19.06.2008
286
0
#2
ПовторятьПриПечатиСтроки(<?>,);

Синтаксис:
ПовторятьПриПечатиСтроки(<НачСтрока>,<КонСтрока>)

Назначение:
Задать строки результирующей таблицы, повторяющиеся при печати в начале каждой страницы.

Параметры:
<НачСтрока> - номер первой строки повторения.
<КонСтрока> - номер последней строки повторения.

и не надо никакого геммороя с условиями и проверками кол-ва строк в отчете
 

SeverBap

Well-known member
18.09.2007
451
0
#3
Без проблем ... и как мне ставить номера страниц??? как я буду их ставить мне интересно?????
 

SeverBap

Well-known member
18.09.2007
451
0
#4
Как правильно сформировать отчет с выводом номеров страниц и шапки, если высота строки может меняться, и количество строк на странице не постоянно.
;)
 

SeverBap

Well-known member
18.09.2007
451
0
#6
В ТОРГ12 фиксируется шапка с количеством строк у нас нет, она может менятся (С этим как нибудь разбиремся), потом выводимая строка иногда меняется исходя из данных может занимать несколько строк (свойство переносить все портить - а оно нужно) .... тот метод я применяю (сотрите первое сообшение!!!) .... но это же не верно!!!
 

SeverBap

Well-known member
18.09.2007
451
0
#7
GorlanovMax
ПовторятьПриПечатиСтроки(4,5);
поставил в 4 строке функцию по возврату номера страницы (объявил переменную в модуле, перед началом обнуляю)
Код:
Функция НомерСтраницыПолучить()
НомерЛиста=НомерЛиста+1;
Возврат НомерЛиста;
КонецФункции
все путем нормельно шапки как положено ставит, вот только косяк один:
ОДНА И ТАЖЕ СТРАНИЦА ВЕЗДЕ - ПЕРВАЯ ...
 

Вложения

vitfil

IT-интегратор
02.04.2004
2 062
0
#8
Номера страниц указываются в колонтитулах!
вроде как #P
выводится автоматом.
 

SeverBap

Well-known member
18.09.2007
451
0
#10
Да хорошо когда все хорошо кончается - но вот подстава! Мне теперь непонятно как ставить нижние колонтитулы на страничке, раньше все ставилось с расчетом сколько строчек в страицу вбито ....

а сейчас такое не получается ... че делать????
 

Вложения

vitfil

IT-интегратор
02.04.2004
2 062
0
#11
Марио Пьюзо сказал(а):
..."Что делать? Что делать?"
Имитация дона была столь удачной и неожиданной, что Джонни
и Хаген отпрянули и засмеялись. Дон Корлеоне был доволен...
в нижний колонтитул вставьте переменные, в которые "собирайте" ваши итоговые значения. По сути, как происходит вывод таблицы:
Верхний колонтитул (значения переменных, которые есть на момент вывода колонтитула), секции таблицы, нижний колонтитул (значения переменных на момент вывода).
Идея ясна?
И увольте меня от грубой лести - я вообще не программист ни разу. Занимаюсь чистым программированием исключительно из любви к искусству.
 

SeverBap

Well-known member
18.09.2007
451
0
#12
:( Почему я перешел на 1С я незнаю!!!!! сидел бы писал бы на СИ и все!!!
сейчас посмортю что можно сделать (надо позаморачиватся с секциями в колонтитуле) - для меня колонтитулы в 1С новы я поэтому туплю пока!!! (думал что все знаю - а тут шишь!!!)
 

vitfil

IT-интегратор
02.04.2004
2 062
0
#13
Чем больше узнаю, тем больше понимаю, насколько мало я знаю...
 

puh14

Well-known member
11.07.2008
1 412
0
#14
кстати - значения переменных на момент вывода в колонтитулах показать невозможно - только конечные значения. и передать из колонтикула номер страницы тоже не выходит.
 

vitfil

IT-интегратор
02.04.2004
2 062
0
#15

puh14

Well-known member
11.07.2008
1 412
0
#16
смотрел - колонтикулы походу выставляются непосредственно при выводе на печать - а не при формировании таблицы. Таким образом на выходе имеем только конечное значение переменной. щас ищу - мож через какую внешнюю компоненту можно.
 

SeverBap

Well-known member
18.09.2007
451
0
#17
Нда полный капец, зарылся с этими ... у кого есть пример???? Подскажите кто нибудь - у меня кончились идеии!!! :(