СуммаВключаетНДС проблемка

Sangitam

Well-known member
04.02.2008
90
0
#1
Где программно выключить этот флаг, чтобы он корректно изменял табличную часть?
Вручную все без проблем, а вот в коде -- где ни выключу -- все время увеличивает значения реквизитов.
 

Sangitam

Well-known member
04.02.2008
90
0
#2
Решил все так

Если (СуммаВключаетНДС) и (НЕ ЭтотОбъект.Проведен) Тогда
СуммаВключаетНДС = Ложь;
Для каждого СтрокаТабличнойЧасти из Товары Цикл
СтрокаТабличнойЧасти.Цена = СтрокаТабличнойЧасти.Цена - СтрокаТабличнойЧасти.СуммаНДС;
СтрокаТабличнойЧасти.Сумма = СтрокаТабличнойЧасти.Цена * СтрокаТабличнойЧасти.Количество;
КонецЦикла;
Для каждого СтрокаТабличнойЧасти из Услуги Цикл
СтрокаТабличнойЧасти.Цена = СтрокаТабличнойЧасти.Цена - СтрокаТабличнойЧасти.СуммаНДС;
СтрокаТабличнойЧасти.Сумма = СтрокаТабличнойЧасти.Цена * СтрокаТабличнойЧасти.Количество;
КонецЦикла;
КонецЕсли;

И поместил это дело в ПередЗаписью модуля документа.
 

Дайнеко

Well-known member
19.11.2009
951
0
#3
СтрокаТабличнойЧасти.Цена = СтрокаТабличнойЧасти.Цена - СтрокаТабличнойЧасти.СуммаНДС;

Да бред это: от Цены вычесть Сумму НДС.
 

Sangitam

Well-known member
04.02.2008
90
0
#5
Забыл Количество в формулу вставить :newconfus: В общем, все работает.