СуммаВключаетНДС проблемка

Тема в разделе "1C и всё что с ней связано", создана пользователем Sangitam, 18 авг 2011.

  1. Sangitam

    Sangitam Well-Known Member

    Регистрация:
    4 фев 2008
    Сообщения:
    90
    Симпатии:
    0
    Где программно выключить этот флаг, чтобы он корректно изменял табличную часть?
    Вручную все без проблем, а вот в коде -- где ни выключу -- все время увеличивает значения реквизитов.
     
  2. Sangitam

    Sangitam Well-Known Member

    Регистрация:
    4 фев 2008
    Сообщения:
    90
    Симпатии:
    0
    Решил все так

    Если (СуммаВключаетНДС) и (НЕ ЭтотОбъект.Проведен) Тогда
    СуммаВключаетНДС = Ложь;
    Для каждого СтрокаТабличнойЧасти из Товары Цикл
    СтрокаТабличнойЧасти.Цена = СтрокаТабличнойЧасти.Цена - СтрокаТабличнойЧасти.СуммаНДС;
    СтрокаТабличнойЧасти.Сумма = СтрокаТабличнойЧасти.Цена * СтрокаТабличнойЧасти.Количество;
    КонецЦикла;
    Для каждого СтрокаТабличнойЧасти из Услуги Цикл
    СтрокаТабличнойЧасти.Цена = СтрокаТабличнойЧасти.Цена - СтрокаТабличнойЧасти.СуммаНДС;
    СтрокаТабличнойЧасти.Сумма = СтрокаТабличнойЧасти.Цена * СтрокаТабличнойЧасти.Количество;
    КонецЦикла;
    КонецЕсли;

    И поместил это дело в ПередЗаписью модуля документа.
     
  3. Дайнеко

    Дайнеко Well-Known Member
    1C Team

    Регистрация:
    19 ноя 2009
    Сообщения:
    951
    Симпатии:
    0
    СтрокаТабличнойЧасти.Цена = СтрокаТабличнойЧасти.Цена - СтрокаТабличнойЧасти.СуммаНДС;

    Да бред это: от Цены вычесть Сумму НДС.
     
  4. unknown181538

    unknown181538 НеГуру
    1C Team

    Регистрация:
    28 дек 2008
    Сообщения:
    1.418
    Симпатии:
    0
    У него, наверное количество - 1 :)
     
  5. Sangitam

    Sangitam Well-Known Member

    Регистрация:
    4 фев 2008
    Сообщения:
    90
    Симпатии:
    0
    Забыл Количество в формулу вставить :newconfus: В общем, все работает.
     
Загрузка...
Похожие Темы - СуммаВключаетНДС проблемка
  1. Tarik
    Ответов:
    3
    Просмотров:
    559
  2. Antiseptik
    Ответов:
    3
    Просмотров:
    891
  3. Wolfises
    Ответов:
    2
    Просмотров:
    2.101
  4. kaskad755
    Ответов:
    4
    Просмотров:
    2.466

Поделиться этой страницей