Связь документа и справочника

Тема в разделе "1C и всё что с ней связано", создана пользователем Kriptex, 26 май 2009.

Статус темы:
Закрыта.
  1. Kriptex

    Kriptex Гость

    Есть справочник "Склад". Есть документ "Накладная". В документе есть таблица, которую нужно заполнять вручную. В ней столбцы Номенклатура и Количество . Нужно, чтобы при проводке этого документа, данные из таблицы записывались в справочник "Склад". Причем если в Складе уже есть данный вид номенклатуры, то необходимо прибовить только количество. Если такойвой номенклатуры нет, то создать новый.

    Пробовал вот так:

    Процедура ОбработкаПроведения()
    СпрСклад = СоздатьОбъект("Справочник.Склад");
    СпрСклад.Новый();
    СпрСклад.Номенклатура = Номенклатура;
    СпрСклад.Количество = Количество;
    СпрСклад.Записать();
    КонецПроцедуры
     
  2. ech

    ech Гость

    УстановитьРеквизитСправочника(<?>,,,,,,); юзай этот метод и будет тебе счастье
     
  3. kaa

    kaa Гость

    Процедура ОбработкаПроведения()
    СпрСклад = СоздатьОбъект("Справочник.Склад");
    ВыбратьСтроки();
    Пока ПолучитьСтроку()=1 Цикл
    Если СпрСклад.НайтиПоРеквизиту("Номенклатура",Номенклатура) = 0 Тогда
    СпрСклад.Новый();
    СпрСклад.Номенклатура = Номенклатура;
    СпрСклад.Количество = Количество;
    Иначе
    СпрСклад.Количество = СпрСклад.Количество+Количество;
    КонецЕсли;
    СпрСклад.Записать();
    КонецЦикла;
    КонецПроцедуры


    правда не совсем понятна логика, вы таким образом пытаетесь вести учет товара?
     
  4. vbs

    vbs Well-Known Member

    Регистрация:
    18 фев 2007
    Сообщения:
    1.708
    Симпатии:
    3
    Да, какой-то школьный подход. То ли задачка учебная, то ли про регистры не знает
     
Загрузка...
Похожие Темы - Связь документа справочника
  1. serox
    Ответов:
    3
    Просмотров:
    1.710
  2. morkov
    Ответов:
    1
    Просмотров:
    1.571
  3. shadow288
    Ответов:
    3
    Просмотров:
    1.869
  4. nayke
    Ответов:
    60
    Просмотров:
    9.788
  5. Chron
    Ответов:
    14
    Просмотров:
    5.273
Статус темы:
Закрыта.

Поделиться этой страницей