Связь документа и справочника

  • Автор темы Kriptex
  • Дата начала
Статус
Закрыто для дальнейших ответов.
K

Kriptex

Гость
#1
Есть справочник "Склад". Есть документ "Накладная". В документе есть таблица, которую нужно заполнять вручную. В ней столбцы Номенклатура и Количество . Нужно, чтобы при проводке этого документа, данные из таблицы записывались в справочник "Склад". Причем если в Складе уже есть данный вид номенклатуры, то необходимо прибовить только количество. Если такойвой номенклатуры нет, то создать новый.

Пробовал вот так:

Процедура ОбработкаПроведения()
СпрСклад = СоздатьОбъект("Справочник.Склад");
СпрСклад.Новый();
СпрСклад.Номенклатура = Номенклатура;
СпрСклад.Количество = Количество;
СпрСклад.Записать();
КонецПроцедуры
 
E

ech

Гость
#2
УстановитьРеквизитСправочника(<?>,,,,,,); юзай этот метод и будет тебе счастье
 
K

kaa

Гость
#3
Процедура ОбработкаПроведения()
СпрСклад = СоздатьОбъект("Справочник.Склад");
ВыбратьСтроки();
Пока ПолучитьСтроку()=1 Цикл
Если СпрСклад.НайтиПоРеквизиту("Номенклатура",Номенклатура) = 0 Тогда
СпрСклад.Новый();
СпрСклад.Номенклатура = Номенклатура;
СпрСклад.Количество = Количество;
Иначе
СпрСклад.Количество = СпрСклад.Количество+Количество;
КонецЕсли;
СпрСклад.Записать();
КонецЦикла;
КонецПроцедуры


правда не совсем понятна логика, вы таким образом пытаетесь вести учет товара?
 
Статус
Закрыто для дальнейших ответов.