1. Набираем команду codeby webinar. Набираем команду для организации и проведения вебинаров. Подробнее ...

    Скрыть объявление
  2. Требуются разработчики и тестеры для проекта codebyOS. Требования для участия в проекте: Знание принципов работы ОС на базе Linux; Знание Bash; Крайне желательное знание CPP, Python, Lua; Навыки системного администрирования. Подробнее ...

    Скрыть объявление
  3. Получи 30.000 рублей. Для получения денег необходимо принять участие в конкурсе авторов codeby. С условиями и призами можно ознакомиться на этой странице ...

    Внимание! Регистрация авторов на конкурс закрыта.

    Скрыть объявление

Связь документа и справочника

Тема в разделе "Базы данных и администрирование", создана пользователем Kriptex, 26 май 2009.

Статус темы:
Закрыта.
  1. Kriptex

    Kriptex Гость

    Репутация:
    0
    Есть справочник "Склад". Есть документ "Накладная". В документе есть таблица, которую нужно заполнять вручную. В ней столбцы Номенклатура и Количество . Нужно, чтобы при проводке этого документа, данные из таблицы записывались в справочник "Склад". Причем если в Складе уже есть данный вид номенклатуры, то необходимо прибовить только количество. Если такойвой номенклатуры нет, то создать новый.

    Пробовал вот так:

    Процедура ОбработкаПроведения()
    СпрСклад = СоздатьОбъект("Справочник.Склад");
    СпрСклад.Новый();
    СпрСклад.Номенклатура = Номенклатура;
    СпрСклад.Количество = Количество;
    СпрСклад.Записать();
    КонецПроцедуры
     
  2. ech

    ech Гость

    Репутация:
    0
    УстановитьРеквизитСправочника(<?>,,,,,,); юзай этот метод и будет тебе счастье
     
  3. kaa

    kaa Гость

    Репутация:
    0
    Процедура ОбработкаПроведения()
    СпрСклад = СоздатьОбъект("Справочник.Склад");
    ВыбратьСтроки();
    Пока ПолучитьСтроку()=1 Цикл
    Если СпрСклад.НайтиПоРеквизиту("Номенклатура",Номенклатура) = 0 Тогда
    СпрСклад.Новый();
    СпрСклад.Номенклатура = Номенклатура;
    СпрСклад.Количество = Количество;
    Иначе
    СпрСклад.Количество = СпрСклад.Количество+Количество;
    КонецЕсли;
    СпрСклад.Записать();
    КонецЦикла;
    КонецПроцедуры


    правда не совсем понятна логика, вы таким образом пытаетесь вести учет товара?
     
  4. vbs

    vbs Well-Known Member

    Репутация:
    0
    Регистрация:
    18 фев 2007
    Сообщения:
    1.708
    Симпатии:
    3
    Да, какой-то школьный подход. То ли задачка учебная, то ли про регистры не знает
     
Загрузка...
Похожие Темы - Связь документа справочника
  1. serox
    Ответов:
    3
    Просмотров:
    1.804
  2. morkov
    Ответов:
    1
    Просмотров:
    1.654
  3. shadow288
    Ответов:
    3
    Просмотров:
    1.963
  4. nayke
    Ответов:
    60
    Просмотров:
    10.544
  5. Chron
    Ответов:
    14
    Просмотров:
    5.464
Статус темы:
Закрыта.

Поделиться этой страницей