Таблица в обработке?

  • Автор темы Leon3
  • Дата начала
L

Leon3

Гость
#1
Подсажите пожалуйста ! Как Сделать , Чтобы в обработке (v7.7) В таблице можно было изменять данные прямо в таблице? Записывать числовое значение или строкавое!
 

KiR

НЕ шибка опытный програмер)
11.09.2007
1 581
0
#3
А таблицу в обработке ты рисуешь ручками или же создаешь динамически (кодом в проге)?
 
L

Leon3

Гость
#4
Я ЕЕ Создаю! Записывать данные програмно!! Хочу сделать , чтобы выделялась Колонка количество и можно было ввести любое значение!
Процедура ПриОткрытии()
Матер.Очистить();
Матер.НоваяКолонка("Материал",,,, "Материал", 13);
Матер.НоваяКолонка("Количество",,,, "Количество", 4);
Матер.НоваяКолонка("цена",,,, "цена", 5);
Матер.НоваяКолонка("Сумма",,,, "Сумма", 6);
Матер.НоваяКолонка("НДС",,,, "НДС", 6);
Матер.НоваяКолонка("Всего",,,, "Всего", 7);
КонецПроцедуры
Если Колонка ="Материал" Тогда



Объект = СоздатьОбъект("Справочник.Материалы");

Если Объект.Выбрать("Выберите элемент справочника", "") = 0 Тогда
Возврат;
КонецЕсли;
ТекущийОбъект = Объект.ТекущийЭлемент();
мдСправочник = Метаданные.Справочник(ТекущийОбъект.Вид());


//Матер.УдалитьСтроку(Матер.ТекущаяСтрока());
Матер.Материал =ТекущийОбъект.Наименование;
Матер.Цена = ТекущийОбъект.Цена;
 

puh14

Well-Known Member
11.07.2008
1 412
0
#5
на таблицу повесь что-то вроде
Процедура ВВодСуммы()
Если Матер.ТекущаяСтрока() = 0 Тогда
Возврат;
КонецЕсли;


Стр = Матер.Сумма;

Если ВвестиЧисло(Стр,"ВВедите новую сумму",15,2) = 1 Тогда
Если Стр < 0 Тогда
Стр = Стр *(-1);
КонецЕсли;
КонецЕсли;

Матер.Сумма = Стр;
КонецПроцедуры

Ну или вводить Всего - тут по желанию.

кстати - рекомендую жестко задать типы полей в таблице - а то неудобно будет
 

vbs

Well-Known Member
18.02.2007
1 708
3
#7
для Puh14
Все же перед
Стр = Матер.Сумма;
лучше поставить проверку
Если Матер.ТекущаяКолонка() = "Сумма" Тогда
В этом случае будет удобнее -щелкаешь по нужной ячейке колонки "Сумма" - вводишь сумму,
по по другим щелкаешь - 0-эффект.
Fool-proof опять же

PS. Ну и вообще, он Количество хотел вводить :)
 

puh14

Well-Known Member
11.07.2008
1 412
0
#8
О - Пасиб! Иногда полезно при разных вариантах расчета НДС
 

vbs

Well-Known Member
18.02.2007
1 708
3
#9
У меня есть один пользователь (Фин.директор), которой надо править Excel-таблицы, но при этом она хочет получать данные из 1С. Читает файл, заполняется таблица, некоторые колонки редактируются вручную, а в некоторые проставляется, например, остаток товара. В процедуре этой ТЗ висит соотвествующий кусок для данной колонки для получения остатка, ну, далее, понятно, файл сохраняется