Текущий пользователь и Сервер

Тема в разделе "1C и всё что с ней связано", создана пользователем ich13, 7 дек 2010.

Статус темы:
Закрыта.
  1. ich13

    ich13 Гость

    Как передать текущего пользователя(пользователей) на сервер. У меня регламентная задача возвращает некий список пользователей.
    Очень хочется проверять активного пользователя ИБ на принадлежность к этому списку.
    Но задание выполняется на сервере - пользователя нет. И из метода Рег. задачи не могу достучаться до локальных процедур. Подскажите пожалуйста кто знает!
     
  2. unknown181538

    unknown181538 НеГуру
    1C Team

    Регистрация:
    28 дек 2008
    Сообщения:
    1.418
    Симпатии:
    0
    Т.е. нужно, чтобы регламентное задание знало список активных пользователей?
     
  3. ich13

    ich13 Гость

    именно так
     
  4. unknown181538

    unknown181538 НеГуру
    1C Team

    Регистрация:
    28 дек 2008
    Сообщения:
    1.418
    Симпатии:
    0
    Может это подойдет?

    Код ( (Unknown Language)):
    &НаСервере
    Процедура ЗаполнитьСписокПользователей()

    СписокПользователей.Очистить();

    СеансыИнформационнойБазы = ПолучитьСеансыИнформационнойБазы();

    Для Каждого СеансИБ Из СеансыИнформационнойБазы Цикл
    СтрПользователя = СписокПользователей.Добавить();

    СтрПользователя.Приложение  = ПредставлениеПриложения(СеансИБ.ИмяПриложения);
    СтрПользователя.НачалоРаботы = СеансИБ.НачалоСеанса;
    СтрПользователя.Компьютер   = СеансИБ.ИмяКомпьютера;
    СтрПользователя.Сеанс       = СеансИБ.НомерСеанса;
    СтрПользователя.Соединение  = СеансИБ.НомерСоединения;

    Если СеансИБ.Пользователь <> Неопределено Тогда
    СтрПользователя.Пользователь     = СеансИБ.Пользователь.Имя;
    СтрПользователя.ИмяПользователя       = СеансИБ.Пользователь.ПолноеИмя;
    СтрПользователя.ПользовательСсылка = НайтиСсылкуПоИдентификаторуПользователя(СеансИБ.Пользователь.УникальныйИдентификатор);
    Иначе
    СтрПользователя.Пользователь = "";
    СтрПользователя.ИмяПользователя = "";
    КонецЕсли;

    Если СеансИБ.НомерСеанса = НомерСеансаИнформационнойБазы Тогда
    СтрПользователя.НомерРисункаПользователя = 0;
    Иначе
    СтрПользователя.НомерРисункаПользователя = 1;
    КонецЕсли;
    КонецЦикла;

    КоличествоАктивныхПользователей = СеансыИнформационнойБазы.Количество();
    СписокПользователей.Сортировать(ИмяКолонкиСортировки + " " + НаправлениеСортировки);

    КонецПроцедуры
    Выдернул из библиотеки стандартных подсистем 8.2
     
  5. ich13

    ich13 Гость

    в 8.1 это ПолучитьСоединенияИнформационнойБазы()
    Большое спасибо!
     
  6. Дайнеко

    Дайнеко Well-Known Member
    1C Team

    Регистрация:
    19 ноя 2009
    Сообщения:
    951
    Симпатии:
    0
    А где эта библиотека?
     
  7. unknown181538

    unknown181538 НеГуру
    1C Team

    Регистрация:
    28 дек 2008
    Сообщения:
    1.418
    Симпатии:
    0
    На ИТСе. Интересная штука, но сам глубоко не копал.
     
Загрузка...
Статус темы:
Закрыта.

Поделиться этой страницей