Текущий пользователь и Сервер

  • Автор темы ich13
  • Дата начала
Статус
Закрыто для дальнейших ответов.
I

ich13

#1
Как передать текущего пользователя(пользователей) на сервер. У меня регламентная задача возвращает некий список пользователей.
Очень хочется проверять активного пользователя ИБ на принадлежность к этому списку.
Но задание выполняется на сервере - пользователя нет. И из метода Рег. задачи не могу достучаться до локальных процедур. Подскажите пожалуйста кто знает!
 

unknown181538

НеГуру
28.12.2008
1 417
0
#2
Т.е. нужно, чтобы регламентное задание знало список активных пользователей?
 

unknown181538

НеГуру
28.12.2008
1 417
0
#4
Может это подойдет?

Код:
&НаСервере
Процедура ЗаполнитьСписокПользователей()

СписокПользователей.Очистить();

СеансыИнформационнойБазы = ПолучитьСеансыИнформационнойБазы();

Для Каждого СеансИБ Из СеансыИнформационнойБазы Цикл
СтрПользователя = СписокПользователей.Добавить();

СтрПользователя.Приложение  = ПредставлениеПриложения(СеансИБ.ИмяПриложения);
СтрПользователя.НачалоРаботы = СеансИБ.НачалоСеанса;
СтрПользователя.Компьютер	= СеансИБ.ИмяКомпьютера;
СтрПользователя.Сеанс		= СеансИБ.НомерСеанса;
СтрПользователя.Соединение  = СеансИБ.НомерСоединения;

Если СеансИБ.Пользователь <> Неопределено Тогда
СтрПользователя.Пользователь		= СеансИБ.Пользователь.Имя;
СтрПользователя.ИмяПользователя		= СеансИБ.Пользователь.ПолноеИмя;
СтрПользователя.ПользовательСсылка	= НайтиСсылкуПоИдентификаторуПользователя(СеансИБ.Пользователь.УникальныйИдентификатор);
Иначе
СтрПользователя.Пользователь	= "";
СтрПользователя.ИмяПользователя = "";
КонецЕсли;

Если СеансИБ.НомерСеанса = НомерСеансаИнформационнойБазы Тогда
СтрПользователя.НомерРисункаПользователя = 0;
Иначе
СтрПользователя.НомерРисункаПользователя = 1;
КонецЕсли;
КонецЦикла;

КоличествоАктивныхПользователей = СеансыИнформационнойБазы.Количество();
СписокПользователей.Сортировать(ИмяКолонкиСортировки + " " + НаправлениеСортировки);

КонецПроцедуры
Выдернул из библиотеки стандартных подсистем 8.2
 
I

ich13

#5
в 8.1 это ПолучитьСоединенияИнформационнойБазы()
Большое спасибо!
 
Статус
Закрыто для дальнейших ответов.