ТиС и оперативный учет количества ТМЦ

Тема в разделе "1C и всё что с ней связано", создана пользователем Anatoly1987, 7 май 2009.

  1. Anatoly1987

    Anatoly1987 Гость

    Ребята проблема такая : писал я для ТиС штукенцию которая позволяет при реализации товара, выполнять продажу собственной фирме, где недостающее кол-во тмц будет, только вот чую что надо процедуру определения количества ТМЦ менять. Скажите как лутше сделать, единственно в ТиС нашел вот что:

    ФирмаДляОстатковТМЦ = СписокПараметров.Получить("ФирмаДляОстатковТМЦ");

    ВремОстаткиТМЦ. УстановитьЗначениеФильтра("Фирма" ,ФирмаДляОстатковТМЦ,2);
    Если (ТипЗначенияСтр(ВремРезервыТМЦ) = "Регистр") Тогда
    ВремРезервыТМЦ.УстановитьЗначениеФильтра("Фирма" ,ФирмаДляОстатковТМЦ,2);
    КонецЕсли;

    Если Конт.ИтогиАктуальны()=0 Тогда
    // подготовка фильтров
    СписокТМЦ = СоздатьОбъект("СписокЗначений");
    ТаблНоменклатуры.Выгрузить(СписокТМЦ,,,"Номенклатура");

    // установка фильтров
    ВремОстаткиТМЦ.УстановитьЗначениеФильтра("Номенклатура",СписокТМЦ,2);
    ВремОстаткиТМЦ.ВременныйРасчет();

    Если (ТипЗначенияСтр(ВремРезервыТМЦ) = "Регистр") Тогда
    // установка фильтров
    ВремРезервыТМЦ.УстановитьЗначениеФильтра("Номенклатура",СписокТМЦ,2);
    ВремРезервыТМЦ.ВременныйРасчет();
    КонецЕсли;
    КонецЕсли;

    Этот код фильтрует регистры, потом если что-то вроде такого:

    ВремРезервыТМЦ.СводныйОстаток(,ТекНоменклатура,Склад,Договор,,"Количество");

    мы получим что хотим, только у меня одна проблема, выделить не нужную дату. Что посоветуете?
     
  2. puh14

    puh14 Well-Known Member
    1C Team

    Регистрация:
    11 июл 2008
    Сообщения:
    1.412
    Симпатии:
    0
    Может таки на нужную дату? И как её можно выделить?
     
  3. Anatoly1987

    Anatoly1987 Гость

    Ну да на нужную дату расчитать остатки. Вообщем я разобрался в том что в посте написал, и нашел способ сделать)))
     
Загрузка...
Похожие Темы - ТиС оперативный учет
  1. newlord
    Ответов:
    0
    Просмотров:
    93
  2. Baneslaer
    Ответов:
    9
    Просмотров:
    4.509
  3. vbs
    Ответов:
    6
    Просмотров:
    2.442
  4. ruslana
    Ответов:
    1
    Просмотров:
    1.855
  5. vbs
    Ответов:
    6
    Просмотров:
    1.735

Поделиться этой страницей