ТиС и оперативный учет количества ТМЦ

  • Автор темы Anatoly1987
  • Дата начала
A

Anatoly1987

Гость
#1
Ребята проблема такая : писал я для ТиС штукенцию которая позволяет при реализации товара, выполнять продажу собственной фирме, где недостающее кол-во тмц будет, только вот чую что надо процедуру определения количества ТМЦ менять. Скажите как лутше сделать, единственно в ТиС нашел вот что:

ФирмаДляОстатковТМЦ = СписокПараметров.Получить("ФирмаДляОстатковТМЦ");

ВремОстаткиТМЦ. УстановитьЗначениеФильтра("Фирма" ,ФирмаДляОстатковТМЦ,2);
Если (ТипЗначенияСтр(ВремРезервыТМЦ) = "Регистр") Тогда
ВремРезервыТМЦ.УстановитьЗначениеФильтра("Фирма" ,ФирмаДляОстатковТМЦ,2);
КонецЕсли;

Если Конт.ИтогиАктуальны()=0 Тогда
// подготовка фильтров
СписокТМЦ = СоздатьОбъект("СписокЗначений");
ТаблНоменклатуры.Выгрузить(СписокТМЦ,,,"Номенклатура");

// установка фильтров
ВремОстаткиТМЦ.УстановитьЗначениеФильтра("Номенклатура",СписокТМЦ,2);
ВремОстаткиТМЦ.ВременныйРасчет();

Если (ТипЗначенияСтр(ВремРезервыТМЦ) = "Регистр") Тогда
// установка фильтров
ВремРезервыТМЦ.УстановитьЗначениеФильтра("Номенклатура",СписокТМЦ,2);
ВремРезервыТМЦ.ВременныйРасчет();
КонецЕсли;
КонецЕсли;

Этот код фильтрует регистры, потом если что-то вроде такого:

ВремРезервыТМЦ.СводныйОстаток(,ТекНоменклатура,Склад,Договор,,"Количество");

мы получим что хотим, только у меня одна проблема, выделить не нужную дату. Что посоветуете?