Удаление помоченных на удаление в 1С 7.7 помогите новичку)

Тема в разделе "1C и всё что с ней связано", создана пользователем Vazzzo, 8 ноя 2007.

Статус темы:
Закрыта.
  1. Vazzzo

    Vazzzo Гость

    при удалении объектов помеченных на удаление часто сталкиваюсь с тем, что объект удалить нельзя. ( он связан с другими объектами). Хочу создать обработку показывающую список всех связи этого объекта( например Справочника) с другими объектами. какой фун-ей воспользоваться?
     
  2. Zab

    Zab Well-Known Member
    1C Team

    Регистрация:
    7 авг 2006
    Сообщения:
    583
    Симпатии:
    0
    Если тебе потренироваться, то все есть в синтакс-помошнике:
    Но, можно не мучаться, а зайти на proclub.ru там есть десятки аналогичных обработок. Удачи в освоении нового
     
  3. Vazzzo

    Vazzzo Гость

    все понял НайтиСсылки

    Спасибо

    обязательно зайду, спасиб за совет

    а в каком разделе я могу все это увидеть?
     
  4. Vazzzo

    Vazzzo Гость

    млин, там надо сначала в клуб вступить
     
  5. Vazzzo

    Vazzzo Гость

    кто-нить может помочь? почему не работает?

    Процедура Сформировать()
    Т = СоздатьОбъект("Таблица");
    Абон=СоздатьОбъект("Справочник.Абоненты");
    Абон.ВыбратьЭлементы();
    Пока Абон.ПолучитьЭлемент()=1 Цикл
    Если Абон.ПометкаУдаления()=1 Тогда

    Ссылки=СоздатьОбъект("ТаблицаЗначений");
    НайтиСсылки(Абон,Ссылки);
    Ссылки.ВыбратьСтроки();

    Пока Ссылки.ПолучитьСтроку() = 1 Цикл
    Т.ВывестиСекцию("Секция_1");

    КонецЦикла;
    КонецЕсли;
    КонецЦикла;


    Т.ТолькоПросмотр(1);
    Т.Показать()
    КонецПроцедуры

    Табличная Часть
    <Ссылки.НомерСтроки> <Ссылки.ПолучитьЗначение(Ссылки.НомерСтроки,1)>
    <Ссылки.ПолучитьЗначение(Ссылки.НомерСтроки,2)>
     
  6. kaa

    kaa Гость

    <!--QuoteBegin-Vazzzo+8:11:2007, 17:55 -->
    <span class="vbquote">(Vazzzo @ 8:11:2007, 17:55 )</span><!--QuoteEBegin-->НайтиСсылки(Абон,Ссылки);
    [snapback]84726" rel="nofollow" target="_blank[/snapback]​
    [/quote]
    НайтиСсылки(Абон.ТекущийЭлемент(),Ссылки);
     
  7. Vazzzo

    Vazzzo Гость

    ага понял, ща попробую. спасиб!
     
  8. Vazzzo

    Vazzzo Гость

    Все ок, получилось. Спасибо за помощь)
     
Загрузка...
Статус темы:
Закрыта.

Поделиться этой страницей