Удаление помоченных на удаление в 1С 7.7 помогите новичку)

  • Автор темы Vazzzo
  • Дата начала
Статус
Закрыто для дальнейших ответов.
V

Vazzzo

#1
при удалении объектов помеченных на удаление часто сталкиваюсь с тем, что объект удалить нельзя. ( он связан с другими объектами). Хочу создать обработку показывающую список всех связи этого объекта( например Справочника) с другими объектами. какой фун-ей воспользоваться?
 

Zab

Well-known member
07.08.2006
583
0
#2
Если тебе потренироваться, то все есть в синтакс-помошнике:
НайтиПомеченныеНаУдаление(<?>);
FindMarkedForDelete(<?>);
Синтаксис:
НайтиПомеченныеНаУдаление(<Объекты>)
Назначение:
Находит все помеченные на удаление объекты.
Параметры:
<Объекты> - идентификатор объекта типа ''СписокЗначений'', в который данная процедура помещает найденные объекты.
НайтиСсылки(<?>,);
FindReferences(<?>,);
Синтаксис:
НайтиСсылки(<Объекты>,<Ссылки>)
Назначение:
Находит ссылки на объекты, переданные в списке значений.
Параметры:
<Объекты> - конкретное значение искомого объекта или значение типа ''СписокЗначений'', в котором данной процедуре передаются объекты, по которым надо найти ссылки.
<Ссылки> - идентификатор объекта типа ''ТаблицаЗначений'', в который данная процедура помещает найденные ссылки на объекты. Таблица значений состоит из 3 колонок: 1. объект на который ссылаются; 2. объект, который содержит ссылку; 3. комментарий к ссылке.
УдалитьОбъекты(<?>,,);
DeleteObjects(<?>,,);
Синтаксис:
УдалитьОбъекты(<Объекты>,<Проверять>,<Ссылки>)
Назначение:
Удаляет объекты, переданные в списке значений.
Параметры:
<Объекты> - конкретное значение объекта или значение типа ''СписокЗначений'', в котором данной процедуре передаются объекты, которые надо удалить.
<Проверять> - необязательный параметр. Число: 1 - перед удалением проверяется, нет ли ссылок на удаляемый объект. Если есть, то объект не удаляется, а ссылки помещаются в таблицу значений <Ссылки>. Любое другое число - проверку не выполнять. Значение по умолчанию: 0.
<Ссылки> - Необязательный параметр. Идентификатор объекта типа ''ТаблицаЗначений'', в который данная процедура помещает найденные ссылки на объекты. Таблица значений состоит из 3 колонок: 1. объект на который ссылаются; 2. объект, который содержит ссылку; 3. комментарий к ссылке.
Но, можно не мучаться, а зайти на proclub.ru там есть десятки аналогичных обработок. Удачи в освоении нового
 
V

Vazzzo

#3
все понял НайтиСсылки

Спасибо

обязательно зайду, спасиб за совет

Если тебе потренироваться, то все есть в синтакс-помошнике: Но, можно не мучаться, а зайти на proclub.ru там есть десятки аналогичных обработок. Удачи в освоении нового
а в каком разделе я могу все это увидеть?
 
V

Vazzzo

#5
кто-нить может помочь? почему не работает?

Процедура Сформировать()
Т = СоздатьОбъект("Таблица");
Абон=СоздатьОбъект("Справочник.Абоненты");
Абон.ВыбратьЭлементы();
Пока Абон.ПолучитьЭлемент()=1 Цикл
Если Абон.ПометкаУдаления()=1 Тогда

Ссылки=СоздатьОбъект("ТаблицаЗначений");
НайтиСсылки(Абон,Ссылки);
Ссылки.ВыбратьСтроки();

Пока Ссылки.ПолучитьСтроку() = 1 Цикл
Т.ВывестиСекцию("Секция_1");

КонецЦикла;
КонецЕсли;
КонецЦикла;


Т.ТолькоПросмотр(1);
Т.Показать()
КонецПроцедуры

Табличная Часть
<Ссылки.НомерСтроки> <Ссылки.ПолучитьЗначение(Ссылки.НомерСтроки,1)>
<Ссылки.ПолучитьЗначение(Ссылки.НомерСтроки,2)>
 
K
#6
<!--QuoteBegin-Vazzzo+8:11:2007, 17:55 -->
<span class="vbquote">(Vazzzo @ 8:11:2007, 17:55 )</span><!--QuoteEBegin-->НайтиСсылки(Абон,Ссылки);
[snapback]84726" rel="nofollow" target="_blank[/snapback]​
[/quote]
НайтиСсылки(Абон.ТекущийЭлемент(),Ссылки);
 
Статус
Закрыто для дальнейших ответов.