УникальныйИдентификатор 1С:Предприятие 8.0

Тема в разделе "1C и всё что с ней связано", создана пользователем SeverBap, 26 авг 2009.

  1. SeverBap

    SeverBap Well-Known Member

    Репутация:
    0
    Регистрация:
    18 сен 2007
    Сообщения:
    451
    Симпатии:
    0
    Ситуация такая: удаленно распределенные базы), настроили планый обмена между базами. У одной постоянные проблемы после обмена с головной появляются ссылки типа <объект не найден> код объекта, вот просмотрели ссылается на ндс 18 и 10 (во всех документах стоит эта ссылка объект не найден) я исправил на то что нужно (помимо этого есть такое подобие и у других элементах с единицами измерения и так далее).
    Как мне поменять уникальный идентификатор у этих элементов на то что нужно?
    есть ли какае-то утилита по редактированию файла 1CD? очень нужно!!
    Или как-то это можно обойти и исправить программно кодом в 1С????
    Скорее всего я понял что они просто не верно сделали - надо было сначала загрузить через обмен данные головной а потом переферийку!!! :P ;)
     
  2. SeverBap

    SeverBap Well-Known Member

    Репутация:
    0
    Регистрация:
    18 сен 2007
    Сообщения:
    451
    Симпатии:
    0
    Может стоит подраправить в процедурах при обмене ссылки на правленые объекты?
    Код:
    Если (ТипЗнч(Данные.Ссылка) = Тип("ДокументСсылка.УстановкаЦенНоменклатуры")) Тогда	
    СтрокаGUID = "bfe5746c-74b8-11dc-84dd-00046146d635"; 
    ГрнGUID = Новый УникальныйИдентификатор(СтрокаGUID); 
    СтрокаGUID = "bfe5746d-74b8-11dc-84dd-00046146d635"; 
    USDGUID = Новый УникальныйИдентификатор(СтрокаGUID);			 
    Для Каждого стр из Данные.Товары Цикл				
    Если стр.валюта.УникальныйИдентификатор() = ГрнGUID Тогда 
    стр.валюта = Справочники.Валюты.НайтиПоКоду("980"); 
    КонецЕсли; 
    Если стр.валюта.УникальныйИдентификатор() = USDGUID Тогда 
    стр.валюта = Справочники.Валюты.НайтиПоКоду("840"); 
    КонецЕсли; 
    КонецЦикла; 
    Данные.Записать(); 
    КонецЕсли;
    Так или не так?
     
Загрузка...
Похожие Темы - УникальныйИдентификатор 1С Предприятие
  1. Анастасия Крук
    Ответов:
    0
    Просмотров:
    457
  2. buxar
    Ответов:
    0
    Просмотров:
    223
  3. KatyKoronа
    Ответов:
    0
    Просмотров:
    147
  4. KatyKoronа
    Ответов:
    0
    Просмотров:
    117
  5. NataliaZ
    Ответов:
    0
    Просмотров:
    103

Поделиться этой страницей