УникальныйИдентификатор 1С:Предприятие 8.0

SeverBap

Well-Known Member
18.09.2007
451
0
#1
Ситуация такая: удаленно распределенные базы), настроили планый обмена между базами. У одной постоянные проблемы после обмена с головной появляются ссылки типа <объект не найден> код объекта, вот просмотрели ссылается на ндс 18 и 10 (во всех документах стоит эта ссылка объект не найден) я исправил на то что нужно (помимо этого есть такое подобие и у других элементах с единицами измерения и так далее).
Как мне поменять уникальный идентификатор у этих элементов на то что нужно?
есть ли какае-то утилита по редактированию файла 1CD? очень нужно!!
Или как-то это можно обойти и исправить программно кодом в 1С????
Скорее всего я понял что они просто не верно сделали - надо было сначала загрузить через обмен данные головной а потом переферийку!!! :P ;)
 

SeverBap

Well-Known Member
18.09.2007
451
0
#2
Может стоит подраправить в процедурах при обмене ссылки на правленые объекты?
Код:
Если (ТипЗнч(Данные.Ссылка) = Тип("ДокументСсылка.УстановкаЦенНоменклатуры")) Тогда	
СтрокаGUID = "bfe5746c-74b8-11dc-84dd-00046146d635"; 
ГрнGUID = Новый УникальныйИдентификатор(СтрокаGUID); 
СтрокаGUID = "bfe5746d-74b8-11dc-84dd-00046146d635"; 
USDGUID = Новый УникальныйИдентификатор(СтрокаGUID);			 
Для Каждого стр из Данные.Товары Цикл				
Если стр.валюта.УникальныйИдентификатор() = ГрнGUID Тогда 
стр.валюта = Справочники.Валюты.НайтиПоКоду("980"); 
КонецЕсли; 
Если стр.валюта.УникальныйИдентификатор() = USDGUID Тогда 
стр.валюта = Справочники.Валюты.НайтиПоКоду("840"); 
КонецЕсли; 
КонецЦикла; 
Данные.Записать(); 
КонецЕсли;
Так или не так?