1. Набираем команду codeby webinar. Набираем команду для организации и проведения вебинаров. Подробнее ...

    Скрыть объявление
  2. Требуются разработчики и тестеры для проекта codebyOS. Требования для участия в проекте: Знание принципов работы ОС на базе Linux; Знание Bash; Крайне желательное знание CPP, Python, Lua; Навыки системного администрирования. Подробнее ...

    Скрыть объявление
  3. Получи 30.000 рублей. Для получения денег необходимо принять участие в конкурсе авторов codeby. С условиями и призами можно ознакомиться на этой странице ...

    Внимание! Регистрация авторов на конкурс закрыта.

    Скрыть объявление

УправлениеГостиницей

Тема в разделе "Базы данных и администрирование", создана пользователем Marccc, 29 авг 2011.

Статус темы:
Закрыта.
  1. Marccc

    Marccc Гость

    Репутация:
    0
    Прошу помощи,конфигурацию УправлениеОтелем делаю, у меня есть Общий Модуль "РаботаСоСправочниками"

    Функция РозничнаяЦена(АктуальнаяДата, ЭлементНомераГостиницы) Экспорт
    Запрос = новый Запрос; Запрос.Текст = "ВЫБРАТЬ
    | ЦеныСрезПервых.Цена
    |ИЗ
    | РегистрСведений.Цены.СрезПервых(&ДатаСреза, &ВидНомераГостиницы) КАК ЦеныСрезПервых";
    Запрос.Параметры.Вставить("ДатаСреза", АктуальнаяДата);
    Запрос.Параметры.Вставить("ВидНомераГостиницы", ЭлементНомераГостиницы.ВидНомераГостиницы);
    Выборка = Запрос.Выполнить().Выбрать();
    Если Выборка.Следующий() тогда
    Возврат Выборка.Цена; Иначе Сообщить("Ошибка");
    Возврат 0;
    КонецЕсли;
    КонецФункции

    В Документе Посление Есть Процедура ПриИзменении()

    Процедура ПереченьПоселенцевНомерГостиницыПриИзменении(Элемент)
    СтрокаТабличнойЧасти = ЭлементыФормы.ПереченьПоселенцев.ТекущиеДанные;
    СтрокаТабличнойЧасти.Цена = РаботаСоСправочниками.РозничнаяЦена(Дата,СтрокаТабличнойЧасти.НомерГостиницы);
    КонецПроцедуры

    При выполнении этого выскакивает ошибка
    {ОбщийМодуль.РаботаСоСправочниками(12)}: Ошибка при вызове метода контекста (Выполнить): {(4, 46)}: Неверные параметры "РегистрСведений.Цены.СрезПервых, 1"РегистрСведений.Цены.СрезПервых(&ДатаСреза, <<?>>&ВидНомераГостиницы) КАК ЦеныСрезПервых Выборка = Запрос.Выполнить().Выбрать();по причине:{(4, 46)}: Неверные параметры "РегистрСведений.Цены.СрезПервых, 1"РегистрСведений.Цены.СрезПервых(&ДатаСреза, <<?>>&ВидНомераГостиницы) КАК ЦеныСрезПервых

    Помогите её исправить
     
  2. Marccc

    Marccc Гость

    Репутация:
    0
    задачу решил, удалите тему..
     
Статус темы:
Закрыта.

Поделиться этой страницей