УправлениеГостиницей

  • Автор темы Marccc
  • Дата начала
Статус
Закрыто для дальнейших ответов.
M

Marccc

#1
Прошу помощи,конфигурацию УправлениеОтелем делаю, у меня есть Общий Модуль "РаботаСоСправочниками"

Функция РозничнаяЦена(АктуальнаяДата, ЭлементНомераГостиницы) Экспорт
Запрос = новый Запрос; Запрос.Текст = "ВЫБРАТЬ
| ЦеныСрезПервых.Цена
|ИЗ
| РегистрСведений.Цены.СрезПервых(&ДатаСреза, &ВидНомераГостиницы) КАК ЦеныСрезПервых";
Запрос.Параметры.Вставить("ДатаСреза", АктуальнаяДата);
Запрос.Параметры.Вставить("ВидНомераГостиницы", ЭлементНомераГостиницы.ВидНомераГостиницы);
Выборка = Запрос.Выполнить().Выбрать();
Если Выборка.Следующий() тогда
Возврат Выборка.Цена; Иначе Сообщить("Ошибка");
Возврат 0;
КонецЕсли;
КонецФункции

В Документе Посление Есть Процедура ПриИзменении()

Процедура ПереченьПоселенцевНомерГостиницыПриИзменении(Элемент)
СтрокаТабличнойЧасти = ЭлементыФормы.ПереченьПоселенцев.ТекущиеДанные;
СтрокаТабличнойЧасти.Цена = РаботаСоСправочниками.РозничнаяЦена(Дата,СтрокаТабличнойЧасти.НомерГостиницы);
КонецПроцедуры

При выполнении этого выскакивает ошибка
{ОбщийМодуль.РаботаСоСправочниками(12)}: Ошибка при вызове метода контекста (Выполнить): {(4, 46)}: Неверные параметры "РегистрСведений.Цены.СрезПервых, 1"РегистрСведений.Цены.СрезПервых(&ДатаСреза, <<?>>&ВидНомераГостиницы) КАК ЦеныСрезПервых Выборка = Запрос.Выполнить().Выбрать();по причине:{(4, 46)}: Неверные параметры "РегистрСведений.Цены.СрезПервых, 1"РегистрСведений.Цены.СрезПервых(&ДатаСреза, <<?>>&ВидНомераГостиницы) КАК ЦеныСрезПервых

Помогите её исправить
 
Статус
Закрыто для дальнейших ответов.