Управляемые формы. Вызов процедуры общего модуля.

unknown181538

НеГуру
28.12.2008
1 417
0
#1
Код:
&НаСервереБезКонтекста
Процедура ВычислитьСебестоимостьНаСервере()
РасчетСебестоимости.РассчитатьСебестоимостьПоПартиям();
КонецПроцедуры // ВычислитьСебестоимостьНаСервере()


&НаКлиенте
Процедура ВыполнитьРасчет(Команда)
ВычислитьСебестоимостьНаСервере()
КонецПроцедуры
У модуля РасчетСебестоимость установлен флаг "Сервер", остальные сброшены.
В вышеуказанном виде все работает.
Если пытаюсь сделать :
Код:
&НаКлиенте
Процедура ВыполнитьРасчет(Команда)
РасчетСебестоимости.РассчитатьСебестоимостьПоПартиям();
КонецПроцедуры
1С не видит процедуры.
Получается, что серверная процедура того же модуля доступна в клиенте, а серверная общего модуля нет, и нужно создавать отдельную процедуру для ее вызова? :happy:
 

Дайнеко

Well-known member
19.11.2009
951
0
#3
И у меня нет слов. Пишу программу и пока ориентируюсь только на файл-сервер и в терминале. Мой коллега провел тестирование базы для разных вариантов и разных SQL-серверах. Пришел к выводу, SQL дает прирост скорости только при пользователях от 5 и более.
 

Darlock

Well-known member
04.01.2008
560
1
#4
1С не видит процедуры.
Получается, что серверная процедура того же модуля доступна в клиенте, а серверная общего модуля нет, и нужно создавать отдельную процедуру для ее вызова? unsure.gif
Посмотрите здесь. Не обращайте внимания на заголовок "13 ошибок" там есть пример как делается вызов серверной процедуры из клиента (флаг "Вызов сервера", кажется)
 
M

Mirage

#6
Да галку поставь, "вызов сервера" - да и все. Если галка сервер и больше ничего - то может вызвать только другая серверная процедура.