• Codeby web-security - Курс "Тестирование Веб-Приложений на проникновение с нуля" от команды codeby. Общая теория, подготовка рабочего окружения, пассивный фаззинг и фингерпринт, Активный фаззинг, Уязвимости, Пост-эксплуатация, Инструментальные средства, Social Engeneering и многое другое. Подробнее ...

  • Мобильный клиент нашего форума для Android гаджетов доступен в Google Play Market по этой ссылке. Клиент можно скачать с нашего форума по этой ссылке. Последняя версия МК в нашем телеграм канале вот здесь. Мобильный клиент для IOS находится в itunes по этой ссылке

Проблема Установка Empire

16.12.2017
19
23
#1
Господа, нужна ваша помощь, решил я установить Empire. Нашёл на гитхабе инструкцию, вроде бы ничего сложного.
Выполняю команды:
Bash:
cd /opt
git clone https://github.com/EmpireProject/Empire.git
/opt/Empire/setup/install.sh
/opt/Empire/empire
далее мне выдаёт ошибку, мол не хватает каких то пакетов, устанавливаю их
pip install iptools и т.д
снова запускаю empire мне пишет
Код:
[!] Could not connect to database
[!] Please run database_setup.py
файла database_setup.py не существует зато есть файл setup_database.py запускаю его, меня просят ввести пароль для создания базы данных, после чего программа закрывется.
опять запускаю empire ошибка всё та же
Код:
[!] Could not connect to database
[!] Please run database_setup.py
запускаю файл install.sh что бы посмотреть, может он на что то ругается, а я не заметил.
мне выдало кучу ошибок, писали что то вроде не удалось найти файл или директорию, однако все нужные файлы и директории существовали.
удаляю папку Empire и повторяю всё тоже самое, только устанавливаю всё в домашний каталог.
это результатов никаких не дало.
открываю файл install.sh и нахожу в нём код
Код:
if [[ "$(pwd)" != *setup ]]
then
    cd ./setup
и заменяю его на:
Bash:
if [[ "$(pwd)" != *setup ]]
then
    cd /opt/Empire/setup/
далее опять выполняю install.sh
ошибок почти небыло, на этот раз скрипт находил путь почти ко всем существующим файлам, однако он ещё ссылался на директорию:
/opt/microsoft/powershell/*/DELETE_ME_TO_DISABLE_CONSOLEHOST_TELEMETRY а её как раз таки и не существует.
далее скрипт запускает файл setup_database.py и меня просят ввести пароль для новой базы данных.
установка завершается запускаю empire ошибка никуда не исчезла
Код:
[!] Could not connect to database
[!] Please run database_setup.py
запускаю файл reset.sh если верить описанию на гитхабе он удаляет созданную базу данных.
скрипт выдаёт ошибку: мол не могу найти директорию ./setup открываю скрипт и меняю:
Код:
if [[ "$(pwd)" != *setup ]]
then
    cd ./setup
на
Bash:
if [[ "$(pwd)" != *setup ]]
then
    cd /opt/Empire/setup/
опять запускаю скрипт reset.sh
меня просят ввести пароль от базы данных и...
screen.png screen.png
оно заработало? что это за чертовщина? у меня теперь всё через uninstall.exe запускаться будет? я сомневаюсь в том что empire будет работать корректно, помагите мне
 

~localhost

Well-known member
30.10.2017
151
45
#2
Тоже решил попробывать, у меня установилось без проблем но вот дальше я не ушел, пересмотрел весь ютуб так и не смог настроить слушателя.
 
Симпатии: Понравилось Gruzin

pr0phet

Red Team
02.04.2018
190
271
#3
Господа, нужна ваша помощь, решил я установить Empire. Нашёл на гитхабе инструкцию, вроде бы ничего сложного.
Выполняю команды:
Bash:
cd /opt
git clone https://github.com/EmpireProject/Empire.git
/opt/Empire/setup/install.sh
/opt/Empire/empire
далее мне выдаёт ошибку, мол не хватает каких то пакетов, устанавливаю их
pip install iptools и т.д
снова запускаю empire мне пишет
Код:
[!] Could not connect to database
[!] Please run database_setup.py
файла database_setup.py не существует зато есть файл setup_database.py запускаю его, меня просят ввести пароль для создания базы данных, после чего программа закрывется.
опять запускаю empire ошибка всё та же
Код:
[!] Could not connect to database
[!] Please run database_setup.py
запускаю файл install.sh что бы посмотреть, может он на что то ругается, а я не заметил.
мне выдало кучу ошибок, писали что то вроде не удалось найти файл или директорию, однако все нужные файлы и директории существовали.
удаляю папку Empire и повторяю всё тоже самое, только устанавливаю всё в домашний каталог.
это результатов никаких не дало.
открываю файл install.sh и нахожу в нём код
Код:
if [[ "$(pwd)" != *setup ]]
then
    cd ./setup
и заменяю его на:
Bash:
if [[ "$(pwd)" != *setup ]]
then
    cd /opt/Empire/setup/
далее опять выполняю install.sh
ошибок почти небыло, на этот раз скрипт находил путь почти ко всем существующим файлам, однако он ещё ссылался на директорию:
/opt/microsoft/powershell/*/DELETE_ME_TO_DISABLE_CONSOLEHOST_TELEMETRY а её как раз таки и не существует.
далее скрипт запускает файл setup_database.py и меня просят ввести пароль для новой базы данных.
установка завершается запускаю empire ошибка никуда не исчезла
Код:
[!] Could not connect to database
[!] Please run database_setup.py
запускаю файл reset.sh если верить описанию на гитхабе он удаляет созданную базу данных.
скрипт выдаёт ошибку: мол не могу найти директорию ./setup открываю скрипт и меняю:
Код:
if [[ "$(pwd)" != *setup ]]
then
    cd ./setup
на
Bash:
if [[ "$(pwd)" != *setup ]]
then
    cd /opt/Empire/setup/
опять запускаю скрипт reset.sh
меня просят ввести пароль от базы данных и...
Посмотреть вложение 18278 Посмотреть вложение 18278
оно заработало? что это за чертовщина? у меня теперь всё через uninstall.exe запускаться будет? я сомневаюсь в том что empire будет работать корректно, помагите мне
Как раз под рукой была Кали без емпаира.
Все что сделал:
apt-get update
apt dist-upgrade
git clone EmpireProject/Empire
./setup/install.sh

Установилась без проблем. Попробуй обновить систему до актуальной версии

Тоже решил попробывать, у меня установилось без проблем но вот дальше я не ушел, пересмотрел весь ютуб так и не смог настроить слушателя.
Да, со времен статьи синтаксис немного изменился, но без всяких ютубов на основании этой статьи можно табуляцией найти решение.
5 минут и листенер готов:
1.png 2.png
После ввода сгенерированной команды на винде 10 - прилетел агент.
P.S. Касперу это очень не понравилось :) Прилетел после его выключения.
 

~localhost

Well-known member
30.10.2017
151
45
#4
Да, со времен статьи синтаксис немного изменился, но без всяких ютубов на основании этой статьи можно табуляцией найти решение..
мое первое знакомство с ним было, не малейших понятий не имею зачем он и кто))
Спасибо, буду пробывать


P.S. Касперу это очень не понравилось :) Прилетел после его выключения.
Кстати про антивирусы.
Аваст ms17_10_eternalblue рубит, касперскому все равно, атгуару тоже, а вот включенный аваст видит когда пытаешь получить сессию через этот эксплойт
 
Симпатии: Понравилось Gruzin

pr0phet

Red Team
02.04.2018
190
271
#5
Не правда. Модуль обнаружения сетевых атак гасит его (ms_17_10 имею ввиду) (Kasper Endpoint). Лично проверял. Если Каспер Free, то конечно он не видит, так как он файловый :)
 
Последнее редактирование:
16.12.2017
19
23
#6
Решил я проблему...
всё дело в том что нельзя, просто взять и запустить нужный файл. Сначала нужно перейти в нужную директорию.
в общем: я просто запускал файл install.sh
/opt/Empire/setup/install.sh
нужно было сделать так
cd /opt/Empire/setup/
./install.sh
 
Вверх Снизу