• Codeby web-security - Курс "Тестирование Веб-Приложений на проникновение с нуля" от команды codeby. Общая теория, подготовка рабочего окружения, пассивный фазинг и фингерпринт, Активный фаззинг, Уязвимости, Пост-эксплуатация, Инструментальные средства, Social Engeneering и многое другое. Подробнее ...

  • Мобильный клиент нашего форума для Android гаджетов доступен в Google Play Market по этой ссылке. Клиент можно скачать с нашего форума по этой ссылке. Последняя версия МК в нашем телеграм канале вот здесь

Проблема Установка Kali Linux

vano2003

New member
27.03.2018
1
0
#1
Я не могу установить Kali Linux с флешки пишет что не монтируется cd диск
как решить эту проблему
 

ghost

penetration testing
Red Team
12.05.2016
1 429
2 641
#3
Я не могу установить Kali Linux с флешки пишет что не монтируется cd диск
как решить эту проблему
Выдерни и опять воткни флешку, когда такое пишет. Поможет. Проверено.
 

kn9zz

Member
13.01.2018
16
0
#4
Подскажите пожалуйста еще с такой проблемой: при обновлении вылезает такая ошибка:

Подготовка к распаковке …/6-dradis_3.9.0-0kali2+b1_amd64.deb …
Распаковывается dradis (3.9.0-0kali2+b1) на замену (3.9.0-0kali2) …
Подготовка к распаковке …/7-e2fsprogs-l10n_1.44.1-1_all.deb …
Распаковывается e2fsprogs-l10n (1.44.1-1) на замену (1.44.0-1) …
Подготовка к распаковке …/8-libext2fs2_1.44.1-1_amd64.deb …
Распаковывается libext2fs2:amd64 (1.44.1-1) на замену (1.44.0-1) …
При обработке следующих пакетов произошли ошибки:
/tmp/apt-dpkg-install-pdD7Cq/0-python-apt_1.6.0~rc2_amd64.deb
/tmp/apt-dpkg-install-pdD7Cq/1-python-lxml_4.2.0-1_amd64.deb
/tmp/apt-dpkg-install-pdD7Cq/2-ndiff_7.70+dfsg1-0kali1_all.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

ЧТо это значит и как с этим бороться

и

еще такаое вылезает:

При обработке следующих пакетов произошли ошибки:
/tmp/apt-dpkg-install-8FnCnt/00-python-apt_1.6.0~rc2_amd64.deb
/tmp/apt-dpkg-install-8FnCnt/01-python-lxml_4.2.0-1_amd64.deb
/tmp/apt-dpkg-install-8FnCnt/02-ndiff_7.70+dfsg1-0kali1_all.deb
/tmp/apt-dpkg-install-8FnCnt/03-python-flask_0.12.2-4_all.deb
/tmp/apt-dpkg-install-8FnCnt/04-python-alembic_0.9.7-1_all.deb
/tmp/apt-dpkg-install-8FnCnt/05-python-brotli_1.0.3-1_amd64.deb
/tmp/apt-dpkg-install-8FnCnt/06-python-gdal_2.2.4+dfsg-1_amd64.deb
/tmp/apt-dpkg-install-8FnCnt/07-python-ipaddr_2.2.0-1_all.deb
/tmp/apt-dpkg-install-8FnCnt/08-python-msgpack_0.5.1-3_amd64.deb
/tmp/apt-dpkg-install-8FnCnt/09-python-pyproj_1.9.5.1-3+b2_amd64.deb
/tmp/apt-dpkg-install-8FnCnt/10-python-paramiko_2.4.0-1_all.deb
/tmp/apt-dpkg-install-8FnCnt/11-python-py_1.5.2-1_all.deb
/tmp/apt-dpkg-install-8FnCnt/12-python-pyparsing_2.2.0+dfsg1-2_all.deb
/tmp/apt-dpkg-install-8FnCnt/13-python-pyspatialite_3.0.1-12+b1_amd64.deb
/tmp/apt-dpkg-install-8FnCnt/14-python-pytest_3.3.2-2_all.deb
/tmp/apt-dpkg-install-8FnCnt/15-python-qgis_2.18.17+dfsg-1+b1_amd64.deb
/tmp/apt-dpkg-install-8FnCnt/16-python-qgis-common_2.18.17+dfsg-1_all.deb
/tmp/apt-dpkg-install-8FnCnt/17-python-subprocess32_3.2.7-3_amd64.deb
/tmp/apt-dpkg-install-8FnCnt/18-sqlmap_1.2.3-1_all.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
 

ghost

penetration testing
Red Team
12.05.2016
1 429
2 641
#5
У тебя параллельно с ручным обновлением в фоне идет автообновление в менеджере пакетов.
Подожди немного и обновляйся. Или в менеджере пакетов автообновление отключи.
Поможет.
 
Симпатии: Понравилось Vertigo

kn9zz

Member
13.01.2018
16
0
#6
У тебя параллельно с ручным обновлением в фоне идет автообновление в менеджере пакетов.
Подожди немного и обновляйся. Или в менеджере пакетов автообновление отключи.
Поможет.
У тебя параллельно с ручным обновлением в фоне идет автообновление в менеджере пакетов.
Подожди немного и обновляйся. Или в менеджере пакетов автообновление отключи.
Поможет.
Это в разделе приложения- системные - пакеты? чето не открывается он(
 

kn9zz

Member
13.01.2018
16
0
#8
Для отключения автообновления пишем в терминале:
Код:
dpkg-reconfigure unattended-upgrades
при написании данной команды, терминал наоборот предложил обновляться автоматически(
[automerge]1522586022[/automerge]
может проблема в питоне? как его полностью снести и заново поставить?
 

ghost

penetration testing
Red Team
12.05.2016
1 429
2 641
#9
при написании данной команды, терминал наоборот предложил обновляться автоматически(
[automerge]1522586022[/automerge]
может проблема в питоне? как его полностью снести и заново поставить?
Так ты и выбирай НЕТ при вводе
dpkg-reconfigure unattended-upgrades

Снимок экрана от 2018-04-01 17-51-14.png
чтобы отменить автообновления. А потом спокойно делаешь это вручную через
apt-get update && apt-get dist-upgrade
 
20.07.2016
613
620
#10
Симпатии: Понравилось ghost

ghost

penetration testing
Red Team
12.05.2016
1 429
2 641
#11
потому что он тут везде упоминается)
Такие простыни лучше под спойлер прятать :)
А что у тебя выводит:
cat /etc/apt/sources.list
Может репозитории ненужные подключены? Вот и тянет все подряд при обнове...
 

kn9zz

Member
13.01.2018
16
0
#12
Такие простыни лучше под спойлер прятать :)
А что у тебя выводит:
cat /etc/apt/sources.list
Может репозитории ненужные подключены? Вот и тянет все подряд при обнове...
deb
Для просмотра контента необходимо: Войти или зарегистрироваться
kali-rolling main contrib non-free

согласно имеющейся версии кали
 
20.07.2016
613
620
#13
Пробуй так:
apt-get install -f
apt --fix-broken install
Если данное решение не помогло
dpkg Repair broken packages - (функция восстановления поврежденных пакетов)
[automerge]1522600585[/automerge]
deb
Для просмотра контента необходимо: Войти или зарегистрироваться
kali-rolling main contrib non-free
Это не ответ - покажи что у тебя в sources.list
 
Симпатии: Понравилось Vertigo

Vertigo

Lex mea est Vulgate Linux
Red Team
15.02.2017
787
2 062
#15
Возможно ТС устанавливал программы ,с которыми возникли проблемы с зависимостями.
Код:
# apt-get clean
# apt-get autoremove
# apt-get update
# apt-get -f install
# apt-get dist-upgrade
Ещё можно попытаться так :
Код:
# dpkg --configure -a
В крайнем случае ,можно переустановить пакет :
Код:
# apt-get install --reinstall имя_пакета
 

kn9zz

Member
13.01.2018
16
0
#16
Пробуй так:
apt-get install -f
apt --fix-broken install
Если данное решение не помогло
dpkg Repair broken packages - (функция восстановления поврежденных пакетов)
[automerge]1522600585[/automerge]
root@ssid:~# apt-get install -f
Чтение списков пакетов… Готово
Построение дерева зависимостей
Чтение информации о состоянии… Готово
Следующий пакет устанавливался автоматически и больше не требуется:
gcc-7-base:i386
Для его удаления используйте «apt autoremove».
Будут установлены следующие дополнительные пакеты:
ndiff python-alembic python-apt python-attr python-brotli python-click python-dns
python-flask python-gdal python-ipaddr python-lxml python-msgpack python-nacl
python-paramiko python-pkg-resources python-py python-pyparsing python-pyproj
python-pyspatialite python-pytest python-qgis python-qgis-common python-samba
python-setuptools python-sip python-sqlalchemy python-subprocess32 python-tabulate
python-whois sqlmap
Предлагаемые пакеты:
python-apt-dbg python-apt-doc python-attr-doc python-flask-doc python-lxml-dbg
python-lxml-doc python-nacl-doc python-gssapi python-pytest-xdist python-pyparsing-doc
python-mock python-gpgme python-setuptools-doc python-sqlalchemy-doc python-fdb
Пакеты, которые будут обновлены:
ndiff python-alembic python-apt python-attr python-brotli python-click python-dns
python-flask python-gdal python-ipaddr python-lxml python-msgpack python-nacl
python-paramiko python-pkg-resources python-py python-pyparsing python-pyproj
python-pyspatialite python-pytest python-qgis python-qgis-common python-samba
python-setuptools python-sip python-sqlalchemy python-subprocess32 python-tabulate
python-whois sqlmap
Обновлено 30 пакетов, установлено 0 новых пакетов, для удаления отмечено 0 пакетов, и 319 пакетов не обновлено.
Установлено или удалено не до конца 66 пакетов.
Необходимо скачать 0 B/22,5 MB архивов.
После данной операции, объём занятого дискового пространства возрастёт на 5 539 kB.
Хотите продолжить? [Д/н] Д
Прервано.
[automerge]1522601770[/automerge]
Возможно ТС устанавливал программы ,с которыми возникли проблемы с зависимостями.
Код:
# apt-get clean
# apt-get autoremove
[/QUOTE]
уже на этой команде выдает ту же ошибку, что указал первоначально.
[automerge]1522601845[/automerge]
dpkg Repair broken packages - (функция восстановления поврежденных пакетов)
пишет, чтонет такой команды. и в help тоже про не написано
 
Последнее редактирование:
20.07.2016
613
620
#17
Перезагружаемся.
apt-get -f install
apt --fix-broken install
apt-get update
apt-get upgrade
apt-get autoremove
apt-get dist-upgrade
 

kn9zz

Member
13.01.2018
16
0
#18
Перезагружаемся.
apt-get -f install
apt --fix-broken install
apt-get update
apt-get upgrade
apt-get autoremove
apt-get dist-upgrade
Не помогло(
[automerge]1522604331[/automerge]
мне все-таки кажется дело в питоне. потому что при запуске OSRFramework выдает такую ошибку:

root@ssid:~# mailfy.py -m 'me@spryt.ru'

___ ____ ____ _____ _
/ _ \/ ___|| _ \| ___| __ __ _ _ __ ___ _____ _____ _ __| | __
| | | \___ \| |_) | |_ | '__/ _` | '_ ` _ \ / _ \ \ /\ / / _ \| '__| |/ /
| |_| |___) | _ <| _|| | | (_| | | | | | | __/\ V V / (_) | | | <
\___/|____/|_| \_\_| |_| \__,_|_| |_| |_|\___| \_/\_/ \___/|_| |_|\_\


Version: OSRFramework 0.18.3
Created by: Felix Brezo and Yaiza Rubio, (i3visio)



Mailfy | Copyright (C) F. Brezo and Y. Rubio (i3visio) 2016-2018

This program comes with ABSOLUTELY NO WARRANTY. This is free software, and you
are welcome to redistribute it under certain conditions. For additional info,
visit https://www.gnu.org/licenses/agpl-3.0.txt


2018-04-01 19:35:02.494676 Starting search of 1 different emails in leaked databases.

Note that this will take between 1 and 2 seconds per query due to the thirdparties API restrictions:
[
"me@spryt.ru"
]

Press <Ctrl + C> to stop...

Mailfy will use haveibeenpwned.com (HIBP) and hesidohackeado.com (HSH) APIs to find leaked emails...

1/1 - Searching if me@spryt.ru has been leaked...
me@spryt.ru has been found in at least 30 different leaks.

2018-04-01 19:35:07.103215 A summary of the results obtained is shown in the following table:

Traceback (most recent call last):
File "/usr/local/bin/mailfy.py", line 11, in <module>
sys.exit(main())
File "/usr/local/lib/python2.7/dist-packages/osrframework/mailfy.py", line 638, in main
print(general.success(general.usufyToTextExport(results)))
File "/usr/local/lib/python2.7/dist-packages/osrframework/utils/general.py", line 313, in usufyToTextExport
import pyexcel as pe
File "/usr/lib/python2.7/dist-packages/pyexcel/__init__.py", line 44, in <module>
from .cookbook import (
File "/usr/lib/python2.7/dist-packages/pyexcel/cookbook.py", line 12, in <module>
from .sources import get_book, get_sheet, save_as
File "/usr/lib/python2.7/dist-packages/pyexcel/sources/__init__.py", line 22, in <module>
from . import memory, file, database, http
File "/usr/lib/python2.7/dist-packages/pyexcel/sources/memory.py", line 10, in <module>
from pyexcel_io.deprecated import load_data
ImportError: No module named deprecated
 
20.07.2016
613
620
#19
Попробуй так
dpkg --configure -a
или переконфигурировать всё
dpkg-reconfigure -a
 
Вверх Снизу