1. Требуются разработчики и тестеры для проекта codebyOS. Требования для участия в проекте: Знание принципов работы ОС на базе Linux; Знание Bash; Крайне желательное знание CPP, Python, Lua; Навыки системного администрирования. Подробнее ...

    Скрыть объявление

УТ Доработать рабочее место менеджера по продажам

Тема в разделе "1C и всё что с ней связано", создана пользователем Спартак, 21 янв 2010.

  1. Спартак

    Спартак Well-Known Member

    Репутация:
    0
    Регистрация:
    2 май 2009
    Сообщения:
    69
    Симпатии:
    0
    Доброго времени суток!
    Возникла задача: в УТ доработать типовую обработку "Рабочее место менеджера по продажам". А сделать нужно следующее: в левой части формы в табличной части Номенклатура добывить еще одну колонку - количество на складе.
    В самой обработке эта таблица имеет тип СправочникСписок.Номенклатура. Перебрал уже кучу вариантов - пока безрезультатно. Думаю, может проще переписать ее (левую часть обработки :angry2:))) с нуля??
    Что посоветуете??
     
  2. Mirage

    Mirage Гость

    Репутация:
    0

    Добавь колонку и при событии "при получении данных" заполняй ее остатками?
     
  3. evgenyatam

    evgenyatam Well-Known Member

    Репутация:
    0
    Регистрация:
    7 сен 2007
    Сообщения:
    175
    Симпатии:
    0
    можно и в событии "при выводе строки".
    пример 1:
    Процедура ТабличноеПоле1ПриВыводеСтроки(Элемент, ОформлениеСтроки, ДанныеСтроки)
    //ОформлениеСтроки.Ячейки.КнНормализовать.ОтображатьТекст = Истина;
    //ОформлениеСтроки.Ячейки.КнНормализовать.Текст = "O"; //"о"
    ОформлениеСтроки.Ячейки.КнНормализовать.ОтображатьКартинку = Истина;
    ОформлениеСтроки.Ячейки.КнНормализовать.ИндексКартинки =0;
    КонецПроцедуры

    пример 2:
    Процедура ДокументСписокПриПолученииДанных(Элемент, ОформленияСтрок)
    НазванияДней=Новый Массив();
    НазванияДней.Добавить("Понедельник");
    НазванияДней.Добавить("Вторник");
    НазванияДней.Добавить("Среда");
    НазванияДней.Добавить("Четверг");
    НазванияДней.Добавить("Пятница");
    НазванияДней.Добавить("Суббота");
    НазванияДней.Добавить("Воскресенье");
    Для каждого Стр Из ОформленияСтрок Цикл
    мДата = Стр.ДанныеСтроки.Дата;
    мДень = ДеньНедели(мДата);
    Стр.Ячейки.Колонка1.ОтображатьТекст=Истина;
    Стр.Ячейки.Колонка1.Текст = НазванияДней[мДень-1];
    КонецЦикла;
    КонецПроцедуры
     
  4. Спартак

    Спартак Well-Known Member

    Репутация:
    0
    Регистрация:
    2 май 2009
    Сообщения:
    69
    Симпатии:
    0
    спасибо! буду пробовать. еще такой вопрос... если получится вывести остатки, то возможно ли будет сортировать по ним стандартными средствами??
     
  5. Mirage

    Mirage Гость

    Репутация:
    0
    Не учи плохому, при выводе строки будет делать запрос в БД для каждой строки, а это не гегиенично

    Нет
     
  6. evgenyatam

    evgenyatam Well-Known Member

    Репутация:
    0
    Регистрация:
    7 сен 2007
    Сообщения:
    175
    Симпатии:
    0
    правильно!! когда мне понадобилось вывести в документ список номенклатуры с остатками, я остатки держал в таблице значений. за одно и контролировать по остаткам проще.
     
  7. Pro

    Pro Гость

    Репутация:
    0
    Mirage
    а если остатки меняются в процессе работы с этой накладной?
     
  8. Mirage

    Mirage Гость

    Репутация:
    0
    Мы вроде как про рабочее место манагера по продажам :)
     
  9. evgenyatam

    evgenyatam Well-Known Member

    Репутация:
    0
    Регистрация:
    7 сен 2007
    Сообщения:
    175
    Симпатии:
    0
    тогда вариант "при получении данных" вообще не проходит. эта процедура слишком редко вызывается.
     
  10. Pro

    Pro Гость

    Репутация:
    0
    не знаю как у вас у нас манагер над одной накладной может и целый день проработать, открывая и закрывая ее по несколько раз за день
     
  11. Mirage

    Mirage Гость

    Репутация:
    0
    Подключи ему обработчик оповещения к накладной, пусть обработка подбора знает что он там с остатками делает,
    Но это все естественно в пределах одного сеанса, для того что бы делать корректно для нескольких сеансов, надо что бы либо остатки брались исключительно из резерва и только один человек мог работать с этим резервом, либо писать в какую то таблицу что набивается в не проведенную накладную
     
  12. Sawunya2010

    Sawunya2010 Гость

    Репутация:
    0
    Здравствуйте уважаемые знатоки! Я чайник в программировании, но у меня стоит срочная задача, но не знаю, как ее выполнить. Помогите, плиз! ГОРЮ! Мне нужно в обработке "Рабочее место менеджера", на вкладке "остатки, цены", добавить колонки качество товара и организация к которой он принадлежит. Прилагаю код и версию конфигурации. ПОМОГИТЕ!!! ПОЖАЛУЙСТА!!!
     

    Вложения:

Загрузка...

Поделиться этой страницей