УТ Доработать рабочее место менеджера по продажам

Спартак

Well-known member
02.05.2009
69
0
#1
Доброго времени суток!
Возникла задача: в УТ доработать типовую обработку "Рабочее место менеджера по продажам". А сделать нужно следующее: в левой части формы в табличной части Номенклатура добывить еще одну колонку - количество на складе.
В самой обработке эта таблица имеет тип СправочникСписок.Номенклатура. Перебрал уже кучу вариантов - пока безрезультатно. Думаю, может проще переписать ее (левую часть обработки :angry2:))) с нуля??
Что посоветуете??
 
M

Mirage

#2
Доброго времени суток!
Возникла задача: в УТ доработать типовую обработку "Рабочее место менеджера по продажам". А сделать нужно следующее: в левой части формы в табличной части Номенклатура добывить еще одну колонку - количество на складе.
В самой обработке эта таблица имеет тип ссылка на номенклатуру. Перебрал уже кучу вариантов - пока безрезультатно. Думаю, может проще переписать ее (левую часть обработки (IMG:style_emoticons/default/smile.gif) ))) с нуля??
Что посоветуете??

Добавь колонку и при событии "при получении данных" заполняй ее остатками?
 

evgenyatam

Well-known member
07.09.2007
175
0
#3
Добавь колонку и при событии "при получении данных" заполняй ее остатками?
можно и в событии "при выводе строки".
пример 1:
Процедура ТабличноеПоле1ПриВыводеСтроки(Элемент, ОформлениеСтроки, ДанныеСтроки)
//ОформлениеСтроки.Ячейки.КнНормализовать.ОтображатьТекст = Истина;
//ОформлениеСтроки.Ячейки.КнНормализовать.Текст = "O"; //"о"
ОформлениеСтроки.Ячейки.КнНормализовать.ОтображатьКартинку = Истина;
ОформлениеСтроки.Ячейки.КнНормализовать.ИндексКартинки =0;
КонецПроцедуры

пример 2:
Процедура ДокументСписокПриПолученииДанных(Элемент, ОформленияСтрок)
НазванияДней=Новый Массив();
НазванияДней.Добавить("Понедельник");
НазванияДней.Добавить("Вторник");
НазванияДней.Добавить("Среда");
НазванияДней.Добавить("Четверг");
НазванияДней.Добавить("Пятница");
НазванияДней.Добавить("Суббота");
НазванияДней.Добавить("Воскресенье");
Для каждого Стр Из ОформленияСтрок Цикл
мДата = Стр.ДанныеСтроки.Дата;
мДень = ДеньНедели(мДата);
Стр.Ячейки.Колонка1.ОтображатьТекст=Истина;
Стр.Ячейки.Колонка1.Текст = НазванияДней[мДень-1];
КонецЦикла;
КонецПроцедуры
 

Спартак

Well-known member
02.05.2009
69
0
#4
спасибо! буду пробовать. еще такой вопрос... если получится вывести остатки, то возможно ли будет сортировать по ним стандартными средствами??
 
M

Mirage

#5
можно и в событии "при выводе строки".
пример 1:
Процедура ТабличноеПоле1ПриВыводеСтроки(Элемент, ОформлениеСтроки, ДанныеСтроки)
//ОформлениеСтроки.Ячейки.КнНормализовать.ОтображатьТекст = Истина;
//ОформлениеСтроки.Ячейки.КнНормализовать.Текст = "O"; //"о"
ОформлениеСтроки.Ячейки.КнНормализовать.ОтображатьКартинку = Истина;
ОформлениеСтроки.Ячейки.КнНормализовать.ИндексКартинки =0;
КонецПроцедуры

пример 2:
Процедура ДокументСписокПриПолученииДанных(Элемент, ОформленияСтрок)
НазванияДней=Новый Массив();
НазванияДней.Добавить("Понедельник");
НазванияДней.Добавить("Вторник");
НазванияДней.Добавить("Среда");
НазванияДней.Добавить("Четверг");
НазванияДней.Добавить("Пятница");
НазванияДней.Добавить("Суббота");
НазванияДней.Добавить("Воскресенье");
Для каждого Стр Из ОформленияСтрок Цикл
мДата = Стр.ДанныеСтроки.Дата;
мДень = ДеньНедели(мДата);
Стр.Ячейки.Колонка1.ОтображатьТекст=Истина;
Стр.Ячейки.Колонка1.Текст = НазванияДней[мДень-1];
КонецЦикла;
КонецПроцедуры
Не учи плохому, при выводе строки будет делать запрос в БД для каждой строки, а это не гегиенично

спасибо! буду пробовать. еще такой вопрос... если получится вывести остатки, то возможно ли будет сортировать по ним стандартными средствами??
Нет
 

evgenyatam

Well-known member
07.09.2007
175
0
#6
Не учи плохому, при выводе строки будет делать запрос в БД для каждой строки, а это не гегиенично
правильно!! когда мне понадобилось вывести в документ список номенклатуры с остатками, я остатки держал в таблице значений. за одно и контролировать по остаткам проще.
 
P
#7
Mirage
а если остатки меняются в процессе работы с этой накладной?
 
P
#10
не знаю как у вас у нас манагер над одной накладной может и целый день проработать, открывая и закрывая ее по несколько раз за день
 
M

Mirage

#11
не знаю как у вас у нас манагер над одной накладной может и целый день проработать, открывая и закрывая ее по несколько раз за день
Подключи ему обработчик оповещения к накладной, пусть обработка подбора знает что он там с остатками делает,
Но это все естественно в пределах одного сеанса, для того что бы делать корректно для нескольких сеансов, надо что бы либо остатки брались исключительно из резерва и только один человек мог работать с этим резервом, либо писать в какую то таблицу что набивается в не проведенную накладную
 
S

Sawunya2010

#12
Здравствуйте уважаемые знатоки! Я чайник в программировании, но у меня стоит срочная задача, но не знаю, как ее выполнить. Помогите, плиз! ГОРЮ! Мне нужно в обработке "Рабочее место менеджера", на вкладке "остатки, цены", добавить колонки качество товара и организация к которой он принадлежит. Прилагаю код и версию конфигурации. ПОМОГИТЕ!!! ПОЖАЛУЙСТА!!!
 

Вложения