V 8.2 Создать элемент справочника

Тема в разделе "1C и всё что с ней связано", создана пользователем Antonn28, 25 апр 2011.

Статус темы:
Закрыта.
  1. Antonn28

    Antonn28 Гость

    Создаю элемент справочника при записи документа! 1С ругается! Подскажите в чем может быть ошибка!
    &НаКлиенте
    Процедура ПередЗаписью(Отказ,Код,Объект, ПараметрыЗаписи)
    УправлениеПоступлением.ГруппироватьЭРИ(Объект,Код)
    КонецПроцедуры

    &НаСервере
    Процедура ГруппироватьЭРИ(Объект,Код) Экспорт
    ПартияЭРИ=Справочники.ПартииЭРИ;
    СсылкаНайденного=ПартияЭРИ.НайтиПоКоду(Код);
    Если СсылкаНайденного.Пустая() Тогда
    Для каждого СтрокаДокумента Из Объект.Поступление Цикл
    СправочникОбъект=Справочники.ПартииЭРИ.СоздатьЭлемент();
    СправочникОбъект.Наименование=СтрокаДокумента.ТипЭРИ;
    СправочникОбъект.Владелец=СтрокаДокумента.ТипЭРИ;
    СправочникОбъект.Индекс=СтрокаДокумента.Индекс;
    СправочникОбъект.Изготовитель=СтрокаДокумента.Изготовитель;
    СправочникОбъект.ДатаПоступления=Объект.Дата;
    СправочникОбъект.Партия=СтрокаДокумента.Партия;
    СправочникОбъект.ДатаИзготовления=СтрокаДокумента.ДатаИзготовления;
    СправочникОбъект.ЕдИзмерения=СтрокаДокумента.ЕдИзмерения;
    СправочникОбъект.Цена=СтрокаДокумента.Цена;
    СправочникОбъект.Количество=СтрокаДокумента.Количество;
    СправочникОбъект.ДокументПоступления=Объект.Ссылка;
    СправочникОбъект.Счет=Объект.Счет;
    СправочникОбъект.ПроцентНДС=Объект.ПроцентНДС;
    СправочникОбъект.Сумма=СтрокаДокумента.Сумма;
    СправочникОбъект.ДокКачества=СтрокаДокумента.ДокКачества;
    СправочникОбъект.Золото=СтрокаДокумента.Золото;
    СправочникОбъект.ЗолотоКобальт=СтрокаДокумента.ЗолотоКобальт;
    СправочникОбъект.Серебро=СтрокаДокумента.Серебро;
    СправочникОбъект.Серебро999=СтрокаДокумента.Серебро999;
    СправочникОбъект.СереброПалладий=СтрокаДокумента.СереброПалладий;
    СправочникОбъект.СереброПлатина=СтрокаДокумента.СереброПлатина;
    СправочникОбъект.СерМагнНик=СтрокаДокумента.СерМагнНик;
    СправочникОбъект.Записать();
    СсылкаНаЭлемент=СправочникОбъект.Ссылка;
    СтрокаДокумента.Код=СсылкаНаЭлемент.Код;
    КонецЦикла;
    Иначе СправочникОбъект=СсылкаНайденного.ПолучитьОбъект();
    Для каждого СтрокаДокумента Из Объект.Поступление Цикл
    СправочникОбъект=Справочники.ПартииЭри.СоздатьЭлемент();
    СправочникОбъект.Наименование=СтрокаДокумента.ТипЭРИ;
    СправочникОбъект.Владелец=СтрокаДокумента.ТипЭРИ;
    СправочникОбъект.Индекс=СтрокаДокумента.Индекс;
    СправочникОбъект.Изготовитель=СтрокаДокумента.Изготовитель;
    СправочникОбъект.ДатаПоступления=Объект.Дата;
    СправочникОбъект.Партия=СтрокаДокумента.Партия;
    СправочникОбъект.ДатаИзготовления=СтрокаДокумента.ДатаИзготовления;
    СправочникОбъект.ЕдИзмерения=СтрокаДокумента.ЕдИзмерения;
    СправочникОбъект.Цена=СтрокаДокумента.Цена;
    СправочникОбъект.Количество=СтрокаДокумента.Количество;
    СправочникОбъект.ДокументПоступления=Объект.Ссылка;
    СправочникОбъект.Счет=Объект.Счет;
    СправочникОбъект.ПроцентНДС=Объект.ПроцентНДС;
    СправочникОбъект.Сумма=СтрокаДокумента.Сумма;
    СправочникОбъект.ДокКачества=СтрокаДокумента.ДокКачества;
    СправочникОбъект.Золото=СтрокаДокумента.Золото;
    СправочникОбъект.ЗолотоКобальт=СтрокаДокумента.ЗолотоКобальт;
    СправочникОбъект.Серебро=СтрокаДокумента.Серебро;
    СправочникОбъект.Серебро999=СтрокаДокумента.Серебро999;
    СправочникОбъект.СереброПалладий=СтрокаДокумента.СереброПалладий;
    СправочникОбъект.СереброПлатина=СтрокаДокумента.СереброПлатина;
    СправочникОбъект.СерМагнНик=СтрокаДокумента.СерМагнНик;
    СправочникОбъект.Записать();
    СсылкаНаЭлемент=СправочникОбъект.Ссылка;
    СтрокаДокумента.Код=СсылкаНаЭлемент.Код;
    КонецЦикла;
    КонецЕсли;
    КонецПроцедуры

    {ОбщийМодуль.УправлениеПоступлением.Модуль(15)}: Значение не является значением объектного типа (Поступление)
    Для каждого СтрокаДокумента Из Объект.Поступление Цикл
    Подскажите в чем ошибка!!!
     
  2. KiR

    KiR НЕ шибка опытный програмер)
    1C Team

    Регистрация:
    11 сен 2007
    Сообщения:
    1.581
    Симпатии:
    0
    отладчик в зубы! и смотреть что содержит в себе Объект
     
  3. Дайнеко

    Дайнеко Well-Known Member
    1C Team

    Регистрация:
    19 ноя 2009
    Сообщения:
    951
    Симпатии:
    0
    Обожаю примеры в 2 экрана, да еще не оформленные стилем. Я добрый и помочь готов, но изложите мне проблему а не "ДокКачества".
     
  4. unknown181538

    unknown181538 НеГуру
    1C Team

    Регистрация:
    28 дек 2008
    Сообщения:
    1.418
    Симпатии:
    0
    Мож нету у него такой табличной части?))
     
  5. Allexei

    Allexei Well-Known Member

    Регистрация:
    2 май 2008
    Сообщения:
    322
    Симпатии:
    0
    Включаешь остановку по ошибке и смотришь что там такого ты наворотил. Так же посмотри что содержит в себе сам Объект и определи является ли доступным твои "Продажи" в контексте сервера
     
  6. Antonn28

    Antonn28 Гость

    Уже Давно разобрался!!!
     
  7. unknown181538

    unknown181538 НеГуру
    1C Team

    Регистрация:
    28 дек 2008
    Сообщения:
    1.418
    Симпатии:
    0
    За дублированный код отрывать руки!!! Знаете, как тоскливо разбирать чем код в первой ветви условия отличается от второй?

    Добавлено:
    И ЗаполнитьЗначенияСвойств() напрашивается.
     
  8. Antonn28

    Antonn28 Гость

    Уже давно все переделал и разобрался! Тема закрыта!
     
Загрузка...
Статус темы:
Закрыта.

Поделиться этой страницей