V 8.2 Создать элемент справочника

  • Автор темы Antonn28
  • Дата начала
Статус
Закрыто для дальнейших ответов.
A

Antonn28

Гость
#1
Создаю элемент справочника при записи документа! 1С ругается! Подскажите в чем может быть ошибка!
&НаКлиенте
Процедура ПередЗаписью(Отказ,Код,Объект, ПараметрыЗаписи)
УправлениеПоступлением.ГруппироватьЭРИ(Объект,Код)
КонецПроцедуры

&НаСервере
Процедура ГруппироватьЭРИ(Объект,Код) Экспорт
ПартияЭРИ=Справочники.ПартииЭРИ;
СсылкаНайденного=ПартияЭРИ.НайтиПоКоду(Код);
Если СсылкаНайденного.Пустая() Тогда
Для каждого СтрокаДокумента Из Объект.Поступление Цикл
СправочникОбъект=Справочники.ПартииЭРИ.СоздатьЭлемент();
СправочникОбъект.Наименование=СтрокаДокумента.ТипЭРИ;
СправочникОбъект.Владелец=СтрокаДокумента.ТипЭРИ;
СправочникОбъект.Индекс=СтрокаДокумента.Индекс;
СправочникОбъект.Изготовитель=СтрокаДокумента.Изготовитель;
СправочникОбъект.ДатаПоступления=Объект.Дата;
СправочникОбъект.Партия=СтрокаДокумента.Партия;
СправочникОбъект.ДатаИзготовления=СтрокаДокумента.ДатаИзготовления;
СправочникОбъект.ЕдИзмерения=СтрокаДокумента.ЕдИзмерения;
СправочникОбъект.Цена=СтрокаДокумента.Цена;
СправочникОбъект.Количество=СтрокаДокумента.Количество;
СправочникОбъект.ДокументПоступления=Объект.Ссылка;
СправочникОбъект.Счет=Объект.Счет;
СправочникОбъект.ПроцентНДС=Объект.ПроцентНДС;
СправочникОбъект.Сумма=СтрокаДокумента.Сумма;
СправочникОбъект.ДокКачества=СтрокаДокумента.ДокКачества;
СправочникОбъект.Золото=СтрокаДокумента.Золото;
СправочникОбъект.ЗолотоКобальт=СтрокаДокумента.ЗолотоКобальт;
СправочникОбъект.Серебро=СтрокаДокумента.Серебро;
СправочникОбъект.Серебро999=СтрокаДокумента.Серебро999;
СправочникОбъект.СереброПалладий=СтрокаДокумента.СереброПалладий;
СправочникОбъект.СереброПлатина=СтрокаДокумента.СереброПлатина;
СправочникОбъект.СерМагнНик=СтрокаДокумента.СерМагнНик;
СправочникОбъект.Записать();
СсылкаНаЭлемент=СправочникОбъект.Ссылка;
СтрокаДокумента.Код=СсылкаНаЭлемент.Код;
КонецЦикла;
Иначе СправочникОбъект=СсылкаНайденного.ПолучитьОбъект();
Для каждого СтрокаДокумента Из Объект.Поступление Цикл
СправочникОбъект=Справочники.ПартииЭри.СоздатьЭлемент();
СправочникОбъект.Наименование=СтрокаДокумента.ТипЭРИ;
СправочникОбъект.Владелец=СтрокаДокумента.ТипЭРИ;
СправочникОбъект.Индекс=СтрокаДокумента.Индекс;
СправочникОбъект.Изготовитель=СтрокаДокумента.Изготовитель;
СправочникОбъект.ДатаПоступления=Объект.Дата;
СправочникОбъект.Партия=СтрокаДокумента.Партия;
СправочникОбъект.ДатаИзготовления=СтрокаДокумента.ДатаИзготовления;
СправочникОбъект.ЕдИзмерения=СтрокаДокумента.ЕдИзмерения;
СправочникОбъект.Цена=СтрокаДокумента.Цена;
СправочникОбъект.Количество=СтрокаДокумента.Количество;
СправочникОбъект.ДокументПоступления=Объект.Ссылка;
СправочникОбъект.Счет=Объект.Счет;
СправочникОбъект.ПроцентНДС=Объект.ПроцентНДС;
СправочникОбъект.Сумма=СтрокаДокумента.Сумма;
СправочникОбъект.ДокКачества=СтрокаДокумента.ДокКачества;
СправочникОбъект.Золото=СтрокаДокумента.Золото;
СправочникОбъект.ЗолотоКобальт=СтрокаДокумента.ЗолотоКобальт;
СправочникОбъект.Серебро=СтрокаДокумента.Серебро;
СправочникОбъект.Серебро999=СтрокаДокумента.Серебро999;
СправочникОбъект.СереброПалладий=СтрокаДокумента.СереброПалладий;
СправочникОбъект.СереброПлатина=СтрокаДокумента.СереброПлатина;
СправочникОбъект.СерМагнНик=СтрокаДокумента.СерМагнНик;
СправочникОбъект.Записать();
СсылкаНаЭлемент=СправочникОбъект.Ссылка;
СтрокаДокумента.Код=СсылкаНаЭлемент.Код;
КонецЦикла;
КонецЕсли;
КонецПроцедуры

{ОбщийМодуль.УправлениеПоступлением.Модуль(15)}: Значение не является значением объектного типа (Поступление)
Для каждого СтрокаДокумента Из Объект.Поступление Цикл
Подскажите в чем ошибка!!!
 

KiR

НЕ шибка опытный програмер)
11.09.2007
1 581
0
#2
отладчик в зубы! и смотреть что содержит в себе Объект
 

Дайнеко

Well-Known Member
19.11.2009
951
0
#3
Обожаю примеры в 2 экрана, да еще не оформленные стилем. Я добрый и помочь готов, но изложите мне проблему а не "ДокКачества".
 

Allexei

Well-Known Member
02.05.2008
322
1
#5
Включаешь остановку по ошибке и смотришь что там такого ты наворотил. Так же посмотри что содержит в себе сам Объект и определи является ли доступным твои "Продажи" в контексте сервера
 

unknown181538

НеГуру
28.12.2008
1 417
0
#7
За дублированный код отрывать руки!!! Знаете, как тоскливо разбирать чем код в первой ветви условия отличается от второй?

Добавлено:
За дублированный код отрывать руки!!! Знаете, как тоскливо разбирать чем код в первой ветви условия отличается от второй?
И ЗаполнитьЗначенияСвойств() напрашивается.
 
A

Antonn28

Гость
#8
За дублированный код отрывать руки!!! Знаете, как тоскливо разбирать чем код в первой ветви условия отличается от второй?

Добавлено:
И ЗаполнитьЗначенияСвойств() напрашивается.
Уже давно все переделал и разобрался! Тема закрыта!
 
Статус
Закрыто для дальнейших ответов.