Веб сервер для 1С 8.2

Тема в разделе "1C и всё что с ней связано", создана пользователем UndeadFun, 25 авг 2011.

Статус темы:
Закрыта.
  1. UndeadFun

    UndeadFun Гость

    Здравствуйте. Суть проблемы такова. Устанавливал веб сервер Apache 2.0 по инструкции с официального сайта 1С. Все прошло гладко. Теперь пытаюсь подключится к серверу, выдает собщение об ошибке:
    1C:Enterprise 8 application error:
    Ошибка при разборе дескриптора виртуальных ресурсовby reason:
    Ошибка разбора XML: - [5,19] Фатальная ошибка: Input is not proper UTF-8, indicate encoding ! Bytes: 0xD1 0x5C 0x54 0x45 SystemId: file://C:/www/MyApp/default.VRD

    Есть какие-нибудь идеи?
    ОС: Win XP
     
  2. vitfil

    vitfil IT-интегратор

    Регистрация:
    2 апр 2004
    Сообщения:
    2.070
    Симпатии:
    0
    Есть!
     
  3. UndeadFun

    UndeadFun Гость

    Буду рад услышать, точнее увидеть)
     
  4. vitfil

    vitfil IT-интегратор

    Регистрация:
    2 апр 2004
    Сообщения:
    2.070
    Симпатии:
    0
    1. Качаем апач 2.2 с официального родного ресурса.
    2. Устанавливаем в дефолтном виде.
    3. Сносим IIS с компа.

    Вуаля.
     
  5. UndeadFun

    UndeadFun Гость

    Спасибо за совет, но не помгло(((
     
  6. vitfil

    vitfil IT-интегратор

    Регистрация:
    2 апр 2004
    Сообщения:
    2.070
    Симпатии:
    0
    Что не помогло? Апач не стартует или что?
     
  7. UndeadFun

    UndeadFun Гость

    Апач стартует, все нормально.Но ошибка изначальная не исчезла. Она вылетает уже в момент подключения в браузере, т.е. когда я пишу в строке адреса: Http://localhost/myApp
     
  8. puh14

    puh14 Well-Known Member
    1C Team

    Регистрация:
    11 июл 2008
    Сообщения:
    1.412
    Симпатии:
    0
    Ну раз пишет про кодировки - то и искать надо тексты где задаются кодировки. В браузере отрубить автоматическое определение кодировки, поставить utf-8, а в default.VRD искать строчку encoding (не уверен что она там есть - давно колупался) и задавать там нужную кодировку.
     
  9. UndeadFun

    UndeadFun Гость

    Большое спасибо. дело было не совсем в этом, но ответ натолкнул на мысль. оказывается у меня в пути к базе была папка, которая называется 1С, и я совершенно случайно не учел, когда писал путь, что папка у меня с русской "С", ну в файле прописана латинская.
    Всем спасибо, тему можно закрывать
    http://uafile.com/file/23385/AdmWebServ-mht.html - вот ссылка на файл - инстркцию по установке веб-сервера, кому надо.
     
  10. vitfil

    vitfil IT-интегратор

    Регистрация:
    2 апр 2004
    Сообщения:
    2.070
    Симпатии:
    0
    Какая там может быть инструкция? Все ставится с настройками по умолчанию. Из коробки.
     
Загрузка...
Статус темы:
Закрыта.

Поделиться этой страницей