Ver 7.7 Проблема набора первого символа в поле ввода

Тема в разделе "1C и всё что с ней связано", создана пользователем Tulipe, 16 мар 2010.

Статус темы:
Закрыта.
  1. Tulipe

    Tulipe Гость

    Репутация:
    0
    Здравствуйте!
    Кто-нибудь встречался с ситуацией: в ver 7.7 1С на форме списка справочника есть поле ввода(для поиска по строке).
    Задача - изменить значение в имеющемся поле ввода. При наборе символов в этом поле первым нажатием стирается имеющийся набор символов в поле ввода и ввод начинается со второго символа. Как сделать, чтобы первым нажатием и стерлось старое и стало вводиться новое? Возможно ли это реализовать программно через модуль формы или же глобальный модуль?
     
  2. Andruha

    Andruha Гость

    Репутация:
    0
    Я так понимаю это 1С - какая версия?
     
  3. Tulipe

    Tulipe Гость

    Репутация:
    0
    Это версия 7.7 1С
     
  4. SeverBap

    SeverBap Well-Known Member
    1C Team

    Репутация:
    0
    Регистрация:
    18 сен 2007
    Сообщения:
    451
    Симпатии:
    0
    покажи скрин!
     
  5. Tulipe

    Tulipe Гость

    Репутация:
    0
    Какой скрин? Код формы отобразить? Я только знаю, что это некий баг седьмой версии, и что нужен какой-то патчер. Кто-нибудь может поведать поподробнее?
     
  6. SeverBap

    SeverBap Well-Known Member
    1C Team

    Репутация:
    0
    Регистрация:
    18 сен 2007
    Сообщения:
    451
    Симпатии:
    0
    сколько тыкал и смотрел у себя нигде такого нет все там нормально!
    ....
     
  7. Hryv

    Hryv Гость

    Репутация:
    0
    Так происходит если в поле введена строка на всю его длину
    Естественно не на видимую длину, а на ту, которая в конфигураторе задана

    Как побороть - не знаю
    Можно сначала нажимать пробел или BackSpase
     
  8. unknown181538

    unknown181538 НеГуру
    1C Team

    Репутация:
    0
    Регистрация:
    28 дек 2008
    Сообщения:
    1.417
    Симпатии:
    0
    "ПриНачалеВыбораЗначения" не сработает подходящим образом?
     
  9. Дайнеко

    Дайнеко Well-Known Member
    1C Team

    Репутация:
    0
    Регистрация:
    19 ноя 2009
    Сообщения:
    951
    Симпатии:
    0
    А я, старый пень, всю жизнь видел такое явление иногда, но думал мерещится. И зависимости не заметил. Спасибо, однако.

    Соображения:
    * этот глюк 1С уже не исправит никогда.
    * лично я с этой "проблемой" бороться не буду.
    * я решил бы ее так:
    1.Вар-т: Расшить поле на 1 символ
    2.Вар-т: Задействовать WScript. С его помощью после ввода предыдущего поля послать имитацию Home.
    Получится, что выделение пропадет, но не будет проглатываться первая буква, т.е. оператор будет бить поверх.
     
  10. Andrus

    Andrus Гость

    Репутация:
    0
    Из личных исследований, и наблюдений попробую смоделировать на своем примере.
    1. Имеем справочник "Клиенты" и подчиненный ему справочник "ФизАдреса" (к примеру)
    2. Если открыть подчиненный справочник (в нашем случае ФизАдреса) и не закрывая его перейти в справочник владелец в форму списка то вышеописаный глюк появляется до тех пор пока не закрыть форму подчиненного справочника (на связь объектов и зависимость никак не влияет, по крайней мере не находил).
     
  11. satone

    satone Гость

    Репутация:
    0
    Понимаю, что некропост, но тем не менее проблема до сих пор актуальна - искал во всем инете нашел только эту тему. Проблема решается как-нибудь? Желательно настройками и с минимальным вмешательством в конфигурацию. По своим ощущениям - проблема возникает спонтанно и через некоторое время исчезает. Чем вызвана - абсолютно не ясно.
     
Загрузка...
Статус темы:
Закрыта.

Поделиться этой страницей