Висит Smtp (domino 8.5.3fp1)

lemuriez

Well-Known Member
14.06.2012
52
0
#1
Здравствуйте!
Случилась вот такая проблема:
В задачах сервера стали появляться записи вида

SMTP Server Providing service for <IP_mail_gateway>
SMTP Server Providing service for <IP_mail_gateway>
SMTP Server Providing service for <IP_mail_gateway>

К концу рабочего дня их количество растет. При этом процесс nsmtp.exe на сервере занимает 90-100% процессора, ну и тормозит все соответственно. Также невозможно остановить и перезапустить службу SMTP на Domino.
В точности эта ошибка описана в статье IBM #1445280, но там также указано, что это исправлено в 8.5.2FP1 и 8.5.3. У нас Domino 8.5.3FP1.
По наблюдениям происходить это начало после включения сжатия вложений LZ1 и элементов дизайна на базах, созданных по некоторым почтовым шаблонам. Но как это может быть связано с SMTP?
 

lemuriez

Well-Known Member
14.06.2012
52
0
#2
И еще вопрос, кто-нибудь уже накатывал 8.5.3 Fix Pack 2? Насколько он стабильный? Хуже не будет?
 

Мыш

Well-Known Member
Lotus team
12.02.2008
1 084
13
#3
По наблюдениям происходить это начало после включения сжатия вложений LZ1 и элементов дизайна на базах, созданных по некоторым почтовым шаблонам.
ЧистА теоретиццки - распаковывает перед отправкой и при этом испытывает какие-то траблы . LZ1 у нас тоже включен, но НЕ на шлюзе (т.е, НЕ на сервере, отправляющем почту в инет).
PS. Индусам верить низзя - это я о фикспэках. :)
PPS. FP2 ставил (32-bit linux), но, опять же, НЕ на шлюз. Сам по себе - работает.
PPS. У Вас винда 2008 ли еще новее? Покопайте гуголь на тему работы приложений, использующих TCP/IP ( необязательно по лотусу, скажем, по ораклу, по сиквелу и т.д.). Поди опять МСявые какие-нить ограничения ввели.
 

lemuriez

Well-Known Member
14.06.2012
52
0
#4
Win2003 у нас. Архивирование отключил - все-равно висит. Отключил вообще все, что включал последние 4 дня.
А еще неделю назад включал сжатие сетевого трафика, галочку на клиенты накатывал через org.policy. Может она только сейчас накатилась?

В любом случае, отключил сейчас и это. Проверим что же это такое и вылечится ли.
 

lemuriez

Well-Known Member
14.06.2012
52
0
#5
Отключение сжатия сетевого трафика решило проблему. Похоже проц действительно не справлялся с сжатием данных "на лету", хотя cpu xeon 5160. Будем ждать модернизации сервера.
 

Мыш

Well-Known Member
Lotus team
12.02.2008
1 084
13
#7
Еще: насколько я помню, включение LZ1 желательно включать везде - в ящиках пользователей, в mail.box на всех серверах, участвующих в обмене...