Внешняя Обработка

Тема в разделе "1C и всё что с ней связано", создана пользователем rpaM, 1 авг 2012.

  1. rpaM

    rpaM Гость

    добрый день!
    Очень нужна помощь.В 1с8.2 есть справочник контрагенты.Необходимо в наименовании убрать ковычки и ООО,ОАО, и т.д.убрать в конец.не получается
    Код внеш.обр.
    Запрос = Новый
    Запрос;
    Запрос.Текст=
    "Выбрать*
    |из Справочник.Контрагенты //ищу справочник,не группу
    |ГДЕ
    |не этоГруппа";
    Выб=Запрос.Выполнить().Выбрать();
    Пока Выб.Следующий()Цикл
    Об_спр=Выб.Ссылка.ПолучитьОбъект();
    a=Об_спр.Наименование;
    //далее не уверен в написанном
    Если Об_спр.Наименование="" тогда
    Результат = СтрЗаменить(Об_спр.Наименование, "//здесь находим нужный символ", "//найден.символ меняем на тут");
    //Функцию перемещения в конец строки не нашел((
    КонецЕсли;
    Об_спр.Записать();
    КонецЦикла

    Только прошу не гнать,код в 1с пишу впервые.
     
  2. Allexei

    Allexei Well-Known Member

    Регистрация:
    2 май 2008
    Сообщения:
    322
    Симпатии:
    0
    Кури
    Код ( (Unknown Language)):
     Запрос = Новый Запрос("ВЫБРАТЬ
    |   Контрагенты.Ссылка
    |ИЗ
    |   Справочник.Контрагенты КАК Контрагенты
    |ГДЕ
    |   Контрагенты.ЭтоГруппа = ЛОЖЬ");

    Выборка = Запрос.Выполнить().Выбрать();

    Пока Выборка.Следующий() Цикл

    Контрагент                     = Выборка.Ссылка.ПолучитьОбъект();

    Контрагент.Наименование= СтрЗаменить(Контрагент.Комментарий, """", "");
    Контрагент.Наименование= СтрЗаменить(Контрагент.Комментарий, "«", "");
    Контрагент.Наименование= СтрЗаменить(Контрагент.Комментарий, "»", "");

    Если НЕ Найти(Контрагент.Наименование, "ООО") = 0 Тогда
    Контрагент.Наименование = СтрЗаменить(Контрагент.Комментарий, "ООО", "");
    Контрагент.Наименование = Контрагент.Наименование + " ООО";
    КонецЕсли;
    Контрагент.Записать();
    КонецЦикла;
    Код не совсем феншуйный, но принцип работы будет понятен
     
  3. rpaM

    rpaM Гость

    спасибо.
    Вечером сам разобрался,код примерно такой же написал.С некоторыми нюансами.СпС
     
Загрузка...

Поделиться этой страницей