Вопрос по документу и справочнику

  • Автор темы Natalya200
  • Дата начала
Статус
Закрыто для дальнейших ответов.
N

Natalya200

#1
1C:Предприятие v8. Есть документ1. На его форме заполняются несколько полей: название дисциплины, группа, экзамен. Так вот нужно следующее: когда документ заполнила. нажимаю на кнопку и все данные должны сохраниться в справочник. Ума не приложу как это сделать. Помогоите!Заранее спасибо огромное)))
 

unknown181538

НеГуру
28.12.2008
1 417
0
#2
:)
В обработке проведения создавайте элемент и записвайте.
Но задача сомнительная, тем более в 8-ке.
 
N

Natalya200

#3
Спасибо)))Есть еще один вопрос. есть сравочник, гед указаны названия дисциплин и их реквизиты. Есть документ, где на форме в табличной части я выбираю азвание дисциплины и в пля должны автоматически загрузиться их реквизиты. Если можно, помогите. Срочно надо.Я можно сказать в беде(((
 

evgenyatam

Well-known member
07.09.2007
175
0
#4
это смотря чего хочется - если просто увидеть - можно перехватить ПриВыводеСтроки:

Процедура ЖурналДокументовСписокПриВыводеСтроки(Элемент, ОформлениеСтроки, ДанныеСтроки)
Если ТипЗнч(ДанныеСтроки.Ссылка) = Тип("ДокументССылка.СЦ_КвитанцияНаТелефон") Тогда
ОформлениеСтроки.Ячейки.Оборудование.Текст ="Сот. телефон";
ОформлениеСтроки.Ячейки.Модель.Текст = Строка(ДанныеСтроки.Модель.Родитель)+" "+Строка(ДанныеСтроки.Модель);
КонецЕсли;
КонецПроцедуры


а если это начальное заполнение значениями по умолчанию (пользователь потом может поменять) то вот так:

Процедура ЗаказчикиКонфигурацияПриИзменении(Элемент)
Стр=ЭлементыФормы.Заказчики.ТекущиеДанные; // получаем текущюю строку табличной части
Если Стр.Заказчик.Пустая() тогда
Стр.Заказчик = Стр.Конфигурация.Владелец;
КонецЕсли;
КонецПроцедуры
 
N

Natalya200

#5
Спасибо огромное, evgenyatam, очень выручили)))
 

vitfil

IT-интегратор
02.04.2004
2 062
0
#6
Natalya200
А слезную историю про беду когда услышим? Подсказываю, например, можно рассказать, как целыми днями бабушек через дорогу переводила, поэтому времени на учебу не было...
 
Статус
Закрыто для дальнейших ответов.