Вопрос по документу и справочнику

Тема в разделе "1C и всё что с ней связано", создана пользователем Natalya200, 13 мар 2010.

Статус темы:
Закрыта.
  1. Natalya200

    Natalya200 Гость

    1C:Предприятие v8. Есть документ1. На его форме заполняются несколько полей: название дисциплины, группа, экзамен. Так вот нужно следующее: когда документ заполнила. нажимаю на кнопку и все данные должны сохраниться в справочник. Ума не приложу как это сделать. Помогоите!Заранее спасибо огромное)))
     
  2. unknown181538

    unknown181538 НеГуру
    1C Team

    Регистрация:
    28 дек 2008
    Сообщения:
    1.418
    Симпатии:
    0
    :)
    В обработке проведения создавайте элемент и записвайте.
    Но задача сомнительная, тем более в 8-ке.
     
  3. Natalya200

    Natalya200 Гость

    Спасибо)))Есть еще один вопрос. есть сравочник, гед указаны названия дисциплин и их реквизиты. Есть документ, где на форме в табличной части я выбираю азвание дисциплины и в пля должны автоматически загрузиться их реквизиты. Если можно, помогите. Срочно надо.Я можно сказать в беде(((
     
  4. evgenyatam

    evgenyatam Well-Known Member

    Регистрация:
    7 сен 2007
    Сообщения:
    175
    Симпатии:
    0
    это смотря чего хочется - если просто увидеть - можно перехватить ПриВыводеСтроки:

    Процедура ЖурналДокументовСписокПриВыводеСтроки(Элемент, ОформлениеСтроки, ДанныеСтроки)
    Если ТипЗнч(ДанныеСтроки.Ссылка) = Тип("ДокументССылка.СЦ_КвитанцияНаТелефон") Тогда
    ОформлениеСтроки.Ячейки.Оборудование.Текст ="Сот. телефон";
    ОформлениеСтроки.Ячейки.Модель.Текст = Строка(ДанныеСтроки.Модель.Родитель)+" "+Строка(ДанныеСтроки.Модель);
    КонецЕсли;
    КонецПроцедуры


    а если это начальное заполнение значениями по умолчанию (пользователь потом может поменять) то вот так:

    Процедура ЗаказчикиКонфигурацияПриИзменении(Элемент)
    Стр=ЭлементыФормы.Заказчики.ТекущиеДанные; // получаем текущюю строку табличной части
    Если Стр.Заказчик.Пустая() тогда
    Стр.Заказчик = Стр.Конфигурация.Владелец;
    КонецЕсли;
    КонецПроцедуры
     
  5. Natalya200

    Natalya200 Гость

    Спасибо огромное, evgenyatam, очень выручили)))
     
  6. vitfil

    vitfil IT-интегратор

    Регистрация:
    2 апр 2004
    Сообщения:
    2.070
    Симпатии:
    0
    Natalya200
    А слезную историю про беду когда услышим? Подсказываю, например, можно рассказать, как целыми днями бабушек через дорогу переводила, поэтому времени на учебу не было...
     
Загрузка...
Похожие Темы - Вопрос по документу
  1. ApplePen
    Ответов:
    0
    Просмотров:
    80
  2. gURaBA_N
    Ответов:
    3
    Просмотров:
    98
  3. kartaman
    Ответов:
    0
    Просмотров:
    128
  4. Peter
    Ответов:
    4
    Просмотров:
    527
  5. di0d_
    Ответов:
    1
    Просмотров:
    442
Статус темы:
Закрыта.

Поделиться этой страницей