Вопрос по форме справочника

Tamchik

Active Member
10.03.2010
27
0
#1
Привет Всем!!
Помогите пожалуйста разобраться.
Как програмно реализовать условие. Дан справочник "Номенклатура" с реквизитами в форме справочника "Тип расчета"(связан с Перечислением Типы Расчета со значениями Задается и Рассчитывается), "ЦенаПродажи", "ПроцентНаценки". Надо сделать так чтобы при выборе в реквизите справочника ТипРасчета значения "Задается" поле ввода реквизита справочника "ПроцентНаценки" становилось недоступным.
 

vbs

Well-Known Member
18.02.2007
1 708
3
#2
Если ТипРасчета = Перечисление.ТипыРасчета.Задается Тогда
Форма.ПроцентНаценки.Доступность(0)
КонецЕсли
 

Tamchik

Active Member
10.03.2010
27
0
#3
Да в том то и дело что ввожу код


Процедура СправочникСписокТипРасчетаПриИзменении(Элемент)
// Вставить содержимое обработчика
РеквизитФормыСправочника = ЭлементыФормы.СправочникСписок.ТекущиеДанные;
Если РеквизитФормыСправочника.ТипРасчета = Перечисления.ТипРасчета.Задается Тогда
РеквизитФормыСправочника.ПроцентНаценки.Доступность(0)
КонецЕсли
КонецПроцедуры

А когда открываю справочник в режиме отладки выдает ошибку:

Значение не является значением объектного типа (Доступность)

:)
 

vbs

Well-Known Member
18.02.2007
1 708
3
#4
Ну так написала бы, что в 8ке работаешь, я для 7.7 пример написал :)
 

Дайнеко

Well-Known Member
19.11.2009
951
0
#5
Эк тебя на семерке заклинило (как и меня). Надо:
РеквизитФормыСправочника.ПроцентНаценки.Доступность = Ложь;
 

Tamchik

Active Member
10.03.2010
27
0
#6
Ну так написала бы, что в 8ке работаешь, я для 7.7 пример написал :whoareyou?:
Да и на том спаибо)) буду разбираться

Добавлено:
Эк тебя на семерке заклинило (как и меня). Надо:
РеквизитФормыСправочника.ПроцентНаценки.Доступность = Ложь;
да и с этим кодом ошибку выдает "Значение не является значением объектного типа (Доступность)"
 

evgenyatam

Well-Known Member
07.09.2007
175
0
#8
РеквизитФормыСправочника.ПроцентНаценки.Доступность = Ложь;
неверно.
верно только для семерки
для восьмерки : ЭлементыФормы.ПроцентНаценки.Доступность = Ложь;
а точнее в вашем случае ЭлементыФормы.СправочникСписок.ПроцентНаценки.Доступность = Ложь;
собственно ТекущиеДанные возвращает ссылку на элемент справочника, а он не визуальный.
 

Tamchik

Active Member
10.03.2010
27
0
#10
неверно.

верно только для семерки
для восьмерки : ЭлементыФормы.ПроцентНаценки.Доступность = Ложь;
а точнее в вашем случае ЭлементыФормы.СправочникСписок.ПроцентНаценки.Доступность = Ложь;
собственно ТекущиеДанные возвращает ссылку на элемент справочника, а он не визуальный.
Спасибо канешь за подсказки, но что то не выходит
Процедура СправочникСписокТипРасчетаПриИзменении(Элемент)
// Вставить содержимое обработчика
РеквизитФормыСправочника = ЭлементыФормы.СправочникСписок.ТекущиеДанные;
Если РеквизитФормыСправочника.ТипРасчета = Перечисления.ТипРасчета.Задается Тогда
ЭлементыФормы.СправочникСписок.ПроцентНаценки.Доступность = Ложь;
КонецЕсли
КонецПроцедуры

Все равно выдает ошибку и поле ПроцентНаценки все равно доступно для редактирования
 

unknown181538

НеГуру
28.12.2008
1 417
0
#11
ЭлементыФормы.СправочникСписок.ТекущаяСтрока.ПроцентНаценки.Доступность = Ложь; ?
 
W

WildAnther

Гость
#12
ЭлементыФормы.СправочникСписок.ТекущаяСтрока.ПроцентНаценки.РедактированиеТекста = Ложь; Может просто редактирование текста попробовать отрубить?
Может у вас условие не проходит?
 

tanat

Well-Known Member
02.03.2007
265
0
#13
дак может всетаки видимость у колонки нужно поменять, а не у реквизита?)
Попробуйте: ЭлементыФормы.СправочникСписок.Колонка.имяКолонки.Видимость=Ложь;
 
W

WildAnther

Гость
#14
А я думал реквизит надо заблокировать=)
 

tanat

Well-Known Member
02.03.2007
265
0
#15
Ну доступность). Разницы в синтаксе - минимум). А на отдельную ячейку таблицы помоему накладывать ограничения доступности нельзя ( по крайней мере как на элементы формы) .

Вообще автор виноват сам: ввел людёф в заблуждение, ибо не понимает разницу между формой элемента и формой справочника.
Для формы справочника можно изменить доступность у всей колонки но никак не у отдельной ячейки таблицы, а вот в форме элемента всеми реквизитами нетабличных частей играйте как можете. Вроде нигде ничего не напутал).
 

Tamchik

Active Member
10.03.2010
27
0
#16
Для формы справочника можно изменить доступность у всей колонки но никак не у отдельной ячейки таблицы, а вот в форме элемента всеми реквизитами нетабличных частей играйте как можете. Вроде нигде ничего не напутал).
Спасибо большое))) а то я сижу с этой ячейкой и думаю почему ничего не получается, а тут вся колонка , теперь буду знать))


Еще раз всем БОЛЬШОЕ СПАСИБО))