Выбор Движков 8.х

  • Автор темы MVGROB
  • Дата начала
M

MVGROB

#1
Сел переписывать с 77 на 81. С языком и структурой разобрался. Но пугает вот что:
Открываю конфигуратор (чистая база) говорю загрузить конфигурацию, а он мне "структура конфигурации не совместима с текущей версией программы"....
Что за...? В 77 движку все равно, какую конфу в него грузить.
В 81 я так понял, нет. Значит ли это я сейчас навояю конфу, а потом не смогу движок обновить?
Или у меня версия, какая то левая. Взял наугад 8.1 8.1.9.57.
Помогите плиз советом.
 

Zab

Well-known member
07.08.2006
583
0
#2
Та нивопрос: восьмерка с каждым релизом платформы меняет и формат конфиги. Более новые платформы могут открыть конфиги нескольких более старых. Если разарабатывать конфиг под совсем старым релизом, то, чтобы потом сконвертить его под последний, возможно, придется поставить по порядку несколько релизов платформы и сконвертить конфиг последовательно. Обратной совместимости нет. Инфа про то, какие релизы конфигов какими платформами читаются есть где-то в каталоге с бинарниками восьмерки, ищи.

Вывод: движок надо выбирать как можно более свежий. Инфа про новые движки выкладывается 1С на сайте.