выбор в запросе нулевых остатков

  • Автор темы LEVENTENOK
  • Дата начала
Статус
Закрыто для дальнейших ответов.
L

LEVENTENOK

Гость
#1
есть список значений СПС с товарами.
нужно выбрать только те, у которых остаток <=0

пишу запрос:

Запрос1 = СоздатьОбъект("Запрос");
ТекстЗапроса1 =
"//{{ЗАПРОС(Сформировать)
|Период с ВыбДата по ВыбДата;
|Товар = Регистр.ОстаткиТоваров.Товар;
|ОстатокТовара = Регистр.ОстаткиТоваров.ОстатокТовара;
|Функция КвоКонОст = КонОст(ОстатокТовара);
|Условие (Товар в СПС);
|Группировка Товар без групп;";

Запрос1.Выполнить(ТекстЗапроса1);
Пока Запрос1.Группировка(1)=1 Цикл
Если Запрос1.КвоКонОст<=0 Тода
Сообщить(Запрос1.ОстатокТовара);
КонецЕсли;
КонецЦикла;

не сообщает ничего, хотя некоторые товары, находящиеся в СПС имеют нулевые остатки 100%

значит, по ним нет записей в регистрах? что делать?
 

puh14

Well-Known Member
11.07.2008
1 412
0
#2
с коност я тебе наврал - он выдается не на документ регистратор а на конец периода в запросе и регистратора там нет. Выложил примерный алгоритм в предыддущей ветке.
 
K

kaa

Гость
#3
Запрос1 = СоздатьОбъект("Запрос");
ТекстЗапроса1 =
"//{{ЗАПРОС(Сформировать)
|Период с ВыбДата по ВыбДата;
|Товар = Регистр.ОстаткиТоваров.Товар;
|ОстатокТовара = Регистр.ОстаткиТоваров.ОстатокТовара;
|Функция КвоКонОст = КонОст(ОстатокТовара);
|Условие (Товар в СПС);
|Группировка Товар без групп все ВошедшиеВЗапрос;";

Запрос1.Выполнить(ТекстЗапроса1);
Пока Запрос1.Группировка(1)=1 Цикл
Если Запрос1.КвоКонОст<=0 Тода
Сообщить(Запрос1.ОстатокТовара);
КонецЕсли;
КонецЦикла;
 
L

LEVENTENOK

Гость
#4
ВошедшиеВЗапрос -- Необязательное добавочное ключевое слово действие которого уточняет предыдущее ключевое слово «Все». Использование дан­ного слова подразумевает, что в каждую строку запроса будут включены значения данных (в том числе нулевые), для которых есть ненулевое значение хотя бы в одной строке запроса. А если нет?
 
Статус
Закрыто для дальнейших ответов.