Выборка документов

Тема в разделе "1C и всё что с ней связано", создана пользователем kentochek, 20 мар 2007.

Статус темы:
Закрыта.
  1. kentochek

    kentochek Гость

    Здравствуйте у меня такой вопрос, как мне сделать выборку документов по определенному контрагенту,т.е. другими словами, мы выбираем определенного контрагента, затем мы выбираем документ, и нужно чтобы при выборе документа отображались только те, которые в реквизите имеют точно такого же контрагента,другие из этого же журнала выводить не надо.Мой код имеет следующий вид, и он выводит все документы...

    Док=СоздатьОбъект("Документ.ПередачаИмВЗалог");
    Док.ВыбратьДокументы(); //***Делаем выборку документов
    Пока Док.ПолучитьДокумент()=1 Цикл
    ///***Выбираем только документы,у которых контрагент такой же как и в "Кредитном договоре"
    Если Док.Контрагент=Контрагент Тогда
    Если Док.Выбран()=1 Тогда
    Док.ВыбратьСтроки(); //***Делаем выборку табличной части документа
    Пока Док.ПолучитьСтроку()=1 Цикл
    //***Заносим значения в определенные поля
    Сумма=Док.Сумма;
    ДатаДог=ДатаДок;
    СуммаКредита=Сумма;
    КонецЦикла
    КонецЕсли;
    Иначе
    Сообщить("Нет подходящих документов для данного контрагента!");
    КонецЕсли;
    КонецЦикла;

    За ранее спасибо...
     
  2. vitfil

    vitfil IT-интегратор

    Регистрация:
    2 апр 2004
    Сообщения:
    2.070
    Симпатии:
    0
    Лучше всего будет сделать запросом.
     
  3. kentochek

    kentochek Гость

    А каким образом после запроса, привязать полученные данные к таблице на форме,точнее к ее определенному полю (в данном случае поле называется "Документ залога", который мы будем выбирать)?
     
  4. vitfil

    vitfil IT-интегратор

    Регистрация:
    2 апр 2004
    Сообщения:
    2.070
    Симпатии:
    0
    Интересный вопрос...
    Опять же настоятельно рекомендую все же почитать книги по программированию в 1С.
     
  5. kentochek

    kentochek Гость

    Эти книги сейчас передо мной лежат открытые, но в них конкретных примеров нет,есть типовые...Вы бы не могли привести хотя бы, какой-нибудь пример запроса, подходящий для моего случая,если вам не сложно...
     
  6. vitfil

    vitfil IT-интегратор

    Регистрация:
    2 апр 2004
    Сообщения:
    2.070
    Симпатии:
    0
    В книгах как раз есть примеры запросов по документам.
     
  7. kentochek

    kentochek Гость

    Ок, щас посмотрю....Дак а как связать результат запроса с колонкой? :)
     
  8. vitfil

    vitfil IT-интегратор

    Регистрация:
    2 апр 2004
    Сообщения:
    2.070
    Симпатии:
    0
    в цикле пройтись по результатам запроса и в соответствующие строки соответствующей колонки записать нужные данные.
     
  9. kentochek

    kentochek Гость

    А с помощью какого метода можно обращаться к колонкам из реквизитов табличной части документа?
     
  10. vitfil

    vitfil IT-интегратор

    Регистрация:
    2 апр 2004
    Сообщения:
    2.070
    Симпатии:
    0
    Например, реквизит табличной части "Номенклатура".
    Номенклатура = ...
     
  11. kentochek

    kentochek Гость

    Понял..спасибо :)
     
Загрузка...
Статус темы:
Закрыта.

Поделиться этой страницей