Выборка документов

  • Автор темы kentochek
  • Дата начала
Статус
Закрыто для дальнейших ответов.
K

kentochek

#1
Здравствуйте у меня такой вопрос, как мне сделать выборку документов по определенному контрагенту,т.е. другими словами, мы выбираем определенного контрагента, затем мы выбираем документ, и нужно чтобы при выборе документа отображались только те, которые в реквизите имеют точно такого же контрагента,другие из этого же журнала выводить не надо.Мой код имеет следующий вид, и он выводит все документы...

Док=СоздатьОбъект("Документ.ПередачаИмВЗалог");
Док.ВыбратьДокументы(); //***Делаем выборку документов
Пока Док.ПолучитьДокумент()=1 Цикл
///***Выбираем только документы,у которых контрагент такой же как и в "Кредитном договоре"
Если Док.Контрагент=Контрагент Тогда
Если Док.Выбран()=1 Тогда
Док.ВыбратьСтроки(); //***Делаем выборку табличной части документа
Пока Док.ПолучитьСтроку()=1 Цикл
//***Заносим значения в определенные поля
Сумма=Док.Сумма;
ДатаДог=ДатаДок;
СуммаКредита=Сумма;
КонецЦикла
КонецЕсли;
Иначе
Сообщить("Нет подходящих документов для данного контрагента!");
КонецЕсли;
КонецЦикла;

За ранее спасибо...
 
K

kentochek

#3
А каким образом после запроса, привязать полученные данные к таблице на форме,точнее к ее определенному полю (в данном случае поле называется "Документ залога", который мы будем выбирать)?
 

vitfil

IT-интегратор
02.04.2004
2 062
0
#4
Интересный вопрос...
Опять же настоятельно рекомендую все же почитать книги по программированию в 1С.
 
K

kentochek

#5
Эти книги сейчас передо мной лежат открытые, но в них конкретных примеров нет,есть типовые...Вы бы не могли привести хотя бы, какой-нибудь пример запроса, подходящий для моего случая,если вам не сложно...
 

vitfil

IT-интегратор
02.04.2004
2 062
0
#6
В книгах как раз есть примеры запросов по документам.
 
K

kentochek

#7
Ок, щас посмотрю....Дак а как связать результат запроса с колонкой? :)
 

vitfil

IT-интегратор
02.04.2004
2 062
0
#8
в цикле пройтись по результатам запроса и в соответствующие строки соответствующей колонки записать нужные данные.
 
K

kentochek

#9
А с помощью какого метода можно обращаться к колонкам из реквизитов табличной части документа?
 

vitfil

IT-интегратор
02.04.2004
2 062
0
#10
Например, реквизит табличной части "Номенклатура".
Номенклатура = ...
 
Статус
Закрыто для дальнейших ответов.