Выбрать из регистра сведений в справочник

  • Автор темы Guest
  • Дата начала
Статус
Закрыто для дальнейших ответов.
G

Guest

#1
Здравствуйте... подскажите пожалуйста....

Из Справочника Номенклатура по кнопке открывается форма списка Регистр сведений ЦеныПоставщика
Как сделать так чтоб при выборе в этой форме цена обновлялась в справочнике Номенклатура в поле ввода ЦенаПокупки?
 

tanat

Well-known member
02.03.2007
265
0
#2
По какой кнопке? - 1)
Какая конфигурация? - 2)
 

tanat

Well-known member
02.03.2007
265
0
#4
Ну тогда пойдем по порядку. Процедуру в студию.
Если форму выбора цены открываете модально - тогда можно при закрытии формы передавать любое значение.
 
G

Guest

#5
Ну тогда пойдем по порядку. Процедуру в студию.
Если форму выбора цены открываете модально - тогда можно при закрытии формы передавать любое значение.
Вот так открываю форму:

Процедура ОбновлениеЗакупочнойЦеныНажатие(Элемент)

Форма = РегистрыСведений.ЦеныПоставщиков.ПолучитьФормуСписка(,ЭтаФорма,);
Форма.РегистрСведенийСписок.Отбор.Номенклатура.Значение=Ссылка;
Форма.РегистрСведенийСписок.Отбор.Номенклатура.Использование= Истина;
Форма.ЗакрыватьПриЗакрытииВладельца=Истина;

Если Не Форма.Открыта() Тогда
Форма.РазрешитьСостояниеПрячущееся=Истина;
Форма.РазрешитьСостояниеПрикрепленное=Истина;
Форма.РазрешитьСоединятьОкно=Истина;
КонецЕсли;
Форма.Открыть();

КонецПроцедуры



Добавлено:
Вот так открываю форму:

Процедура ОбновлениеЗакупочнойЦеныНажатие(Элемент)

Форма = РегистрыСведений.ЦеныПоставщиков.ПолучитьФормуСписка(,ЭтаФорма,);
Форма.РегистрСведенийСписок.Отбор.Номенклатура.Значение=Ссылка;
Форма.РегистрСведенийСписок.Отбор.Номенклатура.Использование= Истина;
Форма.ЗакрыватьПриЗакрытииВладельца=Истина;

Если Не Форма.Открыта() Тогда
Форма.РазрешитьСостояниеПрячущееся=Истина;
Форма.РазрешитьСостояниеПрикрепленное=Истина;
Форма.РазрешитьСоединятьОкно=Истина;
КонецЕсли;
Форма.Открыть();

КонецПроцедуры
сейчас нашла вот такую статью: http://pro1c.org.ua/lofiversion/index.php?t276.html
Но по ней ничего не получается... почему то...
 
Статус
Закрыто для дальнейших ответов.