ВыбратьКорсчета возвращает 0

  • Автор темы Teklbery
  • Дата начала
Статус
Закрыто для дальнейших ответов.
T

Teklbery

Гость
#1
Задача состоит в следующем: необходимо выбрать все перемещения ОС за период и обязательно откуда и куда ниже рабочий код
БухИт = СоздатьОбъект("БухгалтерскиеИтоги");
БухИт.ИспользоватьСубконто(ВидыСубконто.ОсновныеСредства);
БухИт.ИспользоватьСубконто(ВидыСубконто.местахранения);
БухИт.ИспользоватьКорСубконто(ВидыСубконто.местахранения,,,);БухИт.ВключатьСубсч
ета(1,1);
БухИт.ВыполнитьЗапрос(НачДата,КонДата,"01,02","01,02",,,2,5);
БухИт.ВыбратьПериоды(1,,,1);
Пока БухИт.ПолучитьПериод() = 1 Цикл
БухИт.ВыбратьСубконто();
Пока БухИт.ПолучитьСубконто() = 1 Цикл
ОС = БухИт.Субконто(1);
Сч01 = ОС.СчетОС;
Сч02 = ОС.СчетИзносаОС;
СчетНачисленияАмортизации = Сч02;
место1 = БухИт.Субконто(2);
БухИт.ВыбратьКорСубконто();
Пока БухИт.ПолучитьКорСубконто() = 1 цикл
Место2 = БухИт.Корсубконто();
КонецЦикла;
наименование = БухИт.Субконто();
БалансоваяСтоимость = ?(БухИт.ПолучитьСчет(,Сч01)=1, БухИт.ДО(), 0);
ИзносНаНачалоМесяца = ?(БухИт.ПолучитьСчет(,Сч02)=1, БухИт.КО(), 0);
ОстаточнаяСтоимость = БалансоваяСтоимость - ИзносНаНачалоМесяца;
КонецЦикла;
КонецЦикла;

Все выдает правильно за исключением корсубконто, БухИт.ВыбратьКорСубконто() возвращает ноль и поэтому не попадает в цикл
 
D

Demetry2000

Гость
#2
Хмм, первый раз вижу Суб "МестаХранения" на 01,02.
Они точно у тебя есть ?
И еще если у тебя на кредит идут счета 01,02 , значит ты увидишь только выбывшие ОС.

01.2/01.1 Выбытие ОС.
02.1 /01.2списание Арм.

Или я вооще нече не понял :)
 
Статус
Закрыто для дальнейших ответов.