Выделение цветом

Тема в разделе "1C и всё что с ней связано", создана пользователем GreyMen, 2 мар 2007.

Статус темы:
Закрыта.
  1. GreyMen

    GreyMen Гость

    Подскажите, если кто знает, можно ли как то выделить цветом во многострочной части документа столбцы и строки
     
  2. vitfil

    vitfil IT-интегратор

    Регистрация:
    2 апр 2004
    Сообщения:
    2.070
    Симпатии:
    0
    Можно.
    FormEx.dll
     
  3. GreyMen

    GreyMen Гость

    vitfil, ты уж прости, но я еще не опытный в 1с, поэтому спрашиваю, как использовать эту FormEx.dll
     
  4. vitfil

    vitfil IT-интегратор

    Регистрация:
    2 апр 2004
    Сообщения:
    2.070
    Симпатии:
    0
    в документации к ней есть примеры.
     
  5. GreyMen

    GreyMen Гость

    в общем то подключить FormEx я сумел, но вот раскрасить многострочную часть не получается, ну вот никак, писал в строке формулы BRUSH [1] и с ковычками и со скобочками и без ничего и как только не писал, все равно ошибки. подскажите как правильно написать команду? или мож у кого примерчик есть по раскраске многостр. части дока?
     
  6. jj_mail

    jj_mail Гость

    в глобальном модуле пишешь например так :

    Функция ПолучитьЦвет(Красный = 0,Зеленый = 0,Синий = 0) Экспорт
    // функция для формирования значения цвета из составляющих (RGB)
    Возврат Макс(0,Синий)*65536 + Макс(0,Зеленый)*256 + Макс(0,Красный);

    КонецФункции


    Использование :

    Т = СоздатьОбъект("ТаблицаЗначений");
    Т.НоваяКолонка("ЦветСтр","Строка");
    Т.ВидимостьКолонки("ЦветСтр",0);

    Т.ЦветСтр = "BRUSH["+ ПолучитьЦвет(255,100,100)+"]";
     
  7. GreyMen

    GreyMen Гость

    попробовал, в глоб. модуле написал все как посоветовали, в процедуре ПриОткрытии оформил следующим образом:

    Процедура ПриОткрытии()
    Сервис = СоздатьОбъект("Сервис");
    Сервис.ВключитьРаскраскуТаблиц();
    ПриЗаписиПерепроводить(1);
    Кр = "BRUSH["+ ПолучитьЦвет(115,50,41)+"]";
    КонецПроцедуры

    Кр - колонка ТЧ

    И всеравно не красит ничего. Подскажите что я не так делаю, может есть у кого нибудь примерчик попобробнее?
    Мне в принципе от ФормЕкс нужна только возможность раскраски строк и столбцов в тч дока, и никак не могу воткнуть как она работает
     
  8. jj_mail

    jj_mail Гость

    а нет желания использовать 1CPP.DLL ? там все как-то проще..... (и функций больше)
    Никаких СоздатьОбъект там писать не нужно. В параметрах включил раскраску и вперед
    Если есть желание, могу подкинуть
     
  9. GreyMen

    GreyMen Гость

    конечно хочу! скинь мне на мыло Greymen@mail.ru
    и если не сложно то документацию какую нибудь к ней и примерчики.
    Заранее благодарен
     
  10. LSH

    LSH Гость

    Для: jj_mail

    В 1С++ включено ядро компоненты FormEx. Минус - приходится таскать с собой 1,5 Мб библиотеку, грузится дольше чем ФормЕКС, да и зачем тянуть библиотеку, если 95% ее функций использоваться не будет? Плюс еще там ядро обновляется довольно редко, а Формекс - часто.

    <!--QuoteBegin-GreyMen+6:03:2007, 09:15 -->
    <span class="vbquote">(GreyMen @ 6:03:2007, 09:15 )</span><!--QuoteEBegin-->попробовал, в глоб. модуле написал все как посоветовали, в процедуре ПриОткрытии оформил следующим образом:

    Процедура ПриОткрытии()
    Сервис = СоздатьОбъект("Сервис");
    Сервис.ВключитьРаскраскуТаблиц();
    ПриЗаписиПерепроводить(1);
    Кр = "BRUSH["+ ПолучитьЦвет(115,50,41)+"]";
    КонецПроцедуры

    Кр - колонка ТЧ

    И всеравно не красит ничего. Подскажите что я не так делаю, может есть у кого нибудь примерчик попобробнее?
    Мне в принципе от ФормЕкс нужна только возможность раскраски строк и столбцов в тч дока, и никак не могу воткнуть как она работает
    [snapback]58313" rel="nofollow" target="_blank[/snapback]​
    [/quote]

    Там всё не так.
    Вешаем на табл. часть формы реквизит текст (кликнуть по тексту в панельке, кликнуть по форме), на нее вешаем функцию, например, Раскрас(), делаем этот реквизит невидимым.
    Далее, в глоб. модуле заводим переменную Сервис, а
    Процедура ПриНачалеРаботыСистемы()
    Попытка
    ЗагрузитьВнешнююКомпоненту("FormEX.DLL");
    Сервис = СоздатьОбъект("Сервис");
    Сервис.ВключитьРаскраскуТаблиц();
    Исключение
    Сообщить("Компонента недоступна");
    КонецПопытки;
    КонецПроцедуры

    В модуле:
    Функция Раскрас()
    Если [Какое_то_условие] Тогда
    Возврат "BRUSH["+ПолучитьЦвет(221,221,255)+"]"; //ну или какие-то другие цвета
    Иначе
    Возврат ""; //чтобы не раскрашивало
    КонецЕсли;
    КонецФункции

    <!--QuoteBegin-jj_mail+6:03:2007, 10:46 -->
    <span class="vbquote">(jj_mail @ 6:03:2007, 10:46 )</span><!--QuoteEBegin-->В параметрах включил раскраску и вперед
    [snapback]58323" rel="nofollow" target="_blank[/snapback]​
    [/quote]

    В формексе аналогично. В Предприятии Сервис-Параметры-FormEx
     
  11. GreyMen

    GreyMen Гость

    Благодарю, все получилось!!!!
     
Загрузка...
Статус темы:
Закрыта.

Поделиться этой страницей