Выгрузка Данных

20.02.2013
16
0
#1
Пожалуйста помогите!!!
Прислали вот такое задание:

"Выгрузка данных осуществляется пользователем путем нажатия на кнопку «Выгрузить» на панели обработки"

Навоял вот такой вот код:
Код:
Процедура ДействияФормыВыгрузить(Кнопка)
Режим = РежимДиалогаВыбораФайла.Сохранение;
Диалог = Новый ДиалогВыбораФайла(Режим);
Диалог.Заголовок = "Сохранение";
Диалог.Фильтр = "XML-файл (*.xml)|*.xml";
Если Диалог.Выбрать() Тогда
Запись = Новый ЗаписьXML;
Запись.ОткрытьФайл(Диалог.ПолноеИмяФайла);
Запись.ЗаписатьОбъявлениеXML();
Для Каждого Стр Из ЭлементыФормы.Данные.Значение Цикл


///как я понял здесь формируется XML код			


КонецЦикла;
Запись.ЗаписатьКонецЭлемента();
Запись.Закрыть();
КонецЕсли;
КонецПроцедуры

Итог: я не вижу в XML документе ничего кроме СЛОВО "СТРОКИ"
 
20.02.2013
16
0
#3
Думаю это уже второй вопрос!!
Для начала подскажите как мне туда вбить <?XML version="1.0"?> </xml>

Я новичек. просьба не выражаться громко) ну и не выражайтесь терминами плиз
 
20.02.2013
16
0
#4
Принцип выгрузки работает!
Единственное чего я понять немогу, это как мне вбить туда записи и куда их прописывать?Вот в чем вопрос собственно говоря.
Хотябы как вытащить из справочника список Банков и сформировать их в формате XMl
 

evgenyatam

Well-Known Member
07.09.2007
175
0
43
#5
Единственное чего я понять немогу, это как мне вбить туда записи и куда их прописывать?Вот в чем вопрос собственно говоря.

Смотри встроенную справку (синтаксис помошник).
 
20.02.2013
16
0
#6
Спасибо!! С синтаксисом разобрался!!
Есть первые строки.. Да и XML как положено теперь читается..


Вопрос, А как мне туда вбить данные от документа??