Выгрузка Данных

Тема в разделе "1C и всё что с ней связано", создана пользователем Peacedeath, 20 фев 2013.

  1. Peacedeath

    Peacedeath Member

    Регистрация:
    20 фев 2013
    Сообщения:
    16
    Симпатии:
    0
    Пожалуйста помогите!!!
    Прислали вот такое задание:

    "Выгрузка данных осуществляется пользователем путем нажатия на кнопку «Выгрузить» на панели обработки"

    Навоял вот такой вот код:
    Код ( (Unknown Language)):
    Процедура ДействияФормыВыгрузить(Кнопка)
    Режим = РежимДиалогаВыбораФайла.Сохранение;
    Диалог = Новый ДиалогВыбораФайла(Режим);
    Диалог.Заголовок = "Сохранение";
    Диалог.Фильтр = "XML-файл (*.xml)|*.xml";
    Если Диалог.Выбрать() Тогда
    Запись = Новый ЗаписьXML;
    Запись.ОткрытьФайл(Диалог.ПолноеИмяФайла);
    Запись.ЗаписатьОбъявлениеXML();
    Для Каждого Стр Из ЭлементыФормы.Данные.Значение Цикл


    ///как я понял здесь формируется XML код           


    КонецЦикла;
    Запись.ЗаписатьКонецЭлемента();
    Запись.Закрыть();
    КонецЕсли;
    КонецПроцедуры

    Итог: я не вижу в XML документе ничего кроме СЛОВО "СТРОКИ"
     
  2. unknown181538

    unknown181538 НеГуру
    1C Team

    Регистрация:
    28 дек 2008
    Сообщения:
    1.418
    Симпатии:
    0
    Так вы туда записываете что-нибудь, кроме объявления хмл?
     
  3. Peacedeath

    Peacedeath Member

    Регистрация:
    20 фев 2013
    Сообщения:
    16
    Симпатии:
    0
    Думаю это уже второй вопрос!!
    Для начала подскажите как мне туда вбить <?XML version="1.0"?> </xml>

    Я новичек. просьба не выражаться громко) ну и не выражайтесь терминами плиз
     
  4. Peacedeath

    Peacedeath Member

    Регистрация:
    20 фев 2013
    Сообщения:
    16
    Симпатии:
    0
    Принцип выгрузки работает!
    Единственное чего я понять немогу, это как мне вбить туда записи и куда их прописывать?Вот в чем вопрос собственно говоря.
    Хотябы как вытащить из справочника список Банков и сформировать их в формате XMl
     
  5. evgenyatam

    evgenyatam Well-Known Member

    Регистрация:
    7 сен 2007
    Сообщения:
    175
    Симпатии:
    0
    Единственное чего я понять немогу, это как мне вбить туда записи и куда их прописывать?Вот в чем вопрос собственно говоря.

    Смотри встроенную справку (синтаксис помошник).
     
  6. Peacedeath

    Peacedeath Member

    Регистрация:
    20 фев 2013
    Сообщения:
    16
    Симпатии:
    0
    Спасибо!! С синтаксисом разобрался!!
    Есть первые строки.. Да и XML как положено теперь читается..


    Вопрос, А как мне туда вбить данные от документа??
     
  7. Allexei

    Allexei Well-Known Member

    Регистрация:
    2 май 2008
    Сообщения:
    322
    Симпатии:
    0
    Есть замечательна книженция по технологии интеграции 1С. Вот ссылочка
    http://v8.1c.ru/metod/books/book.jsp?id=288
    Посмотрите там. Там доступно, на примерах описано как работать с ХМЛ.
     
  8. Peacedeath

    Peacedeath Member

    Регистрация:
    20 фев 2013
    Сообщения:
    16
    Симпатии:
    0
    Всё Всё понятно!! Большое спасибо!
    Тему не закрывать i'll be back)
     
Загрузка...

Поделиться этой страницей